aboutsummaryrefslogtreecommitdiffstats
path: root/packages/matchbox-wm
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-03-07 20:49:50 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-03-07 20:49:50 +0000
commit5b68dd3d1623c1f79f2c78939a1e4ef4283685b0 (patch)
tree8c02c813031f3378cf48c011534812dd1a593ca8 /packages/matchbox-wm
parent63b340ab1b9d487805564871b934e190dadcd6af (diff)
downloadopenembedded-5b68dd3d1623c1f79f2c78939a1e4ef4283685b0.tar.gz
matchbox-wm: add 1.0
Diffstat (limited to 'packages/matchbox-wm')
-rw-r--r--packages/matchbox-wm/matchbox-wm_1.0.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/matchbox-wm/matchbox-wm_1.0.bb b/packages/matchbox-wm/matchbox-wm_1.0.bb
new file mode 100644
index 0000000000..2270fccbce
--- /dev/null
+++ b/packages/matchbox-wm/matchbox-wm_1.0.bb
@@ -0,0 +1,33 @@
+SECTION = "x11/wm"
+DESCRIPTION = "Matchbox window manager"
+LICENSE = "GPL"
+DEPENDS = "libmatchbox libx11 libxext libxcomposite libxfixes libxdamage libxrender startup-notification expat gconf matchbox-common"
+RDEPENDS = "matchbox-common"
+PR="r0"
+
+
+SRC_URI = "http://projects.o-hand.com/matchbox/sources/matchbox-window-manager/1.0/matchbox-window-manager-${PV}.tar.gz \
+ file://kbdconfig"
+
+S = "${WORKDIR}/matchbox-window-manager-${PV}"
+
+inherit autotools pkgconfig update-alternatives
+
+FILES_${PN} = "${bindir} \
+ ${datadir}/matchbox \
+ ${sysconfdir}/matchbox \
+ ${datadir}/themes/blondie/matchbox \
+ ${datadir}/themes/Default/matchbox \
+ ${datadir}/themes/MBOpus/matchbox"
+
+ALTERNATIVE_NAME = "x-window-manager"
+ALTERNATIVE_LINK = "${bindir}/x-window-manager"
+ALTERNATIVE_PATH = "${bindir}/matchbox-session"
+ALTERNATIVE_PRIORITY = "10"
+
+EXTRA_OECONF = " --enable-startup-notification --disable-xrm"
+
+do_install_prepend() {
+ install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig
+}
+