aboutsummaryrefslogtreecommitdiffstats
path: root/packages/matchbox-wm
diff options
context:
space:
mode:
authorGreg Gilbert <greg@treke.net>2005-01-25 22:51:31 +0000
committerGreg Gilbert <greg@treke.net>2005-01-25 22:51:31 +0000
commit88e6a379cba87ab8c710b084fdc61ea3e4750d2f (patch)
tree3ff812d40da81d5ee1fb5326649396d1f916bede /packages/matchbox-wm
parent8ba79f8f234d8a6b7b4fdcdc3a8889d18929bda5 (diff)
downloadopenembedded-88e6a379cba87ab8c710b084fdc61ea3e4750d2f.tar.gz
Merge bk://oe-devel@oe-devel.bkbits.net/openembedded
into sql.brooks.edu:/home/ggilbert/oe/openembedded 2005/01/25 23:47:01+01:00 (none)!koen Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into lieve.(none):/data/build/oe/clean-tree/openembedded 2005/01/25 23:46:44+01:00 (none)!koen fix themes in matchbox-wm-0.9.2 BKrev: 41f6cd73SdV_h9IBJXvz6zPfrSWaHg
Diffstat (limited to 'packages/matchbox-wm')
-rw-r--r--packages/matchbox-wm/matchbox-wm_0.9.2.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/packages/matchbox-wm/matchbox-wm_0.9.2.bb b/packages/matchbox-wm/matchbox-wm_0.9.2.bb
index e69de29bb2..b552a4b344 100644
--- a/packages/matchbox-wm/matchbox-wm_0.9.2.bb
+++ b/packages/matchbox-wm/matchbox-wm_0.9.2.bb
@@ -0,0 +1,29 @@
+SECTION = "x11/wm"
+DESCRIPTION = "Matchbox window manager"
+LICENSE = "GPL"
+DEPENDS = "libmatchbox x11 xext xcomposite libxfixes xdamage libxrender startup-notification expat gconf matchbox-common"
+RDEPENDS = "matchbox-common"
+
+SRC_URI = "http://projects.o-hand.com/matchbox/sources/matchbox-window-manager/0.9/matchbox-window-manager-${PV}.tar.gz"
+
+S = "${WORKDIR}/matchbox-window-manager-${PV}"
+
+inherit autotools pkgconfig
+
+FILES_${PN} = "${bindir} \
+ ${datadir}/matchbox \
+ ${sysconfdir}/matchbox \
+ ${datadir}/themes/blondie/matchbox \
+ ${datadir}/themes/Default/matchbox \
+ ${datadir}/themes/MBOpus/matchbox"
+
+EXTRA_OECONF = "--enable-composite --enable-startup-notification --disable-xrm"
+
+pkg_postinst() {
+update-alternatives --install /usr/bin/x-window-manager x-window-manager /usr/bin/matchbox-session 10
+}
+
+pkg_postrm() {
+update-alternatives --remove x-window-manager /usr/bin/matchbox-session
+}
+