aboutsummaryrefslogtreecommitdiffstats
path: root/packages/matchbox2
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-06-16 10:16:40 +0000
committerKoen Kooi <koen@openembedded.org>2007-06-16 10:16:40 +0000
commit478903dd1bf027ff13ab64ad878ea96628852739 (patch)
tree3e5b8087035fe0f29593e8f1765aa97a84e98ad9 /packages/matchbox2
parentc3fb203dde42731406ca81d0fb21535545a7f8f1 (diff)
downloadopenembedded-478903dd1bf027ff13ab64ad878ea96628852739.tar.gz
matchbox-desktop-2: add matchbox-desktop-2
Diffstat (limited to 'packages/matchbox2')
-rw-r--r--packages/matchbox2/matchbox-desktop-2_svn.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/matchbox2/matchbox-desktop-2_svn.bb b/packages/matchbox2/matchbox-desktop-2_svn.bb
new file mode 100644
index 0000000000..31a6b9836d
--- /dev/null
+++ b/packages/matchbox2/matchbox-desktop-2_svn.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Matchbox Window Manager Desktop"
+LICENSE = "GPL"
+SECTION = "x11/panels"
+DEPENDS = "gtk+ startup-notification"
+
+PV = "0.1+svn${SRCDATE}"
+PR = "r0"
+
+SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http"
+S = "${WORKDIR}/${PN}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--enable-startup-notification --disable-libnotify"
+
+PARALLEL_MAKE = ""
+
+# matchbox-<anything>-2 aims to replace their -1 counterpart, but at this point in time it's unfinished and unusable, so make it parallel installable
+do_install_append() {
+ mv ${D}${bindir}/matchbox-desktop ${D}${bindir}/matchbox-desktop-2
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+