aboutsummaryrefslogtreecommitdiffstats
path: root/packages/matrixssl
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-10-12 09:19:31 +0000
committerMichael Lauer <mickey@vanille-media.de>2006-10-12 09:19:31 +0000
commit7b3360da2cf2096ba1b876f11814d6eb09e65d85 (patch)
tree8c2378f8b916a5b519462220426b4c87db52c83e /packages/matrixssl
parent67a391820a7b50eac89da4faa76ff60cc9c5aec9 (diff)
downloadopenembedded-7b3360da2cf2096ba1b876f11814d6eb09e65d85.tar.gz
matrixssl: remove 1.0-beta, refactor get_os function out into common .inc
Diffstat (limited to 'packages/matrixssl')
-rw-r--r--packages/matrixssl/matrixssl-1.0-beta/.mtn2git_empty0
-rw-r--r--packages/matrixssl/matrixssl-1.0-beta/cross.patch28
-rw-r--r--packages/matrixssl/matrixssl.inc5
-rw-r--r--packages/matrixssl/matrixssl_1.0-beta.bb18
-rw-r--r--packages/matrixssl/matrixssl_1.1.1.bb12
5 files changed, 10 insertions, 53 deletions
diff --git a/packages/matrixssl/matrixssl-1.0-beta/.mtn2git_empty b/packages/matrixssl/matrixssl-1.0-beta/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/matrixssl/matrixssl-1.0-beta/.mtn2git_empty
+++ /dev/null
diff --git a/packages/matrixssl/matrixssl-1.0-beta/cross.patch b/packages/matrixssl/matrixssl-1.0-beta/cross.patch
deleted file mode 100644
index b4c9634949..0000000000
--- a/packages/matrixssl/matrixssl-1.0-beta/cross.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- src/Makefile~cross 2004-03-01 19:12:37.000000000 -0500
-+++ src/Makefile 2004-06-04 21:59:55.527364588 -0400
-@@ -12,14 +12,14 @@
- #
- # Debug flags and C flags
- #
--DFLAGS = -O3
-+CFLAGS = -O3
- #
- # To build a debug version of the MatrixSSL library, uncomment the DFLAGS line
- # below and remove the strip command in the .so target below.
- #
--#DFLAGS = -g -DDEBUG
-+#CFLAGS = -g -DDEBUG
-
--CFLAGS = -DLINUX $(DFLAGS)
-+override CFLAGS += -DLINUX
- LDFLAGS = -Wl -lc -lpthread
-
- all: compile
-@@ -56,7 +56,6 @@
- #
- libmatrixssl.so: $(OBJECTS)
- $(CC) -shared -nostdlib -o $@ $^ $(LDFLAGS)
-- strip $(LIBRARIES)
-
- #
- # Clean up workspace
diff --git a/packages/matrixssl/matrixssl.inc b/packages/matrixssl/matrixssl.inc
new file mode 100644
index 0000000000..5f6bf43a9e
--- /dev/null
+++ b/packages/matrixssl/matrixssl.inc
@@ -0,0 +1,5 @@
+def define_os (d):
+ import bb
+ if bb.data.getVar('TARGET_OS', d).startswith('linux'):
+ return "-DLINUX"
+ return ""
diff --git a/packages/matrixssl/matrixssl_1.0-beta.bb b/packages/matrixssl/matrixssl_1.0-beta.bb
deleted file mode 100644
index 3dfd02448d..0000000000
--- a/packages/matrixssl/matrixssl_1.0-beta.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-SECTION = "unknown"
-SRC_URI = "http://openembedded.org/dl/matrixssl-1-0-beta2-r2.tar.gz \
- file://cross.patch;patch=1"
-S = "${WORKDIR}/matrixssl/src"
-LICENSE = "GPL"
-def define_os (d):
- import bb
- if bb.data.getVar('TARGET_OS', d).startswith('linux'):
- return "-DLINUX"
- return ""
-
-CFLAGS += " ${@define_os(d)}"
-
-do_install () {
- install -d ${D}${includedir}
- install -m 0644 ${S}/../matrixSsl.h ${D}${includedir}/
- oe_libinstall -so libmatrixssl ${D}${libdir}/
-}
diff --git a/packages/matrixssl/matrixssl_1.1.1.bb b/packages/matrixssl/matrixssl_1.1.1.bb
index 674e4b4509..09df504a8b 100644
--- a/packages/matrixssl/matrixssl_1.1.1.bb
+++ b/packages/matrixssl/matrixssl_1.1.1.bb
@@ -1,14 +1,12 @@
-SECTION = "unknown"
+DESCRIPTION = "A secure sockets library"
+SECTION = "libs"
+LICENSE = "GPL"
+
SRC_URI = "http://openembedded.org/dl/matrixssl-1-1-1.tar.gz \
file://cross.patch;patch=1"
S = "${WORKDIR}/matrixssl/src"
-LICENSE = "GPL"
-def define_os (d):
- import bb
- if bb.data.getVar('TARGET_OS', d).startswith('linux'):
- return "-DLINUX"
- return ""
+require matrixssl.inc
CFLAGS += " ${@define_os(d)}"
do_install () {