aboutsummaryrefslogtreecommitdiffstats
path: root/packages/matrixssl
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/matrixssl
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/matrixssl')
-rw-r--r--packages/matrixssl/.mtn2git_empty0
-rw-r--r--packages/matrixssl/matrixssl-1.0-beta/.mtn2git_empty0
-rw-r--r--packages/matrixssl/matrixssl-1.0-beta/cross.patch28
-rw-r--r--packages/matrixssl/matrixssl-1.1.1/.mtn2git_empty0
-rw-r--r--packages/matrixssl/matrixssl-1.1.1/cross.patch55
5 files changed, 83 insertions, 0 deletions
diff --git a/packages/matrixssl/.mtn2git_empty b/packages/matrixssl/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/matrixssl/.mtn2git_empty
diff --git a/packages/matrixssl/matrixssl-1.0-beta/.mtn2git_empty b/packages/matrixssl/matrixssl-1.0-beta/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/matrixssl/matrixssl-1.0-beta/.mtn2git_empty
diff --git a/packages/matrixssl/matrixssl-1.0-beta/cross.patch b/packages/matrixssl/matrixssl-1.0-beta/cross.patch
index e69de29bb2..b4c9634949 100644
--- a/packages/matrixssl/matrixssl-1.0-beta/cross.patch
+++ b/packages/matrixssl/matrixssl-1.0-beta/cross.patch
@@ -0,0 +1,28 @@
+--- src/Makefile~cross 2004-03-01 19:12:37.000000000 -0500
++++ src/Makefile 2004-06-04 21:59:55.527364588 -0400
+@@ -12,14 +12,14 @@
+ #
+ # Debug flags and C flags
+ #
+-DFLAGS = -O3
++CFLAGS = -O3
+ #
+ # To build a debug version of the MatrixSSL library, uncomment the DFLAGS line
+ # below and remove the strip command in the .so target below.
+ #
+-#DFLAGS = -g -DDEBUG
++#CFLAGS = -g -DDEBUG
+
+-CFLAGS = -DLINUX $(DFLAGS)
++override CFLAGS += -DLINUX
+ LDFLAGS = -Wl -lc -lpthread
+
+ all: compile
+@@ -56,7 +56,6 @@
+ #
+ libmatrixssl.so: $(OBJECTS)
+ $(CC) -shared -nostdlib -o $@ $^ $(LDFLAGS)
+- strip $(LIBRARIES)
+
+ #
+ # Clean up workspace
diff --git a/packages/matrixssl/matrixssl-1.1.1/.mtn2git_empty b/packages/matrixssl/matrixssl-1.1.1/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/matrixssl/matrixssl-1.1.1/.mtn2git_empty
diff --git a/packages/matrixssl/matrixssl-1.1.1/cross.patch b/packages/matrixssl/matrixssl-1.1.1/cross.patch
index e69de29bb2..05ae0523e8 100644
--- a/packages/matrixssl/matrixssl-1.1.1/cross.patch
+++ b/packages/matrixssl/matrixssl-1.1.1/cross.patch
@@ -0,0 +1,55 @@
+--- src/Makefile.porig 2004-06-10 15:03:25.000000000 -0400
++++ src/Makefile 2004-06-11 20:16:30.701134886 -0400
+@@ -6,7 +6,7 @@
+ #
+
+ CC = gcc
+-STRIP = strip
++STRIP = -s
+ O = .o
+ SO = .so
+ E =
+@@ -37,17 +37,17 @@
+ #
+ ifdef MATRIXSSL_DEBUG
+ DFLAGS = -g -Wall -DDEBUG
+-STRIP = test
++STRIP =
+ else
+-DFLAGS = -O3
++DFLAGS = -O2
+ endif
+
+ #
+ # Compile options
+ #
+-SHARED = -shared
+-CFLAGS = $(DFLAGS) -DLINUX
+-LDFLAGS = -nostdlib -lc -lpthread
++SHARED = -shared
++CFLAGS = $(DFLAGS) $(STRIP) -DLINUX
++LDLIBS = -nostdlib -lc -lpthread
+
+ #
+ # Override variables for compilation on Mac OS X (Darwin)
+@@ -57,8 +57,8 @@
+ SO = .dylib
+ SHARED = -dynamiclib
+ CFLAGS += -DOSX -isystem -I/usr/include
+-LDFLAGS = -flat_namespace -install_name @executable_path/../src/$(LIBRARY)
+-STRIP = test
++LDLIBS = -flat_namespace -install_name @executable_path/../src/$(LIBRARY)
++STRIP =
+ endif
+
+ all: compile
+@@ -77,8 +77,7 @@
+ # Build the library
+ #
+ $(LIBRARY): $(OBJECTS)
+- $(CC) $(SHARED) -o $@ $^ $(LDFLAGS)
+- $(STRIP) $(LIBRARY)
++ $(CC) $(SHARED) -o $@ $^ $(LDFLAGS) $(LDLIBS)
+
+ #
+ # Clean up all generated files