aboutsummaryrefslogtreecommitdiffstats
path: root/packages/mesa
diff options
context:
space:
mode:
authorStelios Koroneos <skoroneos@digital-opsis.com>2007-06-07 21:55:05 +0000
committerStelios Koroneos <skoroneos@digital-opsis.com>2007-06-07 21:55:05 +0000
commit33912187feccda04c86a66aabd2c9476e68421b0 (patch)
treeac04bf179f2b55f349671fcd7bb5db27f5946f07 /packages/mesa
parentaa55b3d55ab9e798c11f194ae811768fea716719 (diff)
downloadopenembedded-33912187feccda04c86a66aabd2c9476e68421b0.tar.gz
packages/mesa/mesa_6.5.2.bb : Fix a bug in mesa that tries to build a binary
(gen_matypes) used by the host to generate an include file (matypes.h) using target's includes
Diffstat (limited to 'packages/mesa')
-rw-r--r--packages/mesa/mesa-6.5.2/fix-host-compile.patch30
-rw-r--r--packages/mesa/mesa_6.5.2.bb7
2 files changed, 36 insertions, 1 deletions
diff --git a/packages/mesa/mesa-6.5.2/fix-host-compile.patch b/packages/mesa/mesa-6.5.2/fix-host-compile.patch
new file mode 100644
index 0000000000..d24d03d379
--- /dev/null
+++ b/packages/mesa/mesa-6.5.2/fix-host-compile.patch
@@ -0,0 +1,30 @@
+--- /src/mesa/x86/orig-Makefile 2005-07-01 04:54:38.000000000 +0300
++++ /src/mesa/x86/Makefile 2007-06-07 21:52:31.000000000 +0300
+@@ -5,6 +5,7 @@
+
+
+ INCLUDE_DIRS = \
++ -I/usr/include \
+ -I$(TOP)/include/GL \
+ -I$(TOP)/include \
+ -I.. \
+@@ -13,6 +14,10 @@
+ -I../glapi \
+ -I../tnl
+
++OPT_FLAGS_host = -fexpensive-optimizations -fomit-frame-pointer -frename-registers -Os
++
++CFLAGS_host = -Wall -Wmissing-prototypes $(OPT_FLAGS_host) $(PIC_FLAGS) $(ARCH_FLAGS) \
++ $(DEFINES) $(ASM_FLAGS) $(X11_INCLUDES) -std=c99 -ffast-math
+
+ default: gen_matypes matypes.h
+
+@@ -21,7 +26,7 @@
+
+
+ gen_matypes: gen_matypes.c
+- $(CC) $(INCLUDE_DIRS) $(CFLAGS) gen_matypes.c -o gen_matypes
++ $(CC) $(INCLUDE_DIRS) $(CFLAGS_host) gen_matypes.c -o gen_matypes
+
+ # need some special rules here, unfortunately
+ matypes.h: ../main/mtypes.h ../tnl/t_context.h gen_matypes
diff --git a/packages/mesa/mesa_6.5.2.bb b/packages/mesa/mesa_6.5.2.bb
index 1c245f003b..79993cc1f1 100644
--- a/packages/mesa/mesa_6.5.2.bb
+++ b/packages/mesa/mesa_6.5.2.bb
@@ -1,3 +1,8 @@
-PR = "r0"
+PR = "r1"
include mesa-mesa.inc
+
+SRC_URI_append = " file://fix-host-compile.patch;patch=1 "
+
+
+