aboutsummaryrefslogtreecommitdiffstats
path: root/packages/mesa
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-12-08 10:08:18 +0000
committerKoen Kooi <koen@openembedded.org>2007-12-08 10:08:18 +0000
commit8676b78ef8bec6fc74a9015c60150c00bbb94fa5 (patch)
tree43b737dfe906fd3f3691c4e905053aee8acb7a24 /packages/mesa
parent8257f57494600b754b8cd03b5da5649b0aa87616 (diff)
downloadopenembedded-8676b78ef8bec6fc74a9015c60150c00bbb94fa5.tar.gz
mesa: add 7.0.2
Diffstat (limited to 'packages/mesa')
-rw-r--r--packages/mesa/mesa-7.0.2/.mtn2git_empty0
-rw-r--r--packages/mesa/mesa-7.0.2/fix-host-compile.patch30
-rw-r--r--packages/mesa/mesa-7.0.2/mklib-rpath-link.patch23
-rw-r--r--packages/mesa/mesa_7.0.2.bb6
4 files changed, 59 insertions, 0 deletions
diff --git a/packages/mesa/mesa-7.0.2/.mtn2git_empty b/packages/mesa/mesa-7.0.2/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/mesa/mesa-7.0.2/.mtn2git_empty
diff --git a/packages/mesa/mesa-7.0.2/fix-host-compile.patch b/packages/mesa/mesa-7.0.2/fix-host-compile.patch
new file mode 100644
index 0000000000..d24d03d379
--- /dev/null
+++ b/packages/mesa/mesa-7.0.2/fix-host-compile.patch
@@ -0,0 +1,30 @@
+--- /src/mesa/x86/orig-Makefile 2005-07-01 04:54:38.000000000 +0300
++++ /src/mesa/x86/Makefile 2007-06-07 21:52:31.000000000 +0300
+@@ -5,6 +5,7 @@
+
+
+ INCLUDE_DIRS = \
++ -I/usr/include \
+ -I$(TOP)/include/GL \
+ -I$(TOP)/include \
+ -I.. \
+@@ -13,6 +14,10 @@
+ -I../glapi \
+ -I../tnl
+
++OPT_FLAGS_host = -fexpensive-optimizations -fomit-frame-pointer -frename-registers -Os
++
++CFLAGS_host = -Wall -Wmissing-prototypes $(OPT_FLAGS_host) $(PIC_FLAGS) $(ARCH_FLAGS) \
++ $(DEFINES) $(ASM_FLAGS) $(X11_INCLUDES) -std=c99 -ffast-math
+
+ default: gen_matypes matypes.h
+
+@@ -21,7 +26,7 @@
+
+
+ gen_matypes: gen_matypes.c
+- $(CC) $(INCLUDE_DIRS) $(CFLAGS) gen_matypes.c -o gen_matypes
++ $(CC) $(INCLUDE_DIRS) $(CFLAGS_host) gen_matypes.c -o gen_matypes
+
+ # need some special rules here, unfortunately
+ matypes.h: ../main/mtypes.h ../tnl/t_context.h gen_matypes
diff --git a/packages/mesa/mesa-7.0.2/mklib-rpath-link.patch b/packages/mesa/mesa-7.0.2/mklib-rpath-link.patch
new file mode 100644
index 0000000000..618f5b57ed
--- /dev/null
+++ b/packages/mesa/mesa-7.0.2/mklib-rpath-link.patch
@@ -0,0 +1,23 @@
+--- /tmp/mklib 2007-12-08 11:03:23.000000000 +0100
++++ Mesa-7.0.2/bin/mklib 2007-12-08 11:04:02.509863000 +0100
+@@ -106,6 +106,9 @@
+ -L*)
+ DEPS="$DEPS $1"
+ ;;
++ -Wl*)
++ DEPS="$DEPS $1"
++ ;;
+ -pthread)
+ # this is a special case (see bugzilla 10876)
+ DEPS="$DEPS $1"
+--- /tmp/default 2007-12-08 11:04:17.000000000 +0100
++++ Mesa-7.0.2/configs/default 2007-12-08 11:05:06.279863000 +0100
+@@ -76,7 +76,7 @@
+ GLW_LIB_DEPS = -L$(TOP)/$(LIB_DIR) -l$(GL_LIB) $(EXTRA_LIB_PATH) -lXt -lX11
+
+ # Program dependencies - specific GL/glut libraries added in Makefiles
+-APP_LIB_DEPS = -lm
++APP_LIB_DEPS = $(EXTRA_LIB_PATH) -lm
+
+
+
diff --git a/packages/mesa/mesa_7.0.2.bb b/packages/mesa/mesa_7.0.2.bb
new file mode 100644
index 0000000000..3eb1fbef8b
--- /dev/null
+++ b/packages/mesa/mesa_7.0.2.bb
@@ -0,0 +1,6 @@
+include mesa-mesa.inc
+
+SRC_URI_append = " file://fix-host-compile.patch;patch=1 "
+
+
+