aboutsummaryrefslogtreecommitdiffstats
path: root/packages/meta
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2004-12-21 14:00:11 +0000
committerMichael Lauer <mickey@vanille-media.de>2004-12-21 14:00:11 +0000
commit753d951290981c42e16a4c8d14745edb6e95fb55 (patch)
treef5728ffc72f38f669b1e90d62f49c1b76c708178 /packages/meta
parent606ef42074dbb140a5806cb36182c939be760af0 (diff)
downloadopenembedded-753d951290981c42e16a4c8d14745edb6e95fb55.tar.gz
opie-image: install more stuff on devices with ROOT_FLASH_SIZE >= 24MB
BKrev: 41c82c6boPx69Cjwy0T3Dqhmezpsfw
Diffstat (limited to 'packages/meta')
-rw-r--r--packages/meta/opie-collections.inc25
-rw-r--r--packages/meta/opie-image.bb14
2 files changed, 33 insertions, 6 deletions
diff --git a/packages/meta/opie-collections.inc b/packages/meta/opie-collections.inc
index 6f29b262be..d379c5dfb7 100644
--- a/packages/meta/opie-collections.inc
+++ b/packages/meta/opie-collections.inc
@@ -61,3 +61,28 @@ OPIE_EXTRA_APPS = "opie-advancedfm"
OPIE_EXTRA_SETTINGS = "opie-language opie-launcher-settings opie-doctab opie-security \
opie-mediummount opie-networksettings-wlanplugin opie-networksettings-pppplugin"
+#
+# Additional things for a >= 24MB distribution
+#
+
+OPIE_DEPENDS_24 = "konqueror-embedded"
+OPIE_RDEPENDS_24 = "konqueror-embedded"
+
+#
+#
+#
+
+def opie_more_depends(d):
+ import bb
+ root_flash_size = int( bb.data.getVar( "ROOT_FLASH_SIZE", d, True ) )
+ if root_flash_size >= 24: return bb.data.getVar( "OPIE_DEPENDS_24", d, True )
+ else: return " "
+
+def opie_more_rdepends(d):
+ import bb
+ root_flash_size = int( bb.data.getVar( "ROOT_FLASH_SIZE", d, True ) )
+ if root_flash_size >= 24: return bb.data.getVar( "OPIE_RDEPENDS_24", d, True )
+ else: return " "
+
+OPIE_MORE_DEPENDS := "${@opie_more_depends(d)}"
+OPIE_MORE_RDEPENDS := "${@opie_more_rdepends(d)}"
diff --git a/packages/meta/opie-image.bb b/packages/meta/opie-image.bb
index 8fd4d7d0ac..83004f184b 100644
--- a/packages/meta/opie-image.bb
+++ b/packages/meta/opie-image.bb
@@ -1,11 +1,11 @@
export IMAGE_BASENAME = "opie-image"
export IMAGE_LINGUAS = ""
-FEED_URIS_append_openzaurus = " opie##http://openzaurus.org/official/unstable/3.5.2/feed/opie"
-FEED_URIS_append_opensimpad = " opie##http://openzaurus.org/official/unstable/3.5.2/feed/opie"
-FEED_URIS_append_familiar = " opie##http://familiar.handhelds.org/releases/0.8/feed/opie"
+FEED_URIS_append_openzaurus = " opie##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/feed/opie"
+FEED_URIS_append_opensimpad = " opie##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/feed/opie"
+FEED_URIS_append_familiar = " opie##http://familiar.handhelds.org/releases/${DISTRO_VERSION}/feed/opie"
-PR = "r9"
+PR = "r10"
include opie-collections.inc
@@ -17,12 +17,14 @@ export IPKG_INSTALL = "task-bootstrap ${OPIE_LIBS_RDEPENDS} ${OPIE_BASE} ${OPIE_
${OPIE_BASE_SETTINGS} ${OPIE_BASE_APPS} ${OPIE_BASE_RDEPENDS} \
${OPIE_PIM} ${OPIE_EXTRA_APPLETS} ${OPIE_EXTRA_SETTINGS} \
${OPIE_EXTRA_APPS} ${OPIE_BASE_STYLES} ${OPIE_BASE_DECOS} \
- ${OPIE_BASE_INPUTMETHODS}"
+ ${OPIE_BASE_INPUTMETHODS} ${OPIE_MORE_RDEPENDS}"
DEPENDS = "task-bootstrap ${OPIE_LIBS_DEPENDS} ${OPIE_BASE} ${OPIE_BASE_APPLETS} \
${OPIE_BASE_SETTINGS} ${OPIE_BASE_APPS} ${OPIE_BASE_DEPENDS} ${OPIE_PIM} \
${OPIE_EXTRA_APPLETS} ${OPIE_EXTRA_SETTINGS} ${OPIE_EXTRA_APPS} \
- ${OPIE_BASE_STYLES} ${OPIE_BASE_DECOS} ${OPIE_BASE_INPUTMETHODS}"
+ ${OPIE_BASE_STYLES} ${OPIE_BASE_DECOS} ${OPIE_BASE_INPUTMETHODS} ${OPIE_MORE_DEPENDS}"
+
+
# merge feed-sources into ipkg.conf for opie-aqpkg as it can't handle feed-sources outside of ipkg.conf.
merge_feeds() {