aboutsummaryrefslogtreecommitdiffstats
path: root/packages/midpath/midpath-test_0.1.bb
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2007-08-24 21:38:23 +0000
committerHenning Heinold <heinold@inf.fu-berlin.de>2007-08-24 21:38:23 +0000
commit9e9e2859d9f8876ad5b37f94f33c768d2164d81d (patch)
treef44880c62f2b4244a306b74943e6c0ebf98e58a3 /packages/midpath/midpath-test_0.1.bb
parent8c53ce6b232e7bca264d3eae91ae6e2f94a68e55 (diff)
downloadopenembedded-9e9e2859d9f8876ad5b37f94f33c768d2164d81d.tar.gz
midpath: major rework of midpath
* new releas 0.1 * introduce midpath.inc * split midpath-cldc and midpath-cldc-sdl from midpath * seperate out kxml2 from midpath * split midpath-test from midpath * change jar-installdir to /usr/share/java
Diffstat (limited to 'packages/midpath/midpath-test_0.1.bb')
-rw-r--r--packages/midpath/midpath-test_0.1.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/packages/midpath/midpath-test_0.1.bb b/packages/midpath/midpath-test_0.1.bb
new file mode 100644
index 0000000000..14bfdc97f0
--- /dev/null
+++ b/packages/midpath/midpath-test_0.1.bb
@@ -0,0 +1,46 @@
+
+require midpath.inc
+
+SRC_URI += "file://shellscript.patch;patch=1"
+
+DEPENDS += " midpath"
+RDEPENDS += " midpath"
+
+CLDC_PATH = ${STAGING_DATADIR}/java/cldc1.1.jar
+
+do_configure() {
+
+ cd ${S}/bin
+ sed -i -e "s|MIDPATH_HOME=|MIDPATH_HOME=${datadir}/java|" \
+ midpath-test-cacao-cldc.sh
+
+}
+
+do_compile() {
+
+cd ${S}/tests
+make JAVAC=${JAVAC_CMD} JAVAC_FLAGS="-bootclasspath ${STAGING_DATADIR}/java/midpath.jar:${CLDC_PATH} -sourcepath ${S}/tests -source 1.3 -target 1.1" || exit 1
+make jar JAVAC=${JAVAC_CMD} JAVAC_FLAGS="-bootclasspath ${STAGING_DATADIR}/java/midpath.jar:${CLDC_PATH} -source 1.3 -target 1.1" JAR_FILE="midpath-tests.jar" JAR_FLAGS="cvf" || exit 1
+
+}
+
+do_install() {
+ install -d ${D}${bindir}
+# install -m 0755 bin/graphical_launcher-j2se.sh ${D}${bindir}
+# install -m 0755 bin/midpath-test.sh ${D}${bindir}
+ install -m 0755 bin/midpath-test-cacao-cldc.sh ${D}${bindir}
+ install -d ${D}${datadir}/java
+ install -m 0644 ${S}/tests/midpath-tests.jar ${D}${datadir}/java
+}
+
+do_stage() {
+ :
+}
+
+PACKAGES = "${PN}"
+
+FILES_${PN} = "${datadir}/java/midpath-tests.jar \
+# ${bindir}/graphical_launcher-j2se.sh \
+# ${bindir}/midpath-test.sh \
+ ${bindir}/midpath-test-cacao-cldc.sh \
+ "