aboutsummaryrefslogtreecommitdiffstats
path: root/packages/minicom
diff options
context:
space:
mode:
authorPhilipp Zabel <philipp.zabel@gmail.com>2006-06-14 15:55:07 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-06-14 15:55:07 +0000
commit41bf05ee1eda312ee9c5707d0aa15979fefb9dbc (patch)
tree9bf36fad269c12d6d677daa010a57ebd18f5a179 /packages/minicom
parent18d8eeb8c0504dbfdfe7f11931dd30dcdd5fbcb8 (diff)
downloadopenembedded-41bf05ee1eda312ee9c5707d0aa15979fefb9dbc.tar.gz
minicom-2.1: build fix for gcc, closes #1087
Diffstat (limited to 'packages/minicom')
-rw-r--r--packages/minicom/minicom-2.1/gcc4-scope.patch44
-rw-r--r--packages/minicom/minicom_2.1.bb3
2 files changed, 46 insertions, 1 deletions
diff --git a/packages/minicom/minicom-2.1/gcc4-scope.patch b/packages/minicom/minicom-2.1/gcc4-scope.patch
new file mode 100644
index 0000000000..5bd47bd354
--- /dev/null
+++ b/packages/minicom/minicom-2.1/gcc4-scope.patch
@@ -0,0 +1,44 @@
+--- minicom-2.1/src/window.c.orig 2006-06-14 17:49:53.000000000 +0200
++++ minicom-2.1/src/window.c 2006-06-14 17:50:14.000000000 +0200
+@@ -62,7 +62,7 @@
+ static char *CS, *SF, *SR, *VB, *BL;
+ static char *VE, *VI, *KS, *KE;
+ static char *CD, *CL, *IC, *DC;
+-static char *BC, *CR, *NL;
++static char *mcBC, *CR, *NL;
+ #if ST_LINE
+ static char *TS, *FS, *DS;
+ #endif
+@@ -322,8 +322,8 @@
+ else if (NL != CNULL && x == 0 && x == curx && y == cury + 1)
+ outstr(NL);
+ #endif
+- else if (BC != CNULL && y == cury && x == curx - 1)
+- outstr(BC);
++ else if (mcBC != CNULL && y == cury && x == curx - 1)
++ outstr(mcBC);
+ else
+ outstr(tgoto(CM, x, y));
+ curx = x;
+@@ -1918,7 +1918,7 @@
+ CL = tgetstr("cl", &_tptr);
+ IC = tgetstr("ic", &_tptr);
+ DC = tgetstr("dc", &_tptr);
+- BC = tgetstr("bc", &_tptr);
++ mcBC = tgetstr("bc", &_tptr);
+ CR = tgetstr("cr", &_tptr);
+ NL = tgetstr("nl", &_tptr);
+ AC = tgetstr("ac", &_tptr);
+@@ -1967,10 +1967,10 @@
+ _has_am = tgetflag("am");
+ _mv_standout = tgetflag("ms");
+ if (tgetflag("bs")) {
+- if (BC == CNULL) BC = "\b";
++ if (mcBC == CNULL) mcBC = "\b";
+ }
+ else
+- BC = CNULL;
++ mcBC = CNULL;
+
+ /* Special IBM box-drawing characters */
+ D_UL = 201;
diff --git a/packages/minicom/minicom_2.1.bb b/packages/minicom/minicom_2.1.bb
index b2e25d06f7..c4a1c3018a 100644
--- a/packages/minicom/minicom_2.1.bb
+++ b/packages/minicom/minicom_2.1.bb
@@ -2,7 +2,8 @@ SECTION = "console/network"
DEPENDS = "ncurses"
LICENSE = "GPL"
SRC_URI = "http://alioth.debian.org/download.php/123/minicom-${PV}.tar.gz \
- file://configure.patch;patch=1"
+ file://configure.patch;patch=1 \
+ file://gcc4-scope.patch;patch=1"
inherit autotools gettext