aboutsummaryrefslogtreecommitdiffstats
path: root/packages/mipl-mipv6
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-12-04 12:59:34 +0000
committerKoen Kooi <koen@openembedded.org>2007-12-04 12:59:34 +0000
commite38a45e8895fcd771dcb4c674e728ee3147b6495 (patch)
tree65a8da5f0c7aea2fc4d0224e92ba59ac8808d40d /packages/mipl-mipv6
parent70b2f4f88145fc9955207cd7a8382d5d70a769ee (diff)
downloadopenembedded-e38a45e8895fcd771dcb4c674e728ee3147b6495.tar.gz
mipv6: add untested version 2.0.2, this is suppossed to work with kernel 2.6
Diffstat (limited to 'packages/mipl-mipv6')
-rw-r--r--packages/mipl-mipv6/mipv6_2.0.2.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/packages/mipl-mipv6/mipv6_2.0.2.bb b/packages/mipl-mipv6/mipv6_2.0.2.bb
new file mode 100644
index 0000000000..8bbcb4cb75
--- /dev/null
+++ b/packages/mipl-mipv6/mipv6_2.0.2.bb
@@ -0,0 +1,22 @@
+LICENSE = "GPL"
+DEPENDS = "virtual/kernel"
+RRECOMMENDS = "kernel-module-mip6 kernel-module-ipv6"
+
+SRC_URI = "http://www.mobile-ipv6.org/software/download/mipv6-${PV}.tar.gz"
+
+inherit autotools module-base
+
+CFLAGS =+ "-I${S}/include -I${STAGING_KERNEL_DIR}/include"
+
+do_compile() {
+ oe_runmake CFLAGS="${CFLAGS}"
+}
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -d ${D}${sysconfdir}/init.d
+ oe_runmake sbindir="${D}${sbindir}" initdir="${D}${sysconfdir}/init.d" mandir="${D}${mandir}" docdir="${D}${docdir}/mobile-ip6" NETWORK_MIP6_CONF="${D}${sysconfdir}" install
+}
+
+PACKAGE_ARCH_${PN} = "${MACHINE_ARCH}"
+