aboutsummaryrefslogtreecommitdiffstats
path: root/packages/mktemp
diff options
context:
space:
mode:
authorlynnlin <lynn.lin@avocent.com>2009-02-10 23:42:45 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-02-10 23:43:09 +0100
commit840b23db50d99da5506fb7ee2203e9551d1e24a2 (patch)
tree62f35f3f2ae6642bb68ce8cd85e47374c2ff1d76 /packages/mktemp
parent5fae020b6fbac764fb9c4d62935ec9fde41df323 (diff)
downloadopenembedded-840b23db50d99da5506fb7ee2203e9551d1e24a2.tar.gz
mktemp: new recipe; safe temp directory from shell scripts. closes OE #4746
Diffstat (limited to 'packages/mktemp')
-rw-r--r--packages/mktemp/files/add_destdir.patch20
-rw-r--r--packages/mktemp/files/disable-strip.patch12
-rw-r--r--packages/mktemp/mktemp_1.6.bb17
3 files changed, 49 insertions, 0 deletions
diff --git a/packages/mktemp/files/add_destdir.patch b/packages/mktemp/files/add_destdir.patch
new file mode 100644
index 0000000000..5eede383b3
--- /dev/null
+++ b/packages/mktemp/files/add_destdir.patch
@@ -0,0 +1,20 @@
+diff -NurpP --minimal mktemp-1.6/Makefile.in mktemp-1.6-addDESTDIR/Makefile.in
+--- mktemp-1.6/Makefile.in 2008-08-17 23:38:34.000000000 +0800
++++ mktemp-1.6-addDESTDIR/Makefile.in 2008-10-20 14:28:42.000000000 +0800
+@@ -106,13 +106,13 @@ $(OBJS): config.h
+ install: install-dirs install-binaries install-man
+
+ install-dirs:
+- $(SHELL) $(srcdir)/mkinstalldirs $(bindir) $(mandir)/man1
++ $(SHELL) $(srcdir)/mkinstalldirs ${DESTDIR}/$(bindir) ${DESTDIR}/$(mandir)/man1
+
+ install-binaries: $(PROG)
+- $(INSTALL) -m 0555 -s $(PROG) $(bindir)/$(PROG)
++ $(INSTALL) -m 0555 -s $(PROG) ${DESTDIR}/$(bindir)/$(PROG)
+
+ install-man:
+- $(INSTALL) -m 0444 $(srcdir)/mktemp.$(mantype) $(mandir)/man1/mktemp.1
++ $(INSTALL) -m 0444 $(srcdir)/mktemp.$(mantype) ${DESTDIR}/$(mandir)/man1/mktemp.1
+
+ check:
+ @echo nothing to check
diff --git a/packages/mktemp/files/disable-strip.patch b/packages/mktemp/files/disable-strip.patch
new file mode 100644
index 0000000000..96269863a4
--- /dev/null
+++ b/packages/mktemp/files/disable-strip.patch
@@ -0,0 +1,12 @@
+diff -NurpP --minimal mktemp-1.6/Makefile.in mktemp-1.6-disable-strip/Makefile.in
+--- mktemp-1.6/Makefile.in 2009-01-22 15:11:33.000000000 +0800
++++ mktemp-1.6-disable-strip/Makefile.in 2009-01-22 15:13:52.000000000 +0800
+@@ -109,7 +109,7 @@ install-dirs:
+ $(SHELL) $(srcdir)/mkinstalldirs ${DESTDIR}/$(bindir) ${DESTDIR}/$(mandir)/man1
+
+ install-binaries: $(PROG)
+- $(INSTALL) -m 0555 -s $(PROG) ${DESTDIR}/$(bindir)/$(PROG)
++ $(INSTALL) -m 0555 $(PROG) ${DESTDIR}/$(bindir)/$(PROG)
+
+ install-man:
+ $(INSTALL) -m 0444 $(srcdir)/mktemp.$(mantype) ${DESTDIR}/$(mandir)/man1/mktemp.1
diff --git a/packages/mktemp/mktemp_1.6.bb b/packages/mktemp/mktemp_1.6.bb
new file mode 100644
index 0000000000..bd9c4caa7d
--- /dev/null
+++ b/packages/mktemp/mktemp_1.6.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Allow safe temporary file creation from shell scripts."
+HOMEPAGE = "http://www.mktemp.org/"
+SECTION = "console/utils"
+LICENSE = "GPLv2 BSD"
+
+inherit autotools
+
+EXTRA_OECONF = "--with-libc"
+
+SRC_URI = "\
+ ftp://ftp.mktemp.org/pub/mktemp/${P}.tar.gz \
+ file://add_destdir.patch;patch=1 \
+ file://disable-strip.patch;patch=1 \
+"
+
+# FIXME should rather use update-alternatives
+RCONFLICTS_${PN} = "coreutils"