aboutsummaryrefslogtreecommitdiffstats
path: root/packages/mobilemesh
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2004-12-14 12:49:04 +0000
committerMichael Lauer <mickey@vanille-media.de>2004-12-14 12:49:04 +0000
commitfe938bbed352811a2e176797d9f5295d270564e8 (patch)
treeb482ac8d4bbe1d878d08b41d7f73d95b00459474 /packages/mobilemesh
parent8c45dce3743063bf4f15c5c17597fbeb15061d5f (diff)
downloadopenembedded-fe938bbed352811a2e176797d9f5295d270564e8.tar.gz
Merge bk://oe-devel@oe-devel.bkbits.net/openembedded
into r2d2.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2004/12/14 12:27:14+01:00 (none)!br1 Merge http://oe-devel@oe-devel.bkbits.net/openembedded into null.(none):/data/mtx/oe/openembedded 2004/12/14 12:26:43+01:00 (none)!br1 add mtx-1 i2c support 2004/12/14 11:02:03+01:00 (none)!br1 unik-olsrd 0.4.8 2004/12/14 11:00:53+01:00 (none)!br1 little fixes for bitbake 2004/12/14 10:59:06+01:00 (none)!br1 nylon updates 2004/12/14 03:27:14-06:00 ti.com!kergoth More PACKAGE_ARCH/MACHINE_ARCH updates for the multi-z builds. BKrev: 41bee140kQ_QwKwcIxgyouZUyeqwmA
Diffstat (limited to 'packages/mobilemesh')
-rw-r--r--packages/mobilemesh/mobilemesh_1.2.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/packages/mobilemesh/mobilemesh_1.2.bb b/packages/mobilemesh/mobilemesh_1.2.bb
index e69de29bb2..30e1a58a3c 100644
--- a/packages/mobilemesh/mobilemesh_1.2.bb
+++ b/packages/mobilemesh/mobilemesh_1.2.bb
@@ -0,0 +1,37 @@
+SECTION = "console/network"
+DESCRIPTION = "MobileMesh mobile ad-hoc routing protocol"
+HOMEPAGE = "http://www.mitre.org/work/tech_transfer/mobilemesh/"
+MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
+LICENSE = "GPL"
+DEPENDS = "openssl"
+SRC_URI = "svn://meshcube.org/svn/application;module=mobilemesh;proto=http"
+
+S = "${WORKDIR}/mobilemesh"
+
+CXXFLAGS += "-I ."
+LDFLAGS += "-lcrypto -lssl"
+
+do_compile() {
+ oe_runmake depends
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}/${sbindir}
+ install -d ${D}/${sysconfdir}/mobilemesh
+ install -d ${D}/${sysconfdir}/init.d
+ install -d ${D}/${docdir}
+ install -d ${D}/${mandir}/man8
+ oe_runmake PREFIX=${TARGET_PREFIX} BINDIR=${D}/${sbindir} ETCDIR=${D}/${sysconfdir}/mobilemesh install
+ install ${S}/doc/InternetDrafts/draft* ${D}/${docdir}
+ #install ${S}/doc/man/mm*.ps ${D}/${docdir}
+ install ${S}/doc/man/mm*.pdf ${D}/${docdir}
+ install ${S}/doc/man/mm*.8 ${D}/${mandir}/man8
+ install ${S}/doc/FAQ ${D}/${docdir}
+ install ${S}/doc/INSTALL ${D}/${docdir}
+ install ${S}/doc/LICENSE ${D}/${docdir}
+ install ${S}/doc/README ${D}/${docdir}
+ install ${S}/mobilemesh.init ${D}/${sysconfdir}/init.d/mobilemesh
+}
+
+CONFFILES_${PN}_nylon = "${sysconfdir}/mobilemesh/mmrp.conf ${sysconfdir}/mobilemesh/mmdiscover.conf"