aboutsummaryrefslogtreecommitdiffstats
path: root/packages/module-init-tools
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-20 15:40:10 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-20 15:40:10 +0000
commit5ab4bb661fbbb0b656139c1073598859e16b2484 (patch)
treea93dae102b3d4a654bbe55a75d06bca8ffc16f9a /packages/module-init-tools
parent3fff43da673534e60500beeb61ff7875f72cdff4 (diff)
downloadopenembedded-5ab4bb661fbbb0b656139c1073598859e16b2484.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/01/20 10:35:16-05:00 handhelds.org!kergoth Add patcher-native to ixp425-eth's depends. Really, it shouldnt be calling out patcher explicitly in its tasks at all, since the .bb shouldn't have any knowledge of how patches are applied. That said, this should at least get it building again in the meantime. 2005/01/20 10:29:55-05:00 handhelds.org!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into handhelds.org:/home/kergoth/code/openembedded 2005/01/20 10:29:38-05:00 handhelds.org!kergoth Kill off module-init-tools 3.1-pre5. It didn't have the correct set of patches applied, and there's no reason to keep around the old version. BKrev: 41efd0darfDOqFGMjJ_Ozpgb-p9H9g
Diffstat (limited to 'packages/module-init-tools')
-rw-r--r--packages/module-init-tools/module-init-tools-cross_3.1-pre5.bb0
-rw-r--r--packages/module-init-tools/module-init-tools_3.1-pre5.bb56
2 files changed, 0 insertions, 56 deletions
diff --git a/packages/module-init-tools/module-init-tools-cross_3.1-pre5.bb b/packages/module-init-tools/module-init-tools-cross_3.1-pre5.bb
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/module-init-tools/module-init-tools-cross_3.1-pre5.bb
+++ /dev/null
diff --git a/packages/module-init-tools/module-init-tools_3.1-pre5.bb b/packages/module-init-tools/module-init-tools_3.1-pre5.bb
deleted file mode 100644
index ff8b4d5b60..0000000000
--- a/packages/module-init-tools/module-init-tools_3.1-pre5.bb
+++ /dev/null
@@ -1,56 +0,0 @@
-LICENSE = GPL
-SECTION = "base"
-DESCRIPTION = "This package contains a set of programs for loading, inserting, and \
-removing kernel modules for Linux (versions 2.5.48 and above). It serves \
-the same function that the modutils package serves for Linux 2.4."
-PR = "r6"
-
-PACKAGES =+ "module-init-tools-insmod-static module-init-tools-depmod"
-RDEPENDS_${PN} += "module-init-tools-depmod"
-
-FILES_module-init-tools-depmod = "${sbindir}/depmod.26"
-FILES_module-init-tools-insmod-static = "${sbindir}/insmod.static"
-
-SRC_URI = "ftp://ftp.kernel.org/pub/linux/utils/kernel/module-init-tools/module-init-tools-${PV}.tar.bz2 \
- file://backwards.patch;patch=1"
-S = "${WORKDIR}/module-init-tools-${PV}"
-
-bindir = "/bin"
-sbindir = "/sbin"
-
-inherit autotools
-
-do_install() {
- autotools_do_install
- for f in bin/lsmod sbin/insmod sbin/rmmod sbin/modprobe sbin/modinfo sbin/depmod; do
- mv ${D}/$f ${D}/$f.26
- done
- install -d ${D}${mandir}
- mv ${D}${prefix}/man/* ${D}${mandir}/
-}
-
-pkg_postinst_module-init-tools() {
-#!/bin/sh
-for f in sbin/insmod sbin/modprobe sbin/rmmod sbin/depmod sbin/modinfo bin/lsmod; do
-bn=`basename $f`
- update-alternatives --install /$f $bn /$f.26 20
-done
-}
-
-pkg_prerm_module-init-tools() {
-#!/bin/sh
-for f in sbin/insmod sbin/modprobe sbin/rmmod sbin/depmod sbin/modinfo bin/lsmod; do
-bn=`basename $f`
- update-alternatives --remove $bn /$f.26
-done
-}
-
-pkg_postinst_module-init-tools-depmod() {
-#!/bin/sh
-update-alternatives --install /sbin/depmod depmod /sbin/depmod.26 20
-}
-
-pkg_prerm_module-init-tools() {
-#!/bin/sh
-update-alternatives --remove depmod /sbin/depmod.26
-}