aboutsummaryrefslogtreecommitdiffstats
path: root/packages/module-init-tools
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-08 14:40:06 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-08 14:40:06 +0000
commitfde027eb88606eecef59f5380f10608403c61931 (patch)
tree2767d191ccf174e277e337521130c106a7291a6e /packages/module-init-tools
parent7ccc337fe03e352ac41acd3f75480c61fd065fff (diff)
downloadopenembedded-fde027eb88606eecef59f5380f10608403c61931.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/01/08 15:17:40+01:00 mn-solutions.de!schurig make sure all scripts in /etc/pcmcia are executable (network and another on weren't) 2005/01/08 15:15:51+01:00 mn-solutions.de!schurig Merge http://oe-devel@openembedded.bkbits.net/openembedded into mnz66.mn-solutions.de:/usr/src/oe/p 2005/01/08 15:15:27+01:00 mn-solutions.de!schurig make sure that depmod.26 in module-init-tools-depmod will be handled by update-alternatives BKrev: 41dff0c6siKawYOLdWTa8rCAlikf4w
Diffstat (limited to 'packages/module-init-tools')
-rw-r--r--packages/module-init-tools/module-init-tools_3.1-pre5.bb11
1 files changed, 10 insertions, 1 deletions
diff --git a/packages/module-init-tools/module-init-tools_3.1-pre5.bb b/packages/module-init-tools/module-init-tools_3.1-pre5.bb
index 3869f3a38f..1fc882ac56 100644
--- a/packages/module-init-tools/module-init-tools_3.1-pre5.bb
+++ b/packages/module-init-tools/module-init-tools_3.1-pre5.bb
@@ -3,7 +3,7 @@ SECTION = "base"
DESCRIPTION = "This package contains a set of programs for loading, inserting, and \
removing kernel modules for Linux (versions 2.5.48 and above). It serves \
the same function that the modutils package serves for Linux 2.4."
-PR = "r4"
+PR = "r5"
PACKAGES =+ "module-init-tools-insmod-static module-init-tools-depmod"
RDEPENDS_${PN} += "module-init-tools-depmod"
@@ -45,3 +45,12 @@ bn=`basename $f`
done
}
+pkg_postinst_module-init-tools-depmod() {
+#!/bin/sh
+update-alternatives --install /sbin/depmod depmod.26 /sbin/depmod.26 20
+}
+
+pkg_prerm_module-init-tools() {
+#!/bin/sh
+update-alternatives --remove depmod /sbin/debmod.26
+}