aboutsummaryrefslogtreecommitdiffstats
path: root/packages/monotone/monotone-5_0.20.bb
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-07-15 06:23:53 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-15 06:23:53 +0000
commit88320ffdf3926d7638b6f3fb0b9e9eebd7fe226c (patch)
tree3c2f5113ef9dc66a65c1b820a7462097443c5d19 /packages/monotone/monotone-5_0.20.bb
parent6e97c64f8574ffd096471d11edf871f9ae242cff (diff)
downloadopenembedded-88320ffdf3926d7638b6f3fb0b9e9eebd7fe226c.tar.gz
mpd does not build on osuclibc because libvorbis will not build, that
happens because it attempts a static link with the -lm library in the wrong place. monotone split into two versions, one for the netsync-4 versions (up to and including 0.19) one for netsync-5 versions. Both may be installed on one NSLU2, allowing the system to handle both <=0.19 and >=0.20 servers.
Diffstat (limited to 'packages/monotone/monotone-5_0.20.bb')
-rw-r--r--packages/monotone/monotone-5_0.20.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/packages/monotone/monotone-5_0.20.bb b/packages/monotone/monotone-5_0.20.bb
new file mode 100644
index 0000000000..ec98ec26d2
--- /dev/null
+++ b/packages/monotone/monotone-5_0.20.bb
@@ -0,0 +1,51 @@
+# This package builds the devio program
+DESCRIPTION = "monotone - an SCM"
+HOMEPAGE = "http://www.venge.net/"
+MAINTAINER = "John Bowler <jbowler@acm.org>"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "MIT"
+PR = "r0"
+
+SRC_URI = "http://venge.net/monotone/downloads/monotone-${PV}.tar.gz \
+ file://txt2c-cross.patch;patch=1 \
+ file://cryptopp-endianness.patch;patch=1"
+DEPENDS += "boost"
+# Following may be required, not proved yet...
+#TARGET_CFLAGS += "-fno-strict-aliasing"
+
+PACKAGES = "${PN} ${PN}-doc ${PN}-testsuite"
+tsd = "/home/monotone/${PN}"
+FILES_${PN}-testsuite = "${tsd}/testsuite ${tsd}/tests"
+RDEPENDS_${PN}-testsuite += "bash sed grep cvs"
+# The testsuite also requires the following - not yet available...
+#RDEPENDS_${PN}-testsuite += "patch perl"
+
+S = "${WORKDIR}/monotone-${PV}"
+
+# no cross compile support - it tries to run the test program even with
+# --enable_ipv6=yes
+EXTRA_OECONF = "--disable-ipv6 \
+ --disable-dependency-tracking \
+ --disable-rpath \
+ --disable-nls \
+ --with-gnu-ld \
+ "
+
+inherit autotools update-alternatives
+
+ALTERNATIVE_NAME = "monotone"
+ALTERNATIVE_LINK = "${bindir}/monotone"
+ALTERNATIVE_PATH = "${bindir}/${PN}"
+ALTERNATIVE_PRIORITY = "50"
+
+
+# This makes the testsuite as a package and renames the monotone executable
+# to include the netsync suffix.
+do_install_append() {
+ install -d ${D}${tsd}
+ install -c -m 755 testsuite ${D}${tsd}/testsuite
+ cp -a tests ${D}${tsd}/tests
+ #
+ mv ${D}${bindir}/monotone ${D}${bindir}/${PN}
+}