aboutsummaryrefslogtreecommitdiffstats
path: root/packages/monotone
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-07-06 07:48:46 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-06 07:48:46 +0000
commit060a925277aefd5367a76112c45205d3370e0a4a (patch)
treeaa90b599c82232b76763d2b3fb74ac7f730ca798 /packages/monotone
parent6e702c6a8f5ce690de708df66b4d0ea6041dfc52 (diff)
downloadopenembedded-060a925277aefd5367a76112c45205d3370e0a4a.tar.gz
Building but not working monotone - still has problems in cryptopp (in
the rsa code).
Diffstat (limited to 'packages/monotone')
-rw-r--r--packages/monotone/monotone_0.20.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/packages/monotone/monotone_0.20.bb b/packages/monotone/monotone_0.20.bb
new file mode 100644
index 0000000000..dc7abc72b4
--- /dev/null
+++ b/packages/monotone/monotone_0.20.bb
@@ -0,0 +1,37 @@
+# This package builds the devio program
+DESCRIPTION = "monotone - an SCM"
+HOMEPAGE = "http://www.venge.net/"
+MAINTAINER = "John Bowler <jbowler@acm.org>"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "MIT"
+PR = "r0"
+
+SRC_URI = "http://venge.net/monotone/downloads/monotone-${PV}.tar.gz \
+ file://txt2c-cross.patch;patch=1 \
+ file://cryptopp-endianness.patch;patch=1"
+DEPENDS += "boost"
+# Following may be required, not proved yet...
+#TARGET_CFLAGS += "-fno-strict-aliasing"
+
+PACKAGES = "${PN} ${PN}-doc ${PN}-testsuite"
+tsd = "/home/monotone"
+FILES_${PN}-testsuite = "${tsd}/testsuite ${tsd}/tests"
+
+# no cross compile support - it tries to run the test program even with
+# --enable_ipv6=yes
+EXTRA_OECONF = "--disable-ipv6 \
+ --disable-dependency-tracking \
+ --disable-rpath \
+ --disable-nls \
+ --with-gnu-ld \
+ "
+
+inherit autotools
+
+# This makes the testsuite as a package
+do_install_append() {
+ install -d ${D}${tsd}
+ install -c -m 755 testsuite ${D}${tsd}/testsuite
+ cp -a tests ${D}${tsd}/tests
+}