aboutsummaryrefslogtreecommitdiffstats
path: root/packages/monotone
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-07-18 04:09:03 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-18 04:09:03 +0000
commit3143c04f905275f5f07c4147c914e7f859b5fd7d (patch)
treea1c876b1a9765df05d6bbafb7622b1d8ebb7125c /packages/monotone
parent3b41e82b84f8c7777401fb6127122593bce17695 (diff)
downloadopenembedded-3143c04f905275f5f07c4147c914e7f859b5fd7d.tar.gz
monotone 0.21 and associated patches
Diffstat (limited to 'packages/monotone')
-rw-r--r--packages/monotone/files/configure.ac.patch36
-rw-r--r--packages/monotone/files/uclibc.database.hh.stdarg.patch10
-rw-r--r--packages/monotone/monotone-5_0.21.bb12
-rw-r--r--packages/monotone/monotone.inc4
4 files changed, 60 insertions, 2 deletions
diff --git a/packages/monotone/files/configure.ac.patch b/packages/monotone/files/configure.ac.patch
new file mode 100644
index 0000000000..2d3e75531a
--- /dev/null
+++ b/packages/monotone/files/configure.ac.patch
@@ -0,0 +1,36 @@
+--- monotone-0.21/configure.ac.orig 2005-07-17 19:23:29.580829434 -0700
++++ monotone-0.21/configure.ac 2005-07-17 19:28:50.237223287 -0700
+@@ -82,9 +82,14 @@
+ AC_DEFUN([BOOST_VERSION_CHECK],
+ [AC_CACHE_CHECK([boost version 1.32 or newer], ac_cv_version_boost,
+ [
+- AC_TRY_RUN(
++ AC_TRY_COMPILE(
+ [#include <boost/version.hpp>
+- int main() { return (BOOST_VERSION < 103200); }],
++ #if BOOST_VERSION < 103200
++ int main() { return (BOOST_VERSION < 103200); }
++ #else
++ #error boost version is ok
++ #endif
++ ],
+ ac_cv_version_boost=yes,
+ ac_cv_version_boost=no)
+ ])
+@@ -101,9 +106,14 @@
+ AC_DEFUN([BOOST_FIX_VERSION],
+ [AC_CACHE_CHECK([if boost requires extra flags to compile], ac_fix_boost,
+ [
+- AC_TRY_RUN(
++ AC_TRY_COMPILE(
+ [#include <boost/version.hpp>
+- int main() { return (BOOST_VERSION != 103200); }],
++ #if BOOST_VERSION != 103200
++ int main() { return (BOOST_VERSION != 103200); }
++ #else
++ #error boost version is not 1.32.0
++ #endif
++ ],
+ ac_fix_boost=yes,
+ ac_fix_boost=no)
+ ])
diff --git a/packages/monotone/files/uclibc.database.hh.stdarg.patch b/packages/monotone/files/uclibc.database.hh.stdarg.patch
new file mode 100644
index 0000000000..1590b7dded
--- /dev/null
+++ b/packages/monotone/files/uclibc.database.hh.stdarg.patch
@@ -0,0 +1,10 @@
+--- monotone-0.21/database.hh.orig 2005-07-17 19:59:00.312846093 -0700
++++ monotone-0.21/database.hh 2005-07-17 19:59:56.259365537 -0700
+@@ -14,6 +14,7 @@
+ #include <set>
+ #include <map>
+ #include <string>
++#include <stdarg.h>
+
+ #include <boost/filesystem/path.hpp>
+
diff --git a/packages/monotone/monotone-5_0.21.bb b/packages/monotone/monotone-5_0.21.bb
new file mode 100644
index 0000000000..ec31e22bfb
--- /dev/null
+++ b/packages/monotone/monotone-5_0.21.bb
@@ -0,0 +1,12 @@
+include monotone.inc
+
+PR = "r0"
+
+SRC_URI = "http://venge.net/monotone/downloads/monotone-${PV}.tar.gz \
+ file://txt2c-cross.patch;patch=1 \
+ file://cryptopp-endianness.patch;patch=1 \
+ file://configure.ac.patch;patch=1 \
+ file://uclibc.database.hh.stdarg.patch;patch=1 \
+ "
+
+ALTERNATIVE_PRIORITY = "50"
diff --git a/packages/monotone/monotone.inc b/packages/monotone/monotone.inc
index a0b9463cd8..7248a9843d 100644
--- a/packages/monotone/monotone.inc
+++ b/packages/monotone/monotone.inc
@@ -40,6 +40,6 @@ do_install_append() {
PACKAGES = "${PN} ${PN}-doc ${PN}-testsuite"
tsd = "/home/monotone/${PN}"
FILES_${PN}-testsuite = "${tsd}/testsuite ${tsd}/tests"
-RDEPENDS_${PN}-testsuite += "bash sed grep cvs"
+RDEPENDS_${PN}-testsuite += "bash sed grep cvs patch"
# The testsuite also requires the following - not yet available...
-#RDEPENDS_${PN}-testsuite += "patch perl"
+#RDEPENDS_${PN}-testsuite += "perl"