aboutsummaryrefslogtreecommitdiffstats
path: root/packages/monotone
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-07-05 07:42:50 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-05 07:42:50 +0000
commit4c2ddb538079ad9561560f633cecfb6b429d256d (patch)
tree0180d515fffff1e49de4105998ec2bef4dbdaac7 /packages/monotone
parent4def1ea71211f8abeed555475706fa331ac1b635 (diff)
downloadopenembedded-4c2ddb538079ad9561560f633cecfb6b429d256d.tar.gz
Builds but has bugs in very basic functionality (db init does not work).
Diffstat (limited to 'packages/monotone')
-rw-r--r--packages/monotone/.mtn2git_empty0
-rw-r--r--packages/monotone/files/.mtn2git_empty0
-rw-r--r--packages/monotone/files/txt2c-cross.patch15
-rw-r--r--packages/monotone/monotone_0.19.bb34
4 files changed, 49 insertions, 0 deletions
diff --git a/packages/monotone/.mtn2git_empty b/packages/monotone/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/monotone/.mtn2git_empty
diff --git a/packages/monotone/files/.mtn2git_empty b/packages/monotone/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/monotone/files/.mtn2git_empty
diff --git a/packages/monotone/files/txt2c-cross.patch b/packages/monotone/files/txt2c-cross.patch
new file mode 100644
index 0000000000..a50b8135fc
--- /dev/null
+++ b/packages/monotone/files/txt2c-cross.patch
@@ -0,0 +1,15 @@
+# txt2c runs (only) on the build system. This is a fairly horrible
+# hack to make it compile with the build system compiler, not the
+# target compiler.
+
+--- monotone-0.19/Makefile.am.orig 2005-07-04 23:39:44.420722558 -0700
++++ monotone-0.19/Makefile.am 2005-07-04 23:36:50.267121331 -0700
+@@ -356,7 +356,7 @@
+ CLEANFILES = $(BUILT_SOURCES_CLEAN) $(EPS_FIGURES)
+
+ txt2c: txt2c.cc Makefile
+- $(CXX) -Wall -o $@ $<
++ $(BUILD_CXX) -Wall -o $@ $<
+ chmod 0755 $@$(EXEEXT)
+
+ apidocs:
diff --git a/packages/monotone/monotone_0.19.bb b/packages/monotone/monotone_0.19.bb
new file mode 100644
index 0000000000..3bf4608970
--- /dev/null
+++ b/packages/monotone/monotone_0.19.bb
@@ -0,0 +1,34 @@
+# This package builds the devio program
+DESCRIPTION = "monotone - an SCM"
+HOMEPAGE = "http://www.venge.net/"
+MAINTAINER = "John Bowler <jbowler@acm.org>"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "MIT"
+SUBV = "1"
+PR = "r0"
+
+SRC_URI = "http://www.venge.net/monotone/downloads/monotone_${PV}-${SUBV}.tar.gz \
+ file://txt2c-cross.patch;patch=1"
+
+PACKAGES = "${PN} ${PN}-doc ${PN}-testsuite"
+tsd = "/home/monotone"
+FILES_${PN}-testsuite = "${tsd}/testsuite ${tsd}/tests"
+
+# no cross compile support - it tries to run the test program even with
+# --enable_ipv6=yes
+EXTRA_OECONF = "--disable-ipv6 \
+ --disable-dependency-tracking \
+ --disable-rpath \
+ --disable-nls \
+ --with-gnu-ld \
+ "
+
+inherit autotools
+
+# This makes the testsuite as a package
+do_install_append() {
+ install -d ${D}${tsd}
+ install -c -m 755 testsuite ${D}${tsd}/testsuite
+ cp -a tests ${D}${tsd}/tests
+}