aboutsummaryrefslogtreecommitdiffstats
path: root/packages/monotone
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-07-06 06:07:15 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-06 06:07:15 +0000
commit6e702c6a8f5ce690de708df66b4d0ea6041dfc52 (patch)
tree164735b90547884bb26ed1f01270fd29d6eb61af /packages/monotone
parent3ee4b9c71f6a01de7ed32a8ad7018a9c45af6b0a (diff)
downloadopenembedded-6e702c6a8f5ce690de708df66b4d0ea6041dfc52.tar.gz
Working (db init capable) version of monotone. r1 fixes an endianness
configuration error in cryptopp - cryptopp was being compiled for a little endian host.
Diffstat (limited to 'packages/monotone')
-rw-r--r--packages/monotone/files/cryptopp-endianness.patch24
-rw-r--r--packages/monotone/monotone_0.19.bb8
2 files changed, 30 insertions, 2 deletions
diff --git a/packages/monotone/files/cryptopp-endianness.patch b/packages/monotone/files/cryptopp-endianness.patch
new file mode 100644
index 0000000000..7abfa7cda1
--- /dev/null
+++ b/packages/monotone/files/cryptopp-endianness.patch
@@ -0,0 +1,24 @@
+--- intel-0.19/cryptopp/config.h.orig 2005-07-05 22:35:21.352503986 -0700
++++ intel-0.19/cryptopp/config.h 2005-07-05 22:35:24.303056731 -0700
+@@ -5,6 +5,13 @@
+
+ // ***************** Important Settings ********************
+
++#if defined(__BYTE_ORDER) && defined(__LITTLE_ENDIAN) && defined(__BIG_ENDIAN)
++# if __BYTE_ORDER == __LITTLE_ENDIAN
++# define IS_LITTLE_ENDIAN
++# elif __BYTE_ORDER == __BIG_ENDIAN
++# define IS_BIG_ENDIAN
++# endif
++#else
+ // define this if running on a big-endian CPU
+ #if !defined(IS_LITTLE_ENDIAN) && (defined(__BIG_ENDIAN__) || defined(__sparc) || defined(__sparc__) || defined(__hppa__) || defined(__mips__) || (defined(__MWERKS__) && !defined(__INTEL__)))
+ # define IS_BIG_ENDIAN
+@@ -15,6 +22,7 @@
+ #ifndef IS_BIG_ENDIAN
+ # define IS_LITTLE_ENDIAN
+ #endif
++#endif /* Linux endiannes macros not defined */
+
+ // define this if you want to disable all OS-dependent features,
+ // such as sockets and OS-provided random number generators
diff --git a/packages/monotone/monotone_0.19.bb b/packages/monotone/monotone_0.19.bb
index 3bf4608970..3faad29b41 100644
--- a/packages/monotone/monotone_0.19.bb
+++ b/packages/monotone/monotone_0.19.bb
@@ -6,10 +6,14 @@ SECTION = "devel"
PRIORITY = "optional"
LICENSE = "MIT"
SUBV = "1"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://www.venge.net/monotone/downloads/monotone_${PV}-${SUBV}.tar.gz \
- file://txt2c-cross.patch;patch=1"
+ file://txt2c-cross.patch;patch=1 \
+ file://cryptopp-endianness.patch;patch=1"
+DEPENDS += "boost"
+# Following may be required, not proved yet...
+#TARGET_CFLAGS += "-fno-strict-aliasing"
PACKAGES = "${PN} ${PN}-doc ${PN}-testsuite"
tsd = "/home/monotone"