aboutsummaryrefslogtreecommitdiffstats
path: root/packages/monotone
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-07-12 23:48:44 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-12 23:48:44 +0000
commit86ce136b1940f6ab7617c9722c773a336ff0ae88 (patch)
tree9f2d1c740cd3565439b11dba5a9bc3d48fa4c5c7 /packages/monotone
parent484e160440fa31ecaa9ac4c7659edb67103ae3af (diff)
downloadopenembedded-86ce136b1940f6ab7617c9722c773a336ff0ae88.tar.gz
Working, tested, versions of monotone. These past most aspects of the
test suite. Merge tests (which should fail) get unexpected passes (because, apparently, the command to decode b64 data is not installed), cvs tests fail (run as root) and some tests fail because of the lack of a perl packages. However all tests which have no obvious external failure reason (which is all but about 20 of several hundred tests) succeed apart from the large file test (runs out of memory...) monotone-0.20 is currently disabled because the netsync protocol change means it will not work with the OE 0.19 server.
Diffstat (limited to 'packages/monotone')
-rw-r--r--packages/monotone/files/cryptopp-endianness.patch48
-rw-r--r--packages/monotone/monotone_0.19.bb5
-rw-r--r--packages/monotone/monotone_0.20.bb15
3 files changed, 50 insertions, 18 deletions
diff --git a/packages/monotone/files/cryptopp-endianness.patch b/packages/monotone/files/cryptopp-endianness.patch
index 7abfa7cda1..5d52b079bb 100644
--- a/packages/monotone/files/cryptopp-endianness.patch
+++ b/packages/monotone/files/cryptopp-endianness.patch
@@ -1,24 +1,40 @@
---- intel-0.19/cryptopp/config.h.orig 2005-07-05 22:35:21.352503986 -0700
-+++ intel-0.19/cryptopp/config.h 2005-07-05 22:35:24.303056731 -0700
-@@ -5,6 +5,13 @@
+--- monotone-0.20/.pc/cryptopp-endianness.patch/cryptopp/config.h 2005-07-05 22:56:31.000000000 -0700
++++ monotone-0.20/cryptopp/config.h 2005-07-12 12:01:02.626693397 -0700
+@@ -5,15 +5,28 @@
// ***************** Important Settings ********************
-+#if defined(__BYTE_ORDER) && defined(__LITTLE_ENDIAN) && defined(__BIG_ENDIAN)
-+# if __BYTE_ORDER == __LITTLE_ENDIAN
-+# define IS_LITTLE_ENDIAN
-+# elif __BYTE_ORDER == __BIG_ENDIAN
-+# define IS_BIG_ENDIAN
+-// define this if running on a big-endian CPU
+-#if !defined(IS_LITTLE_ENDIAN) && (defined(__BIG_ENDIAN__) || defined(__sparc) || defined(__sparc__) || defined(__hppa__) || defined(__mips__) || (defined(__MWERKS__) && !defined(__INTEL__)))
+-# define IS_BIG_ENDIAN
+-#endif
+-
+-// define this if running on a little-endian CPU
+-// big endian will be assumed if IS_LITTLE_ENDIAN is not defined
+-#ifndef IS_BIG_ENDIAN
+-# define IS_LITTLE_ENDIAN
++// this is GCC specific, but it is safe - the original version
++// of this file defaulted to little endian without warning...
++// The code will error out if an attempt is made to define
++// IS_LITTLE_ENDIAN or IS_BIG_ENDIAN elsewhere
++#ifndef __BYTE_ORDER
++# include <endian.h>
++# ifndef __BYTE_ORDER
++# error cryptopp needs the correct byte order from the compiler
+# endif
++#endif
++#if defined(IS_LITTLE_ENDIAN) || defined(IS_BIG_ENDIAN)
++ // It doesn't work to define this on the command line, at least
++ // with the original version
++# error cryptopp - unexpected endianness definition
++#endif
++
++#if defined(__LITTLE_ENDIAN) && __BYTE_ORDER == __LITTLE_ENDIAN
++# define IS_LITTLE_ENDIAN
++#elif defined(__BIG_ENDIAN) && __BYTE_ORDER == __BIG_ENDIAN
++# define IS_BIG_ENDIAN
+#else
- // define this if running on a big-endian CPU
- #if !defined(IS_LITTLE_ENDIAN) && (defined(__BIG_ENDIAN__) || defined(__sparc) || defined(__sparc__) || defined(__hppa__) || defined(__mips__) || (defined(__MWERKS__) && !defined(__INTEL__)))
- # define IS_BIG_ENDIAN
-@@ -15,6 +22,7 @@
- #ifndef IS_BIG_ENDIAN
- # define IS_LITTLE_ENDIAN
++# error cryptopp - unknown endianness
#endif
-+#endif /* Linux endiannes macros not defined */
// define this if you want to disable all OS-dependent features,
- // such as sockets and OS-provided random number generators
diff --git a/packages/monotone/monotone_0.19.bb b/packages/monotone/monotone_0.19.bb
index 3faad29b41..276bed4b6f 100644
--- a/packages/monotone/monotone_0.19.bb
+++ b/packages/monotone/monotone_0.19.bb
@@ -6,7 +6,7 @@ SECTION = "devel"
PRIORITY = "optional"
LICENSE = "MIT"
SUBV = "1"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://www.venge.net/monotone/downloads/monotone_${PV}-${SUBV}.tar.gz \
file://txt2c-cross.patch;patch=1 \
@@ -18,6 +18,9 @@ DEPENDS += "boost"
PACKAGES = "${PN} ${PN}-doc ${PN}-testsuite"
tsd = "/home/monotone"
FILES_${PN}-testsuite = "${tsd}/testsuite ${tsd}/tests"
+RDEPENDS_${PN}-testsuite += "bash sed grep cvs"
+# The testsuite also requires the following - not yet available...
+#RDEPENDS_${PN}-testsuite += "patch perl"
# no cross compile support - it tries to run the test program even with
# --enable_ipv6=yes
diff --git a/packages/monotone/monotone_0.20.bb b/packages/monotone/monotone_0.20.bb
index dc7abc72b4..05c59ba5ca 100644
--- a/packages/monotone/monotone_0.20.bb
+++ b/packages/monotone/monotone_0.20.bb
@@ -5,7 +5,17 @@ MAINTAINER = "John Bowler <jbowler@acm.org>"
SECTION = "devel"
PRIORITY = "optional"
LICENSE = "MIT"
-PR = "r0"
+PR = "r1"
+
+#WARNING: monotone-0.20 uses a new netsync protocol, at present the
+# OpenEmbedded monotone archives use monotone-0.19 as the server,
+# therefore OE builds of 0.20 are disabled here. The protocol version
+# is checked, 0.19 has version 4, 0.20 has version 5, it is not
+# possible to pull using 0.20 from a 0.19 server.
+# The 0.20 and 0.19 databases (the files) are compatible, so it is
+# possible to use 0.20 then swap back to 0.19 for netsync with the
+# older server.
+DEFAULT_PREFERENCE = "-1"
SRC_URI = "http://venge.net/monotone/downloads/monotone-${PV}.tar.gz \
file://txt2c-cross.patch;patch=1 \
@@ -17,6 +27,9 @@ DEPENDS += "boost"
PACKAGES = "${PN} ${PN}-doc ${PN}-testsuite"
tsd = "/home/monotone"
FILES_${PN}-testsuite = "${tsd}/testsuite ${tsd}/tests"
+RDEPENDS_${PN}-testsuite += "bash sed grep cvs"
+# The testsuite also requires the following - not yet available...
+#RDEPENDS_${PN}-testsuite += "patch perl"
# no cross compile support - it tries to run the test program even with
# --enable_ipv6=yes