aboutsummaryrefslogtreecommitdiffstats
path: root/packages/monotone
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-07-15 06:23:53 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-15 06:23:53 +0000
commit88320ffdf3926d7638b6f3fb0b9e9eebd7fe226c (patch)
tree3c2f5113ef9dc66a65c1b820a7462097443c5d19 /packages/monotone
parent6e97c64f8574ffd096471d11edf871f9ae242cff (diff)
downloadopenembedded-88320ffdf3926d7638b6f3fb0b9e9eebd7fe226c.tar.gz
mpd does not build on osuclibc because libvorbis will not build, that
happens because it attempts a static link with the -lm library in the wrong place. monotone split into two versions, one for the netsync-4 versions (up to and including 0.19) one for netsync-5 versions. Both may be installed on one NSLU2, allowing the system to handle both <=0.19 and >=0.20 servers.
Diffstat (limited to 'packages/monotone')
-rw-r--r--packages/monotone/monotone-4_0.19.bb (renamed from packages/monotone/monotone_0.19.bb)19
-rw-r--r--packages/monotone/monotone-5_0.20.bb (renamed from packages/monotone/monotone_0.20.bb)29
2 files changed, 30 insertions, 18 deletions
diff --git a/packages/monotone/monotone_0.19.bb b/packages/monotone/monotone-4_0.19.bb
index 276bed4b6f..b90f0eacb9 100644
--- a/packages/monotone/monotone_0.19.bb
+++ b/packages/monotone/monotone-4_0.19.bb
@@ -6,7 +6,7 @@ SECTION = "devel"
PRIORITY = "optional"
LICENSE = "MIT"
SUBV = "1"
-PR = "r2"
+PR = "r0"
SRC_URI = "http://www.venge.net/monotone/downloads/monotone_${PV}-${SUBV}.tar.gz \
file://txt2c-cross.patch;patch=1 \
@@ -16,12 +16,14 @@ DEPENDS += "boost"
#TARGET_CFLAGS += "-fno-strict-aliasing"
PACKAGES = "${PN} ${PN}-doc ${PN}-testsuite"
-tsd = "/home/monotone"
+tsd = "/home/monotone/${PN}"
FILES_${PN}-testsuite = "${tsd}/testsuite ${tsd}/tests"
RDEPENDS_${PN}-testsuite += "bash sed grep cvs"
# The testsuite also requires the following - not yet available...
#RDEPENDS_${PN}-testsuite += "patch perl"
+S = "${WORKDIR}/monotone-${PV}"
+
# no cross compile support - it tries to run the test program even with
# --enable_ipv6=yes
EXTRA_OECONF = "--disable-ipv6 \
@@ -31,11 +33,20 @@ EXTRA_OECONF = "--disable-ipv6 \
--with-gnu-ld \
"
-inherit autotools
+inherit autotools update-alternatives
+
+ALTERNATIVE_NAME = "monotone"
+ALTERNATIVE_LINK = "${bindir}/monotone"
+ALTERNATIVE_PATH = "${bindir}/${PN}"
+ALTERNATIVE_PRIORITY = "40"
+
-# This makes the testsuite as a package
+# This makes the testsuite as a package and renames the monotone executable
+# to include the netsync suffix.
do_install_append() {
install -d ${D}${tsd}
install -c -m 755 testsuite ${D}${tsd}/testsuite
cp -a tests ${D}${tsd}/tests
+ #
+ mv ${D}${bindir}/monotone ${D}${bindir}/${PN}
}
diff --git a/packages/monotone/monotone_0.20.bb b/packages/monotone/monotone-5_0.20.bb
index 05c59ba5ca..ec98ec26d2 100644
--- a/packages/monotone/monotone_0.20.bb
+++ b/packages/monotone/monotone-5_0.20.bb
@@ -5,17 +5,7 @@ MAINTAINER = "John Bowler <jbowler@acm.org>"
SECTION = "devel"
PRIORITY = "optional"
LICENSE = "MIT"
-PR = "r1"
-
-#WARNING: monotone-0.20 uses a new netsync protocol, at present the
-# OpenEmbedded monotone archives use monotone-0.19 as the server,
-# therefore OE builds of 0.20 are disabled here. The protocol version
-# is checked, 0.19 has version 4, 0.20 has version 5, it is not
-# possible to pull using 0.20 from a 0.19 server.
-# The 0.20 and 0.19 databases (the files) are compatible, so it is
-# possible to use 0.20 then swap back to 0.19 for netsync with the
-# older server.
-DEFAULT_PREFERENCE = "-1"
+PR = "r0"
SRC_URI = "http://venge.net/monotone/downloads/monotone-${PV}.tar.gz \
file://txt2c-cross.patch;patch=1 \
@@ -25,12 +15,14 @@ DEPENDS += "boost"
#TARGET_CFLAGS += "-fno-strict-aliasing"
PACKAGES = "${PN} ${PN}-doc ${PN}-testsuite"
-tsd = "/home/monotone"
+tsd = "/home/monotone/${PN}"
FILES_${PN}-testsuite = "${tsd}/testsuite ${tsd}/tests"
RDEPENDS_${PN}-testsuite += "bash sed grep cvs"
# The testsuite also requires the following - not yet available...
#RDEPENDS_${PN}-testsuite += "patch perl"
+S = "${WORKDIR}/monotone-${PV}"
+
# no cross compile support - it tries to run the test program even with
# --enable_ipv6=yes
EXTRA_OECONF = "--disable-ipv6 \
@@ -40,11 +32,20 @@ EXTRA_OECONF = "--disable-ipv6 \
--with-gnu-ld \
"
-inherit autotools
+inherit autotools update-alternatives
+
+ALTERNATIVE_NAME = "monotone"
+ALTERNATIVE_LINK = "${bindir}/monotone"
+ALTERNATIVE_PATH = "${bindir}/${PN}"
+ALTERNATIVE_PRIORITY = "50"
+
-# This makes the testsuite as a package
+# This makes the testsuite as a package and renames the monotone executable
+# to include the netsync suffix.
do_install_append() {
install -d ${D}${tsd}
install -c -m 755 testsuite ${D}${tsd}/testsuite
cp -a tests ${D}${tsd}/tests
+ #
+ mv ${D}${bindir}/monotone ${D}${bindir}/${PN}
}