aboutsummaryrefslogtreecommitdiffstats
path: root/packages/mozilla/firefox-1.0.7
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2007-05-07 11:31:23 +0000
committerGraeme Gregory <dp@xora.org.uk>2007-05-07 11:31:23 +0000
commit9bde98efe0f773f113eefe26762c2fd1bcc64b16 (patch)
tree2c961f585a30348649da951d234e8c541584739e /packages/mozilla/firefox-1.0.7
parent15df48be127ab405f0696157b522a4d2a6048c22 (diff)
downloadopenembedded-9bde98efe0f773f113eefe26762c2fd1bcc64b16.tar.gz
firefox_1.0.7.bb : add patch from
http://article.gmane.org/gmane.linux.debian.ports.arm/4082 by Lennert Buytenhek fix a small QA issue firefox_2.0.0.3 : new version with same patch as above added.
Diffstat (limited to 'packages/mozilla/firefox-1.0.7')
-rw-r--r--packages/mozilla/firefox-1.0.7/mozilla-eabi.patch28
-rw-r--r--packages/mozilla/firefox-1.0.7/xptcinvoke-arm.patch11
2 files changed, 39 insertions, 0 deletions
diff --git a/packages/mozilla/firefox-1.0.7/mozilla-eabi.patch b/packages/mozilla/firefox-1.0.7/mozilla-eabi.patch
new file mode 100644
index 0000000000..c12f6ef04e
--- /dev/null
+++ b/packages/mozilla/firefox-1.0.7/mozilla-eabi.patch
@@ -0,0 +1,28 @@
+Index: mozilla/nsprpub/pr/src/misc/prdtoa.c
+===================================================================
+--- mozilla.orig/nsprpub/pr/src/misc/prdtoa.c 2004-03-12 07:30:50.000000000 +0000
++++ mozilla/nsprpub/pr/src/misc/prdtoa.c 2007-05-07 11:35:10.000000000 +0100
+@@ -132,8 +132,8 @@
+ * is not strictly legal and can cause trouble with aggressively
+ * optimizing compilers (e.g., gcc 2.95.1 under -O2).
+ */
+-#if defined(__arm) || defined(__arm__) || defined(__arm26__) \
+- || defined(__arm32__)
++#if (defined(__arm) || defined(__arm__) || defined(__arm26__) \
++ || defined(__arm32__)) && !defined(__ARM_EABI__) && !defined(__ARMEB__)
+ #define IEEE_ARM
+ #elif defined(IS_LITTLE_ENDIAN)
+ #define IEEE_8087
+Index: mozilla/nsprpub/pr/include/md/_linux.h
+===================================================================
+--- mozilla.orig/nsprpub/pr/include/md/_linux.h 2005-05-04 19:06:17.000000000 +0100
++++ mozilla/nsprpub/pr/include/md/_linux.h 2007-05-07 11:34:16.000000000 +0100
+@@ -285,7 +285,7 @@
+ #error "Linux/MIPS pre-glibc2 not supported yet"
+ #endif /* defined(__GLIBC__) && __GLIBC__ >= 2 */
+
+-#elif defined(__arm__)
++#elif defined(__arm__) && !defined(__ARM_EABI__)
+ /* ARM/Linux */
+ #if defined(__GLIBC__) && __GLIBC__ >= 2
+ #define _MD_GET_SP(_t) (_t)->md.context[0].__jmpbuf[20]
diff --git a/packages/mozilla/firefox-1.0.7/xptcinvoke-arm.patch b/packages/mozilla/firefox-1.0.7/xptcinvoke-arm.patch
new file mode 100644
index 0000000000..bc0c6f4e5c
--- /dev/null
+++ b/packages/mozilla/firefox-1.0.7/xptcinvoke-arm.patch
@@ -0,0 +1,11 @@
+--- iceweasel-2.0.0.1+dfsg.orig/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_arm.cpp
++++ iceweasel-2.0.0.1+dfsg/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_arm.cpp
+@@ -212,7 +212,7 @@
+ "add sp, sp, r4 \n\t" /* restore stack pointer */
+ "mov %0, r0 \n\t" /* the result... */
+ : "=r" (result)
+- : "r" (&my_params)
++ : "r" (&my_params), "m" (my_params)
+ : "r0", "r1", "r2", "r3", "r4", "ip", "lr", "sp"
+ );
+