aboutsummaryrefslogtreecommitdiffstats
path: root/packages/mozilla/firefox_3.1b1.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2008-10-15 10:08:06 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2008-10-15 10:08:06 +0200
commitbd558780fab1e8e00d715e4bac3ee2fa86ac179c (patch)
treed43d4fc75eca13a457eb0ef4c705b36a53fc4465 /packages/mozilla/firefox_3.1b1.bb
parent41520d2ae8fee5ad97807a42bc93016ac892aaaf (diff)
downloadopenembedded-bd558780fab1e8e00d715e4bac3ee2fa86ac179c.tar.gz
firefox 3.1: move from alpha2 to beta1
Diffstat (limited to 'packages/mozilla/firefox_3.1b1.bb')
-rw-r--r--packages/mozilla/firefox_3.1b1.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/packages/mozilla/firefox_3.1b1.bb b/packages/mozilla/firefox_3.1b1.bb
new file mode 100644
index 0000000000..eac4adcb75
--- /dev/null
+++ b/packages/mozilla/firefox_3.1b1.bb
@@ -0,0 +1,47 @@
+DEPENDS += "cairo"
+
+PV = "3.0.1+3.1b1"
+MOZPV = "3.1b1"
+PR = "r0"
+
+SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/${MOZPV}-candidates/build2/source/firefox-${MOZPV}-source.tar.bz2 \
+ file://jsautocfg.h \
+ file://jsautocfg-dontoverwrite.patch;patch=1 \
+ file://random_to_urandom.diff;patch=1 \
+"
+
+S = "${WORKDIR}/mozilla-central"
+
+DEFAULT_PREFERENCE = "-1"
+
+inherit mozilla
+require firefox.inc
+
+export HOST_LIBIDL_CONFIG = "${STAGING_BINDIR_NATIVE}/libIDL-config-2"
+FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2"
+
+do_configure_prepend() {
+ sed -i -e s:'head -1':'head -n1':g client.mk
+ oe_runmake -f client.mk CONFIGURE_ARGS="${EXTRA_OECONF}" configure
+}
+
+do_compile_prepend() {
+ cp ${WORKDIR}/jsautocfg.h ${S}/js/src/
+ sed -i -e "s|CPU_ARCH =|CPU_ARCH = ${TARGET_ARCH}|" \
+ -e s:'$(OS_TEST)':${TARGET_ARCH}:g \
+ ${S}/security/coreconf/Linux.mk
+}
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/firefox-${MOZPV}
+ cd dist/sdk/include
+ rm -rf obsolete
+ headers=`find . -name "*.h"`
+ for f in $headers
+ do
+ install -D -m 0644 $f ${STAGING_INCDIR}/firefox-${MOZPV}/
+ done
+ # removes 2 lines that call absent headers
+ sed -e '178,179d' ${STAGING_INCDIR}/firefox-${MOZPV}/nsIServiceManager.h
+}
+