aboutsummaryrefslogtreecommitdiffstats
path: root/packages/mozilla
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2005-08-16 14:05:24 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-16 14:05:24 +0000
commit7aa70994069bcbd6031893316558ea88fd5f8539 (patch)
tree9a3688d25cc8b0f7552f79a3eebe0f4c6ade453b /packages/mozilla
parentbcd1a806faaf20c16b1fff5e3a203e94a3d32208 (diff)
downloadopenembedded-7aa70994069bcbd6031893316558ea88fd5f8539.tar.gz
thunderbird: added version 1.0.6 of thunderbird
Diffstat (limited to 'packages/mozilla')
-rw-r--r--packages/mozilla/thunderbird-1.0.6/.mtn2git_empty0
-rw-r--r--packages/mozilla/thunderbird-1.0.6/extensions-hack.patch10
-rw-r--r--packages/mozilla/thunderbird-1.0.6/mozconfig49
-rw-r--r--packages/mozilla/thunderbird_1.0.6.bb63
4 files changed, 122 insertions, 0 deletions
diff --git a/packages/mozilla/thunderbird-1.0.6/.mtn2git_empty b/packages/mozilla/thunderbird-1.0.6/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/mozilla/thunderbird-1.0.6/.mtn2git_empty
diff --git a/packages/mozilla/thunderbird-1.0.6/extensions-hack.patch b/packages/mozilla/thunderbird-1.0.6/extensions-hack.patch
new file mode 100644
index 0000000000..b3906b2be6
--- /dev/null
+++ b/packages/mozilla/thunderbird-1.0.6/extensions-hack.patch
@@ -0,0 +1,10 @@
+--- mozilla/toolkit/mozapps/extensions/src/nsExtensionManager.js.in.old 2004-08-03 11:45:51.000000000 +0100
++++ mozilla/toolkit/mozapps/extensions/src/nsExtensionManager.js.in 2004-08-03 11:46:04.000000000 +0100
+@@ -1429,6 +1429,7 @@
+ win.close();
+
+ }
++ needsRestart = false;
+ return needsRestart;
+ },
+
diff --git a/packages/mozilla/thunderbird-1.0.6/mozconfig b/packages/mozilla/thunderbird-1.0.6/mozconfig
new file mode 100644
index 0000000000..b48cb7398d
--- /dev/null
+++ b/packages/mozilla/thunderbird-1.0.6/mozconfig
@@ -0,0 +1,49 @@
+ac_add_options --with-pthreads
+ac_add_options --disable-freetype2
+ac_add_options --disable-xprint
+ac_add_options --enable-crypto
+ac_add_options --disable-jsd
+ac_add_options --disable-oji
+ac_add_options --disable-accessibility
+ac_add_options --enable-single-profile
+ac_add_options --disable-composer
+ac_add_options --enable-extensions=pref,spellcheck,universalchardet,wallet
+ac_add_options --disable-ldap
+ac_add_options --disable-mathml
+ac_add_options --disable-installer
+ac_add_options --disable-activex
+ac_add_options --disable-activex-scripting
+ac_add_options --disable-tests
+ac_add_options --disable-logging
+ac_add_options --enable-reorder
+ac_add_options --enable-strip
+ac_add_options --enable-elf-dynstr-gc
+ac_add_options --enable-xterm-updates
+ac_add_options --with-default-mozilla-five-home=/usr/lib/thunderbird-0.7.3
+ac_add_options --disable-pedantic
+ac_add_options --disable-profilesharing
+ac_add_options --disable-profilelocking
+ac_add_options --disable-necko-disk-cache
+ac_add_options --enable-necko-small-buffers
+
+# use GTK+-2 widget set with XFT font rendering
+ac_add_options --enable-default-toolkit=gtk2
+ac_add_options --enable-xft
+ac_add_options --disable-freetype2
+
+ac_add_options --with-system-zlib
+ac_add_options --with-system-jpeg
+ac_add_options --with-system-png
+
+# build minimal set of protocol handlers
+ac_add_options --enable-necko-protocols=http,file,res,jar,viewsource
+
+# build minimal set of image decoders
+ac_add_options --enable-image-decoders=png,gif,jpeg
+
+export MOZ_THUNDERBIRD=1
+mk_add_options MOZ_THUNDERBIRD=1
+export BUILD_OFFICIAL=1
+export MOZILLA_OFFICIAL=1
+mk_add_options BUILD_OFFICIAL=1
+mk_add_options MOZILLA_OFFICIAL=1
diff --git a/packages/mozilla/thunderbird_1.0.6.bb b/packages/mozilla/thunderbird_1.0.6.bb
new file mode 100644
index 0000000000..52d68ef481
--- /dev/null
+++ b/packages/mozilla/thunderbird_1.0.6.bb
@@ -0,0 +1,63 @@
+SECTION = "x11/utils"
+DEPENDS += "gnupg"
+RRECOMMENDS += "gnupg"
+PR = "r0"
+
+EMVER="0.92.0"
+IPCVER="1.1.3"
+SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/${PV}/source/thunderbird-${PV}-source.tar.bz2 \
+ http://downloads.mozdev.org/enigmail/src/enigmail-${EMVER}.tar.gz \
+http://downloads.mozdev.org/enigmail/src/ipc-${IPCVER}.tar.gz \
+ file://xptcstubs.patch;patch=1 \
+ file://no-xmb.patch;patch=1 \
+ file://extensions-hack.patch;patch=1 \
+ file://mozilla-thunderbird.png file://mozilla-thunderbird.desktop"
+S = "${WORKDIR}/mozilla"
+
+FILES_${PN} += "${libdir}/thunderbird-${PV} ${datadir}/idl"
+
+inherit mozilla
+
+export MOZ_THUNDERBIRD=1
+
+do_configure() {
+ for x in ipc enigmail; do
+ if [ ! -e ${WORKDIR}/mozilla/extensions/$x ]; then
+ mv ${WORKDIR}/$x ${WORKDIR}/mozilla/extensions/
+ cd ${WORKDIR}/mozilla/extensions/$x
+ makemake
+ fi
+ done
+ cd ${S}
+ mozilla_do_configure
+}
+
+do_compile() {
+ mozilla_do_compile
+ oe_runmake -C ${WORKDIR}/mozilla/extensions/ipc
+ oe_runmake -C ${WORKDIR}/mozilla/extensions/enigmail
+}
+
+do_install() {
+ mozilla_do_install
+ oe_runmake -C ${WORKDIR}/mozilla/extensions/ipc DESTDIR="${D}" install
+ oe_runmake -C ${WORKDIR}/mozilla/extensions/enigmail DESTDIR="${D}" install
+ install -d ${D}${datadir}/applications
+ install -d ${D}${datadir}/pixmaps
+ install -m 0644 ${WORKDIR}/mozilla-thunderbird.desktop ${D}${datadir}/applications/
+ install -m 0644 ${WORKDIR}/mozilla-thunderbird.png ${D}${datadir}/pixmaps/
+}
+
+pkg_postinst_thunderbird() {
+ chmod -R a+w ${libdir}/thunderbird*
+}
+
+# Simulate the silly csh makemake script
+makemake() {
+ typeset m topdir
+ for m in $(find . -name Makefile.in); do
+ topdir=$(echo "$m" | sed -r 's:[^/]+:..:g')
+ sed -e "s:@srcdir@:.:g" -e "s:@top_srcdir@:${topdir}:g" \
+ < ${m} > ${m%.in} || die "sed ${m} failed"
+ done
+}