aboutsummaryrefslogtreecommitdiffstats
path: root/packages/mtd
diff options
context:
space:
mode:
authorMartin Dietze <di@fh-wedel.de>2006-09-14 10:08:41 +0000
committerMartin Dietze <di@fh-wedel.de>2006-09-14 10:08:41 +0000
commit12cd0aac93821b11ea27f54ff4e82b6b356e3511 (patch)
tree64c2c94b1e45908f3d4fef320242a5be4c6991f9 /packages/mtd
parent68bd8370dafde79536cc79b4ac794e41ed122ce1 (diff)
downloadopenembedded-12cd0aac93821b11ea27f54ff4e82b6b356e3511.tar.gz
mtn: added configuration for cvs20041113 version of mtd-utils which works for nylon/mtx-[12].
Diffstat (limited to 'packages/mtd')
-rw-r--r--packages/mtd/mtd-utils/add-exclusion-to-mkfs-jffs2-20041113.patch107
-rw-r--r--packages/mtd/mtd-utils/target-endian.patch11
-rw-r--r--packages/mtd/mtd-utils_0.0.0+cvs20041113.bb36
3 files changed, 154 insertions, 0 deletions
diff --git a/packages/mtd/mtd-utils/add-exclusion-to-mkfs-jffs2-20041113.patch b/packages/mtd/mtd-utils/add-exclusion-to-mkfs-jffs2-20041113.patch
new file mode 100644
index 0000000000..cb819e19be
--- /dev/null
+++ b/packages/mtd/mtd-utils/add-exclusion-to-mkfs-jffs2-20041113.patch
@@ -0,0 +1,107 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- mtd/util/mkfs.jffs2.c~add-exclusion-to-mkfs-jffs2.patch
++++ mtd/util/mkfs.jffs2.c
+@@ -89,7 +89,12 @@
+ struct filesystem_entry *files; /* Only relevant to directories */
+ };
+
++struct ignorepath_entry {
++ struct ignorepath_entry* next; /* Points to the next ignorepath element */
++ char name[PATH_MAX]; /* Name of the entry */
++};
+
++static struct ignorepath_entry* ignorepath = 0;
+ static int out_fd = -1;
+ static char default_rootdir[] = ".";
+ static char *rootdir = default_rootdir;
+@@ -363,6 +368,7 @@
+ char *hpath, *tpath;
+ struct dirent *dp, **namelist;
+ struct filesystem_entry *entry;
++ struct ignorepath_entry* element = ignorepath;
+
+
+ if (lstat(hostpath, &sb)) {
+@@ -372,6 +378,15 @@
+ entry = add_host_filesystem_entry(targetpath, hostpath,
+ sb.st_uid, sb.st_gid, sb.st_mode, 0, parent);
+
++ while ( element ) {
++ if ( strcmp( element->name, hostpath ) == 0 ) {
++ printf( "Note: ignoring directories below '%s'\n", hostpath );
++ return entry;
++ break;
++ }
++ element = element->next;
++ }
++
+ n = scandir(hostpath, &namelist, 0, alphasort);
+ if (n < 0) {
+ perror_msg_and_die("opening directory %s", hostpath);
+@@ -1139,6 +1154,7 @@
+ {"root", 1, NULL, 'r'},
+ {"pagesize", 1, NULL, 's'},
+ {"eraseblock", 1, NULL, 'e'},
++ {"ignore", 1, NULL, 'i'},
+ {"output", 1, NULL, 'o'},
+ {"help", 0, NULL, 'h'},
+ {"verbose", 0, NULL, 'v'},
+@@ -1180,6 +1196,7 @@
+ " -L, --list-compressors Show the list of the avaiable compressors\n"
+ " -t, --test-compression Call decompress and compare with the original (for test)\n"
+ " -n, --no-cleanmarkers Don't add a cleanmarker to every eraseblock\n"
++ " -i, --ignore=PATH Ignore sub directory and file tree below PATH when recursing over the file system\n"
+ " -o, --output=FILE Output to FILE (default: stdout)\n"
+ " -l, --little-endian Create a little-endian filesystem\n"
+ " -b, --big-endian Create a big-endian filesystem\n"
+@@ -1202,13 +1219,14 @@
+ struct stat sb;
+ FILE *devtable = NULL;
+ struct filesystem_entry *root;
+- char *compr_name = NULL;
+- int compr_prior = -1;
++ char *compr_name = NULL;
++ int compr_prior = -1;
++ struct ignorepath_entry* element = ignorepath;
+
+- jffs2_compressors_init();
++ jffs2_compressors_init();
+
+ while ((opt = getopt_long(argc, argv,
+- "D:d:r:s:o:qUPfh?vVe:lbp::nc:m:x:X:Lty:", long_options, &c)) >= 0)
++ "D:d:r:s:i:o:qUPfh?vVe:lbp::nc:m:x:X:Lty:", long_options, &c)) >= 0)
+ {
+ switch (opt) {
+ case 'D':
+@@ -1231,6 +1249,27 @@
+ page_size = strtol(optarg, NULL, 0);
+ break;
+
++ case 'i':
++ printf( "Note: Adding '%s' to ignore Path\n", optarg );
++ if ( !ignorepath ) {
++ ignorepath = xmalloc( sizeof( struct ignorepath_entry ) );
++ ignorepath->next = 0;
++ strcpy( &ignorepath->name[0], optarg );
++ } else {
++ while ( element->next ) element = element->next;
++ element->next = xmalloc( sizeof( struct ignorepath_entry ) );
++ element->next->next = 0;
++ strcpy( &element->next->name[0], optarg );
++ }
++ printf( "--------- Dumping ignore path list ----------------\n" );
++ element=ignorepath;
++ while ( element ) {
++ printf( " * '%s'\n", &element->name[0] );
++ element = element->next;
++ }
++ printf( "---------------------------------------------------\n" );
++ break;
++
+ case 'o':
+ if (out_fd != -1) {
+ error_msg_and_die("output filename specified more than once");
diff --git a/packages/mtd/mtd-utils/target-endian.patch b/packages/mtd/mtd-utils/target-endian.patch
new file mode 100644
index 0000000000..567730ce31
--- /dev/null
+++ b/packages/mtd/mtd-utils/target-endian.patch
@@ -0,0 +1,11 @@
+--- mtd/util/flash_eraseall.c 2004-09-12 00:00:13.000000000 +0200
++++ mtd-new/util/flash_eraseall.c 2005-08-16 11:36:46.262783496 +0200
+@@ -54,7 +54,7 @@
+ static void display_help (void);
+ static void display_version (void);
+ static struct jffs2_unknown_node cleanmarker;
+-static int target_endian = __BYTE_ORDER;
++int target_endian = __BYTE_ORDER;
+
+ int main (int argc, char *argv[])
+ {
diff --git a/packages/mtd/mtd-utils_0.0.0+cvs20041113.bb b/packages/mtd/mtd-utils_0.0.0+cvs20041113.bb
new file mode 100644
index 0000000000..3cc1878431
--- /dev/null
+++ b/packages/mtd/mtd-utils_0.0.0+cvs20041113.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "Tools for managing memory technology devices."
+SECTION = "base"
+DEPENDS = "zlib"
+HOMEPAGE = "http://www.linux-mtd.infradead.org/"
+LICENSE = "GPLv2"
+PR = "r2"
+SRCDATE = "20041113"
+
+SRC_URI = "cvs://anoncvs:anoncvs@cvs.infradead.org/home/cvs;module=mtd \
+ file://add-exclusion-to-mkfs-jffs2-20041113.patch;patch=1" \
+ file://target-endian.patch;patch=1"
+
+S = "${WORKDIR}/mtd"
+
+
+CFLAGS_prepend = "-I${S}/include "
+
+do_compile () {
+ oe_runmake -C util
+}
+
+do_stage () {
+ install -d ${STAGING_INCDIR}/mtd
+ for f in ${S}/include/mtd/*.h; do
+ install -m 0644 $f ${STAGING_INCDIR}/mtd/
+ done
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ for binary in ftl_format flash_erase flash_eraseall nanddump doc_loadbios \
+ mkfs.jffs ftl_check mkfs.jffs2 flash_lock flash_unlock flash_info mtd_debug \
+ flashcp nandwrite jffs2dump; do
+ install -m 0755 util/$binary ${D}${bindir}
+ done
+}