aboutsummaryrefslogtreecommitdiffstats
path: root/packages/musicpd
diff options
context:
space:
mode:
authorMatthias Goebl <oe@m.goebl.net>2006-02-05 23:24:19 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-05 23:24:19 +0000
commit062e000a4691d4884a3ae0233246fb259a335969 (patch)
treedfba3a9b4491fe1d8cce103cab66c295bdeb03f3 /packages/musicpd
parent64e88ccf6b78e01b5f53a21a026f855ed7783716 (diff)
downloadopenembedded-062e000a4691d4884a3ae0233246fb259a335969.tar.gz
musicpd/mpd-alsa_0.11.5.bb: Add mpd-package with alsa support
- Make mpd-alsa_0.11.5.bb from mpd_0.11.5.bb and add alsa-lib and libao dependency (./configure will add alsa support) (mpd not only uses alsa indirectly via libao, but also directly for mixer support)
Diffstat (limited to 'packages/musicpd')
-rw-r--r--packages/musicpd/mpd-alsa_0.11.5.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/packages/musicpd/mpd-alsa_0.11.5.bb b/packages/musicpd/mpd-alsa_0.11.5.bb
new file mode 100644
index 0000000000..d4ee65abba
--- /dev/null
+++ b/packages/musicpd/mpd-alsa_0.11.5.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Music Player Daemon (mpd). This version is configured for alsa support"
+HOMEPAGE = "http://www.musicpd.org"
+LICENSE = "GPLv2"
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+SECTION = "console/multimedia"
+DEPENDS = "libvorbis libogg libid3tag libao-alsa zlib libmikmod libmad flac audiofile virtual/libiconv"
+RDEPENDS = "libao-alsa"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/musicpd/mpd-${PV}.tar.gz \
+ file://mpd/save-volume-state.patch;patch=1 file://mpd/mpd.init"
+S = "${WORKDIR}/mpd-${PV}"
+
+inherit autotools update-rc.d
+INITSCRIPT_NAME = "mpd"
+
+# Setting --enable-mpd-{mad,id3tag} causes local caches of the libraries to
+# be built, instead we use the OE built versions which should be installed
+# in staging - remove the --with and replace with --enable to use the local
+# versions.
+
+EXTRA_OECONF = "--enable-ogg \
+ --with-id3tag-libraries=${STAGING_LIBDIR} \
+ --with-id3tag-includes=${STAGING_INCDIR} \
+ --with-mad-libraries=${STAGING_LIBDIR} \
+ --with-mad-includes=${STAGING_INCDIR} \
+ --without-faad"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 755 ${WORKDIR}/mpd/mpd.init ${D}${sysconfdir}/init.d/mpd
+}