aboutsummaryrefslogtreecommitdiffstats
path: root/packages/musicpd
diff options
context:
space:
mode:
authorJustin Patrin <papercrane@gmail.com>2007-01-23 20:37:15 +0000
committerJustin Patrin <papercrane@gmail.com>2007-01-23 20:37:15 +0000
commitcb2e4e296f4c3c753f6c9b90165084dff53098f3 (patch)
tree8985497cc71f6bfb3beec2e0dcebbd5b836da747 /packages/musicpd
parent0a59f436a0caddc2e373e3520a72f5942df75e07 (diff)
downloadopenembedded-cb2e4e296f4c3c753f6c9b90165084dff53098f3.tar.gz
mpd: add mpd_svn as 0.12.x releases have problems with autoreconf
Diffstat (limited to 'packages/musicpd')
-rw-r--r--packages/musicpd/mpd_svn.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/packages/musicpd/mpd_svn.bb b/packages/musicpd/mpd_svn.bb
new file mode 100644
index 0000000000..bc10a923fb
--- /dev/null
+++ b/packages/musicpd/mpd_svn.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Music Player Daemon (mpd)"
+HOMEPAGE = "http://www.musicpd.org"
+LICENSE = "GPLv2"
+SECTION = "console/multimedia"
+DEPENDS = "libvorbis libogg libid3tag libao zlib libmikmod libmad flac audiofile virtual/libiconv faad2"
+SRCDATE = "20070120"
+PV = "0.12.1+svn${SRCDATE}"
+PR = "r0"
+
+SRC_URI = "svn://svn.musicpd.org/mpd;module=trunk;proto=https"
+# file://save-volume-state.patch;patch=1"
+S = "${WORKDIR}/trunk"
+
+inherit autotools
+
+# Setting --enable-mpd-{mad,id3tag} causes local caches of the libraries to
+# be built, instead we use the OE built versions which should be installed
+# in staging - remove the --with and replace with --enable to use the local
+# versions.
+
+EXTRA_OECONF = "--enable-ogg \
+ --with-id3tag-libraries=${STAGING_LIBDIR} \
+ --with-id3tag-includes=${STAGING_INCDIR} \
+ --with-mad-libraries=${STAGING_LIBDIR} \
+ --with-mad-includes=${STAGING_INCDIR} \
+ --with-faad-libraries=${STAGING_LIBDIR} \
+ --with-faad-includes=${STAGING_INCDIR} \
+ --disable-jack \
+ --disable-pulse \
+ --enable-mod \
+ --disable-oggflac"
+
+do_compile_prepend() {
+ find -name Makefile | xargs sed -i 's~-I/usr/include~-I${STAGING_INCDIR}~g'
+}