aboutsummaryrefslogtreecommitdiffstats
path: root/packages/mythtv
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-07-22 10:42:25 +0000
committerKoen Kooi <koen@openembedded.org>2008-07-22 10:42:25 +0000
commit97356e8a1c274a2886622226e15937cf110c86f8 (patch)
treeba6d041e5bb30feff34610bb814f466a246de226 /packages/mythtv
parent48e1aea67481a039f2dbd282937e4549d3d63497 (diff)
downloadopenembedded-97356e8a1c274a2886622226e15937cf110c86f8.tar.gz
mythtv: the configure does link tests first (which succeed) and then goes to check if the lib exists in LDPATH. This is bogus, so rig the path check.
Diffstat (limited to 'packages/mythtv')
-rw-r--r--packages/mythtv/mythtv.inc6
-rw-r--r--packages/mythtv/mythtv/configure.patch84
-rw-r--r--packages/mythtv/mythtv_svn.bb20
3 files changed, 99 insertions, 11 deletions
diff --git a/packages/mythtv/mythtv.inc b/packages/mythtv/mythtv.inc
index 3485cca682..9b7a0a768e 100644
--- a/packages/mythtv/mythtv.inc
+++ b/packages/mythtv/mythtv.inc
@@ -2,12 +2,12 @@ DESCRIPTION = "A full featured personal video recorder system."
HOMEPAGE = "http://www.mythtv.org"
LICENSE = "GPL"
SECTION = "x11/multimedia"
-DEPENDS = "libxinerama libxv libxxf86vm libxvmc lirc qt-x11-free"
-RDEPENDS_${PN} = "qt-x11-plugins-sqldrivers qt-x11-plugins-imageformats"
+DEPENDS = "jack alsa-lib lame libxinerama libxv libxxf86vm libxvmc lirc"
+#RDEPENDS_${PN} = "qt-x11-plugins-sqldrivers qt-x11-plugins-imageformats"
SRC_URI = "http://www.mythtv.org/mc/mythtv-${PV}.tar.bz2"
-inherit qmake2 qt3x11
+inherit qmake2 qt4x11
QMAKE_PROFILES = "mythtv.pro"
diff --git a/packages/mythtv/mythtv/configure.patch b/packages/mythtv/mythtv/configure.patch
index 0d5a8fc3c1..feb5e0c00e 100644
--- a/packages/mythtv/mythtv/configure.patch
+++ b/packages/mythtv/mythtv/configure.patch
@@ -1,6 +1,31 @@
--- /tmp/configure 2008-07-22 10:27:56.000000000 +0200
-+++ mythtv/configure 2008-07-22 10:54:24.000000000 +0200
-@@ -1714,7 +1714,7 @@
++++ mythtv/configure 2008-07-22 12:40:06.000000000 +0200
+@@ -476,12 +476,13 @@
+ }
+
+ check_cmd(){
+- log "$@"
++ echo "Checking $@"
++ log "$@"
+ "$@" >>$logfile 2>&1
+ }
+
+ check_cc(){
+- log check_cc "$@"
++ log check_cc "$@"
+ cat >$TMPC
+ log_file $TMPC
+ check_cmd $cc $CFLAGS $ECFLAGS $OPTFLAGS "$@" -c -o $TMPO $TMPC
+@@ -1214,7 +1215,7 @@
+ # build settings
+ SHFLAGS='-shared -Wl,-soname,$@'
+ VHOOKSHFLAGS='$(SHFLAGS)'
+-LDLATEFLAGS='-Wl,-rpath-link,\$(BUILD_ROOT)/libavcodec -Wl,-rpath-link,\$(BUILD_ROOT)/libavformat -Wl,-rpath-link,\$(BUILD_ROOT)/libavutil'
++#LDLATEFLAGS='-Wl,-rpath-link,\$(BUILD_ROOT)/libavcodec -Wl,-rpath-link,\$(BUILD_ROOT)/libavformat -Wl,-rpath-link,\$(BUILD_ROOT)/libavutil'
+ FFSERVERLDFLAGS=-Wl,-E
+ LDCONFIG="ldconfig"
+ LIBPREF="lib"
+@@ -1714,7 +1715,7 @@
has_library()
{
@@ -9,7 +34,7 @@
LIBPATHS=`cat /etc/ld.so.conf | grep -v "#" | grep -v "include"`
else
LIBPATHS=''
-@@ -1725,7 +1725,7 @@
+@@ -1725,7 +1726,7 @@
LIBPATHS="$LIBPATHS `echo $DYLD_LIBRARY_PATH | sed s/':'/' '/g` "
# recurse down just one level, should be enough in most cases
@@ -18,16 +43,61 @@
INCL=`cat /etc/ld.so.conf | grep -v "#" | grep "^include"`
SRCH=`echo "$INCL" | sed '{ s/^include \//\//; s/^include /\/etc\//}'`
for x in $SRCH ; do
-@@ -1734,7 +1734,7 @@
+@@ -1734,29 +1735,31 @@
done
fi
- LIBPATHS="`echo $LIBPATHS /$libdir_name /usr/$libdir_name /usr/local/$libdir_name /usr/X11R6/$libdir_name | sed s/'\/ '/' '/g` "
+ enabled cross_compile || LIBPATHS="`echo $LIBPATHS /$libdir_name /usr/$libdir_name /usr/local/$libdir_name /usr/X11R6/$libdir_name | sed s/'\/ '/' '/g` "
- HAS_IT="no"
+- HAS_IT="no"
++ HAS_IT="yes"
for LIBPATH in $LIBPATHS ; do
-@@ -2254,7 +2254,7 @@
+ if test x`ls $LIBPATH/$1* 2> /dev/null | head -n 1` != x"" ; then
+ HAS_IT="yes"
+ fi
+ done
++ echo "$1: $HAS_IT"
+ expr $HAS_IT : "yes" > /dev/null
+ }
+
+ has_header()
+ {
+- HPATHS="/usr/local/include /usr/include /usr/include/g++-v3 /usr/X11R6/include"
++ enabled cross_compile || HPATHS="/usr/local/include /usr/include /usr/include/g++-v3 /usr/X11R6/include"
+ INCL=`echo $DYLD_LIBRARY_PATH $LD_LIBRARY_PATH | sed s/':'/' '/g`
+ HPATHS="$HPATHS "$(echo $INCL | sed "s/$libdir_name/include/g")
+
+- HAS_IT="no"
++ HAS_IT="yes"
+ for HPATH in $HPATHS ; do
+ if test x`ls $HPATH/$1* 2> /dev/null | head -n 1` != x"" ; then
+ HAS_IT="yes"
+ fi
+ done
++ echo "$1: $HAS_IT"
+ expr $HAS_IT : "yes" > /dev/null
+ }
+
+@@ -1863,13 +1866,15 @@
+ if test x"$cmov" = x"default"; then
+ disable cmov
+ if enabled cpu_override; then
+- is_x86_cmov_cpu "$cpu" && enable cmov
++ disabled cross_compile && is_x86_cmov_cpu "$cpu" && enable cmov
+ disabled cmov || is_x86_slow_cmov_cpu "$cpu" || enable fast_cmov
+ elif expr "$processor_flags" : ".*cmov" > /dev/null ; then
+- enable cmov
++ disabled cross_compile && enable cmov
+ fi
+ fi
+
++enabled cross_compile && disable cmov
++
+ # use different default ARCHFLAGS for CPU missing cmov (Via C3 ...)
+ if test x"$arch" = x"x86_32" && disabled cmov && disabled cpu_override; then
+ ARCHFLAGS="-march=i586"
+@@ -2254,7 +2259,7 @@
EOF
if $cc $CFLAGS $ECFLAGS -o $TMPE $TMPC 2>/dev/null ; then
@@ -36,7 +106,7 @@
fi
# test negative wrap
-@@ -2269,7 +2269,7 @@
+@@ -2269,7 +2274,7 @@
EOF
if $cc $CFLAGS $ECFLAGS -o $TMPE $TMPC 2>/dev/null ; then
diff --git a/packages/mythtv/mythtv_svn.bb b/packages/mythtv/mythtv_svn.bb
index 2d7d7ac938..303462e69f 100644
--- a/packages/mythtv/mythtv_svn.bb
+++ b/packages/mythtv/mythtv_svn.bb
@@ -43,6 +43,22 @@ python __anonymous () {
bb.data.setVar("PACKAGES", packages, d)
}
+
+EXTRA_OECONF_armv5te = " --enable-armv5te "
+EXTRA_OECONF_armv6 = " --enable-armv6 "
+EXTRA_OECONF_armv7a = --enable-armv6"
+
+#build with support for the iwmmxt instruction and pxa270fb overlay support (pxa270 and up)
+#not every iwmmxt machine has the lcd connected to pxafb, but building the module doesn't hurt
+MY_ARCH := "${PACKAGE_ARCH}"
+PACKAGE_ARCH = "${@base_contains('MACHINE_FEATURES', 'iwmmxt', 'iwmmxt', '${MY_ARCH}',d)}"
+
+MY_TARGET_CC_ARCH := "${TARGET_CC_ARCH}"
+TARGET_CC_ARCH = "${@base_contains('MACHINE_FEATURES', 'iwmmxt', '-march=iwmmxt -mtune=iwmmxt', '${MY_TARGET_CC_ARCH}',d)}"
+
+EXTRA_OECONF_append = " ${@base_contains('MACHINE_FEATURES', 'iwmmxt', '--enable-pxa --enable-iwmmxt', '',d)} "
+
+
do_configure_prepend() {
# it's not autotools anyway, so we call ./configure directly
find . -name "Makefile"|xargs rm -f
@@ -50,13 +66,15 @@ do_configure_prepend() {
--mandir=/usr/man \
--cpu=${MYTHTV_ARCH} \
--disable-altivec \
+ --disable-strip \
--enable-v4l \
--enable-audio-oss \
--enable-proc-opt \
--enable-dvb \
--enable-libmp3lame \
--cross-compile \
- --dvb-path=${STAGING_INCDIR}
+ --dvb-path=${STAGING_INCDIR} \
+ ${EXTRA_OECONF}
sed 's!PREFIX =.*!PREFIX = ${prefix}!;/INCLUDEPATH += $${PREFIX}\/include/d' < settings.pro > settings.pro.new
mv settings.pro.new settings.pro