aboutsummaryrefslogtreecommitdiffstats
path: root/packages/neon
diff options
context:
space:
mode:
authorRene Wagner <rw@handhelds.org>2006-03-11 14:34:33 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-03-11 14:34:33 +0000
commit1d2a6067a501d4ce3deea0d35b4ab2f855042df4 (patch)
treea52732dd67755884dba28f4ddfca2aeee9f94f8b /packages/neon
parent7d2493c47cd4a65d6e18fecc0d82fc86a972ea9e (diff)
downloadopenembedded-1d2a6067a501d4ce3deea0d35b4ab2f855042df4.tar.gz
neon: don't link against openssl for licensing reasons. inherit binconfig rather than duplocating code.
Diffstat (limited to 'packages/neon')
-rw-r--r--packages/neon/neon_0.24.7.bb14
1 files changed, 4 insertions, 10 deletions
diff --git a/packages/neon/neon_0.24.7.bb b/packages/neon/neon_0.24.7.bb
index d53260b3cf..534b4d099d 100644
--- a/packages/neon/neon_0.24.7.bb
+++ b/packages/neon/neon_0.24.7.bb
@@ -1,24 +1,18 @@
DESCRIPTION = "neon is an HTTP and WebDAV client library, with a C interface."
SECTION = "base"
LICENSE = "LGPL"
-DEPENDS = "openssl zlib libxml2 expat time"
+DEPENDS = "zlib libxml2 expat time"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://www.webdav.org/neon/neon-0.24.7.tar.gz \
file://no-func-checks.patch;patch=1"
-inherit autotools lib_package
+inherit autotools binconfig lib_package
-EXTRA_OECONF = " --with-ssl --with-libxml2 --with-expat --enable-shared"
+EXTRA_OECONF = " --without-ssl --with-libxml2 --with-expat --enable-shared"
do_stage () {
autotools_stage_includes
oe_libinstall -C src -so -a libneon ${STAGING_LIBDIR}/
-
- cat neon-config | sed -e "s,^prefix=.*,prefix=${STAGING_BINDIR}/..," \
- -e "s,^exec_prefix=.*,exec_prefix=${STAGING_BINDIR}/..," \
- -e "s,^includedir=.*,includedir=${STAGING_INCDIR}," \
- -e "s,^libdir=.*,libdir=${STAGING_LIBDIR}," > ${STAGING_BINDIR}/neon-config
- chmod a+rx ${STAGING_BINDIR}/neon-config
}