aboutsummaryrefslogtreecommitdiffstats
path: root/packages/net-snmp
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2006-05-27 02:14:04 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-27 02:14:04 +0000
commitfb015e8804e306c86e99fdb04e571c06cde17f2c (patch)
tree094890a6450d260f82acec35827c521b270654e3 /packages/net-snmp
parent742627c86660c059f291c349e4922357b4a38a03 (diff)
downloadopenembedded-fb015e8804e306c86e99fdb04e571c06cde17f2c.tar.gz
net-snmp 5.1.2: Fix endianess detection to work on all platforms by looking
at the site file to determine the correct configure parameter (inspired by how openssl does this). Previously this built on mipsel only. Should build on all platforms now. Closes bug #483.
Diffstat (limited to 'packages/net-snmp')
-rw-r--r--packages/net-snmp/net-snmp_5.1.2.bb13
1 files changed, 10 insertions, 3 deletions
diff --git a/packages/net-snmp/net-snmp_5.1.2.bb b/packages/net-snmp/net-snmp_5.1.2.bb
index fe7e9dd4d2..60c8fee549 100644
--- a/packages/net-snmp/net-snmp_5.1.2.bb
+++ b/packages/net-snmp/net-snmp_5.1.2.bb
@@ -12,12 +12,19 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/net-snmp/net-snmp-${PV}.tar.gz \
inherit autotools
EXTRA_OECONF = "--enable-shared --disable-manuals"
-EXTRA_OECONF_mipsel += "--with-endianness=little"
-
EXTRA_OEMAKE = "INSTALL_PREFIX=${D}"
do_configure() {
- oe_runconf
+ # endianness fun.. inspired by openssl.inc
+ . ${CONFIG_SITE}
+ if test "x$ac_cv_c_bigendian" = "xyes"; then
+ ENDIANESS=" --with-endianness=big"
+ elif test "x$ac_cv_c_littleendian" = "xyes"; then
+ ENDIANESS=" --with-endianness=little"
+ else
+ oefatal do_configure cannot determine endianess
+ fi
+ oe_runconf $ENDIANESS
}
do_install_append() {