aboutsummaryrefslogtreecommitdiffstats
path: root/packages/nfs-utils/nfs-utils_1.1.2.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-07-23 12:14:24 +0000
committerKoen Kooi <koen@openembedded.org>2008-07-23 12:14:24 +0000
commit714908d475361a25179229cd6cf145f33968db7d (patch)
tree9bdfe40307812d5c2fa2c62056ed716b6051f1bb /packages/nfs-utils/nfs-utils_1.1.2.bb
parentead59a1b031931b99a2ac6c9e27f6056e4d836ad (diff)
downloadopenembedded-714908d475361a25179229cd6cf145f33968db7d.tar.gz
nfs-utils: update to 1.1.2
Diffstat (limited to 'packages/nfs-utils/nfs-utils_1.1.2.bb')
-rw-r--r--packages/nfs-utils/nfs-utils_1.1.2.bb63
1 files changed, 63 insertions, 0 deletions
diff --git a/packages/nfs-utils/nfs-utils_1.1.2.bb b/packages/nfs-utils/nfs-utils_1.1.2.bb
new file mode 100644
index 0000000000..67adf6e964
--- /dev/null
+++ b/packages/nfs-utils/nfs-utils_1.1.2.bb
@@ -0,0 +1,63 @@
+DESCRIPTION = "userspace utilities for kernel nfs"
+PRIORITY = "optional"
+SECTION = "console/network"
+LICENSE = "GPL"
+
+DEPENDS = "tcp-wrappers libevent"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/nfs/nfs-utils-${PV}.tar.gz \
+ file://nfsserver \
+ "
+
+S = "${WORKDIR}/nfs-utils-${PV}/"
+
+PARALLEL_MAKE = ""
+
+# Only kernel-module-nfsd is required here (but can be built-in) - the nfsd module will
+# pull in the remainder of the dependencies.
+RDEPENDS = "portmap"
+RRECOMMENDS = "kernel-module-nfsd"
+
+INITSCRIPT_NAME = "nfsserver"
+# The server has no dependencies at the user run levels, so just put
+# it in at the default levels. It must be terminated before the network
+# in the shutdown levels, but that works fine.
+INITSCRIPT_PARAMS = "defaults"
+
+inherit autotools update-rc.d
+
+EXTRA_OECONF = "--with-statduser=nobody \
+ --enable-nfsv3 \
+ --disable-nfsv4 \
+ --disable-gss \
+ --with-statedir=/var/lib/nfs"
+
+do_ccompile() {
+ # UGLY HACK ALERT
+ cat ${WORKDIR}/forgotten-defines >> ${S}/support/include/config.h
+ oe_runmake 'BUILD=1'
+}
+
+INHIBIT_AUTO_STAGE = "1"
+
+do_install() {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver
+
+ install -d ${D}${sbindir}
+ install -m 0755 ${S}/utils/exportfs/exportfs ${D}${sbindir}/exportfs
+ install -m 0755 ${S}/utils/mountd/mountd ${D}${sbindir}/mountd
+ install -m 0755 ${S}/utils/mount/mount.nfs ${D}${sbindir}/mount.nfs
+ install -m 0755 ${S}/utils/nfsd/nfsd ${D}${sbindir}/nfsd
+ install -m 0755 ${S}/utils/nfsstat/nfsstat ${D}${sbindir}/nfsstat
+ install -m 0755 ${S}/utils/showmount/showmount ${D}${sbindir}/showmount
+ install -m 0755 ${S}/utils/statd/statd ${D}${sbindir}/statd
+
+ install -d ${D}${mandir}/man8
+ install -m 0644 ${S}/utils/exportfs/exportfs.man ${D}${mandir}/man8/exportfs.8
+ install -m 0644 ${S}/utils/mountd/mountd.man ${D}${mandir}/man8/mountd.8
+ install -m 0644 ${S}/utils/nfsd/nfsd.man ${D}${mandir}/man8/nfsd.8
+ install -m 0644 ${S}/utils/nfsstat/nfsstat.man ${D}${mandir}/man8/nfsstat.8
+ install -m 0644 ${S}/utils/showmount/showmount.man ${D}${mandir}/man8/showmount.8
+ install -m 0644 ${S}/utils/statd/statd.man ${D}${mandir}/man8/statd.8
+}