aboutsummaryrefslogtreecommitdiffstats
path: root/packages/nfs-utils
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-08-28 13:58:00 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-08-28 13:58:00 +0000
commitedbeb005cd8711b6deef2c46d74b4057d2df0ed3 (patch)
treee9a3ffbfb19b03b35371241db085adbad975a9ea /packages/nfs-utils
parent50bf42c0ac01c39b677caf3e7a8c2280f04703cc (diff)
downloadopenembedded-edbeb005cd8711b6deef2c46d74b4057d2df0ed3.tar.gz
nfs-utils: start/stop also statd so clients will be able to do locking (Taken from Poky -r2578) - close #2799
Diffstat (limited to 'packages/nfs-utils')
-rw-r--r--packages/nfs-utils/files/nfsserver21
-rw-r--r--packages/nfs-utils/nfs-utils_1.0.6.bb2
2 files changed, 21 insertions, 2 deletions
diff --git a/packages/nfs-utils/files/nfsserver b/packages/nfs-utils/files/nfsserver
index bb16806ed9..0e9d7be787 100644
--- a/packages/nfs-utils/files/nfsserver
+++ b/packages/nfs-utils/files/nfsserver
@@ -7,9 +7,10 @@
# Other control variables may be overridden here too
test -r /etc/default/nfsd && . /etc/default/nfsd
#
-# Location of exectuables:
+# Location of executables:
test -x "$NFS_MOUNTD" || NFS_MOUNTD=/usr/sbin/mountd
test -x "$NFS_NFSD" || NFS_NFSD=/usr/sbin/nfsd
+test -x "$NFS_STATD" || NFS_STATD=/usr/sbin/statd
#
# The user mode program must also exist (it just starts the kernel
# threads using the kernel module code).
@@ -104,6 +105,20 @@ stop_nfsd(){
echo failed
fi
}
+
+#statd
+start_statd(){
+ echo -n "starting statd: "
+ start-stop-daemon --start --exec "$NFS_STATD"
+ echo done
+}
+stop_statd(){
+ # WARNING: this kills any process with the executable
+ # name 'statd'.
+ echo -n 'stopping statd: '
+ start-stop-daemon --stop --quiet --signal 1 --name statd
+ echo done
+}
#----------------------------------------------------------------------
#
# supported options:
@@ -116,15 +131,19 @@ case "$1" in
start) create_directories
start_nfsd "$NFS_SERVERS"
start_mountd
+ start_statd
test -r /etc/exports && exportfs -a;;
stop) exportfs -ua
+ stop_statd
stop_mountd
stop_nfsd;;
reload) test -r /etc/exports && exportfs -r;;
restart)exportfs -ua
stop_mountd
+ stop_statd
# restart does not restart the kernel threads,
# only the user mode processes
start_mountd
+ start_statd
test -r /etc/exports && exportfs -a;;
esac
diff --git a/packages/nfs-utils/nfs-utils_1.0.6.bb b/packages/nfs-utils/nfs-utils_1.0.6.bb
index fbc2a96a3c..15e3914472 100644
--- a/packages/nfs-utils/nfs-utils_1.0.6.bb
+++ b/packages/nfs-utils/nfs-utils_1.0.6.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "userspace utilities for kernel nfs"
PRIORITY = "optional"
SECTION = "console/network"
LICENSE = "GPL"
-PR = "r11"
+PR = "r12"
SRC_URI = "${SOURCEFORGE_MIRROR}/nfs/nfs-utils-${PV}.tar.gz \
file://acinclude-lossage.patch;patch=1 \