aboutsummaryrefslogtreecommitdiffstats
path: root/packages/nfs-utils
diff options
context:
space:
mode:
authorDerek Young <dyoung@nslu2-linux.org>2005-03-27 21:46:09 +0000
committerDerek Young <dyoung@nslu2-linux.org>2005-03-27 21:46:09 +0000
commit6256a3b966cd513c048f4b64df72c226b107858b (patch)
treed86524ca0bf7f0dc151266b43029bb9daae6075a /packages/nfs-utils
parentb2a7d573260a1b11f8d50dd97a32f8c1bd670640 (diff)
downloadopenembedded-6256a3b966cd513c048f4b64df72c226b107858b.tar.gz
Merge bk://nslu2-linux@nslu2-linux.bkbits.net/openembedded
into builder.(none):/home/dereky/bbroot/openembedded 2005/03/27 04:08:54-10:00 (none)!dyoung nfs-utils_1.0.6.bb: Repaired it to working. Added some patches, hacked the install to bits. stat-include.patch, forgotten-defines: new files BKrev: 424729a10SIvC-KUlG2_UpBSbhvPRQ
Diffstat (limited to 'packages/nfs-utils')
-rw-r--r--packages/nfs-utils/nfs-utils-1.0.6/forgotten-defines0
-rw-r--r--packages/nfs-utils/nfs-utils-1.0.6/stat-include.patch0
-rw-r--r--packages/nfs-utils/nfs-utils_1.0.6.bb71
3 files changed, 71 insertions, 0 deletions
diff --git a/packages/nfs-utils/nfs-utils-1.0.6/forgotten-defines b/packages/nfs-utils/nfs-utils-1.0.6/forgotten-defines
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/nfs-utils/nfs-utils-1.0.6/forgotten-defines
diff --git a/packages/nfs-utils/nfs-utils-1.0.6/stat-include.patch b/packages/nfs-utils/nfs-utils-1.0.6/stat-include.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/nfs-utils/nfs-utils-1.0.6/stat-include.patch
diff --git a/packages/nfs-utils/nfs-utils_1.0.6.bb b/packages/nfs-utils/nfs-utils_1.0.6.bb
index e69de29bb2..53b1b992ae 100644
--- a/packages/nfs-utils/nfs-utils_1.0.6.bb
+++ b/packages/nfs-utils/nfs-utils_1.0.6.bb
@@ -0,0 +1,71 @@
+DESCRIPTION = "userspace utilities for kernel nfs"
+PRIORITY = "optional
+SECTION = "console/networking"
+MAINTAINER = "dyoung <dyoung@thestuffguy.com>"
+LICENSE = GPL
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/nfs/nfs-utils-${PV}.tar.gz \
+ file://acinclude-lossage.patch;patch=1 \
+ file://rpcgen-lossage.patch;patch=1 \
+ file://stat-include.patch;patch=1 \
+ file://forgotten-defines"
+S = ${WORKDIR}/nfs-utils-${PV}/
+
+inherit autotools
+
+EXTRA_OECONF = "--with-statduser=nobody \
+ --enable-nfsv3 \
+ --with-statedir=/var/lib/nfs"
+
+do_compile() {
+ # UGLY HACK ALERT
+ cat ${WORKDIR}/forgotten-defines >> ${S}/support/include/config.h
+ oe_runmake 'BUILD=1'
+}
+
+do_install() {
+ mkdir -p ${D}var/lib/nfs
+ touch ${D}var/lib/nfs/xtab; chmod 644 ${D}var/lib/nfs/xtab
+ touch ${D}var/lib/nfs/etab; chmod 644 ${D}var/lib/nfs/etab
+ touch ${D}var/lib/nfs/smtab; chmod 644 ${D}var/lib/nfs/smtab
+
+ mkdir -p ${D}var/lib/nfs/sm
+ mkdir -p ${D}var/lib/nfs/sm.bak
+
+ touch ${D}var/lib/nfs/state
+
+ chmod go-rwx ${D}var/lib/nfs/sm
+ chmod go-rwx ${D}var/lib/nfs/sm.bak
+ chmod go-rwx ${D}var/lib/nfs/state
+ # they should be owned by statduser, how to do that..
+
+ install -d ${D}${sbindir}
+ install -m 0755 ${S}/utils/exportfs/exportfs ${D}${sbindir}/exportfs
+ install -m 0755 ${S}/utils/lockd/lockd ${D}${sbindir}/lockd
+ install -m 0755 ${S}/utils/mountd/mountd ${D}${sbindir}/mountd
+ install -m 0755 ${S}/utils/nfsd/nfsd ${D}${sbindir}/nfsd
+ install -m 0755 ${S}/utils/nfsstat/nfsstat ${D}${sbindir}/nfsstat
+ install -m 0755 ${S}/utils/nhfsstone/nhfsgraph ${D}${sbindir}/nhfsgraph
+ install -m 0755 ${S}/utils/nhfsstone/nhfsnums ${D}${sbindir}/nhfsnums
+ install -m 0755 ${S}/utils/nhfsstone/nhfsrun ${D}${sbindir}/nhfsrun
+ install -m 0755 ${S}/utils/nhfsstone/nhfsstone ${D}${sbindir}/nhfsstone
+ install -m 0755 ${S}/utils/rquotad/rquotad ${D}${sbindir}/rquotad
+ install -m 0755 ${S}/utils/showmount/showmount ${D}${sbindir}/showmount
+ install -m 0755 ${S}/utils/statd/statd ${D}${sbindir}/statd
+
+ install -d ${D}${mandir}/man8
+ install -m 0644 ${S}/utils/exportfs/exportfs.man ${D}${mandir}/man8/exportfs.8
+ install -m 0644 ${S}/utils/lockd/lockd.man ${D}${mandir}/man8/lockd.8
+ install -m 0644 ${S}/utils/mountd/mountd.man ${D}${mandir}/man8/mountd.8
+ install -m 0644 ${S}/utils/nfsd/nfsd.man ${D}${mandir}/man8/nfsd.8
+ install -m 0644 ${S}/utils/nfsstat/nfsstat.man ${D}${mandir}/man8/nfsstat.8
+ install -m 0644 ${S}/utils/nhfsstone/nhfsgraph.man ${D}${mandir}/man8/nhfsgraph.8
+ install -m 0644 ${S}/utils/nhfsstone/nhfsnums.man ${D}${mandir}/man8/nhfsnums.8
+ install -m 0644 ${S}/utils/nhfsstone/nhfsrun.man ${D}${mandir}/man8/nhfsrun.8
+ install -m 0644 ${S}/utils/nhfsstone/nhfsstone.man ${D}${mandir}/man8/nhfsstone.8
+ install -m 0644 ${S}/utils/rquotad/rquotad.man ${D}${mandir}/man8/rquotad.8
+ install -m 0644 ${S}/utils/showmount/showmount.man ${D}${mandir}/man8/showmount.8
+ install -m 0644 ${S}/utils/statd/statd.man ${D}${mandir}/man8/statd.8
+}
+