aboutsummaryrefslogtreecommitdiffstats
path: root/packages/nis
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/nis
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/nis')
-rw-r--r--packages/nis/.mtn2git_empty0
-rw-r--r--packages/nis/files/.mtn2git_empty0
-rw-r--r--packages/nis/files/libdl.patch12
-rw-r--r--packages/nis/files/no-selinux.patch16
-rw-r--r--packages/nis/nis-all.bb14
-rw-r--r--packages/nis/nis.inc35
-rw-r--r--packages/nis/pwdutils_2.6.bb39
-rw-r--r--packages/nis/yp-tools_2.9.bb11
-rw-r--r--packages/nis/ypbind-mt_1.18.bb21
-rw-r--r--packages/nis/ypserv_2.15.bb12
10 files changed, 160 insertions, 0 deletions
diff --git a/packages/nis/.mtn2git_empty b/packages/nis/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/nis/.mtn2git_empty
diff --git a/packages/nis/files/.mtn2git_empty b/packages/nis/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/nis/files/.mtn2git_empty
diff --git a/packages/nis/files/libdl.patch b/packages/nis/files/libdl.patch
index e69de29bb2..605af319f9 100644
--- a/packages/nis/files/libdl.patch
+++ b/packages/nis/files/libdl.patch
@@ -0,0 +1,12 @@
+--- pwdutils-2.6/configure.in.orig 2005-04-19 20:22:36.603052192 -0700
++++ pwdutils-2.6/configure.in 2005-04-19 21:09:45.308023672 -0700
+@@ -178,6 +178,9 @@
+ AC_CHECK_LIB(ldap, main, LDAP_LIBS="-lldap $LDAP_LIBS" found_ldap_lib=yes,,$LDAP_LIBS)
+ fi
+
++ dnl this always needs dl
++ AC_CHECK_LIB(dl, dlopen, LDAP_LIBS="$LDAP_LIBS -ldl")
++
+ if test -z "$found_ldap_lib" -a \( $with_ldap_lib = auto -o $with_ldap_lib = netscape5 \); then
+ AC_CHECK_LIB(ldap50, main, LDAP_LIBS="-lldap50 -lssldap50 -lssl3 -lnss3 -lnspr4 -lprldap50 -lplc4 -lplds4" found_ldap_lib=yes need_pthread=true,, -lpthread)
+ fi
diff --git a/packages/nis/files/no-selinux.patch b/packages/nis/files/no-selinux.patch
index e69de29bb2..71da3e3931 100644
--- a/packages/nis/files/no-selinux.patch
+++ b/packages/nis/files/no-selinux.patch
@@ -0,0 +1,16 @@
+--- pwdutils-2.6/lib/copy_xattr.c.orig 2005-04-16 17:15:52.916660880 -0700
++++ pwdutils-2.6/lib/copy_xattr.c 2005-04-16 17:18:10.345768480 -0700
+@@ -127,8 +127,11 @@
+
+ if (lsetxattr (to, name, value, size, 0) != 0)
+ {
+- if (strcmp (name, "security.selinux") == 0 &&
+- is_selinux_enabled() == 0)
++ if (strcmp (name, "security.selinux") == 0
++#if defined(WITH_SELINUX)
++ && is_selinux_enabled() == 0
++#endif
++ )
+ fprintf (stderr,
+ _("SELinux not enabled, ignore attribute %s for `%s'.\n"),
+ name, to);
diff --git a/packages/nis/nis-all.bb b/packages/nis/nis-all.bb
index e69de29bb2..5018a25ca1 100644
--- a/packages/nis/nis-all.bb
+++ b/packages/nis/nis-all.bb
@@ -0,0 +1,14 @@
+# This meta package is a convenience to build all of the
+# NIS packages.
+#
+PR = "r0"
+DESCRIPTION="NIS services"
+HOMEPAGE="http://www.linux-nis.org/nis/"
+MAINTAINER = "John Bowler <jbowler@acm.org>"
+SECTION = "console/networking"
+PRIORITY = "optional"
+LICENSE = "GPL-2"
+
+INHIBIT_DEFAULT_DEPS = "1"
+
+DEPENDS = "yp-tools ypbind ypserv pwdutils"
diff --git a/packages/nis/nis.inc b/packages/nis/nis.inc
index e69de29bb2..269904f957 100644
--- a/packages/nis/nis.inc
+++ b/packages/nis/nis.inc
@@ -0,0 +1,35 @@
+# This include file contains global definitions for the
+# various NIS packages.
+#
+# These packages will only function correctly with glibc -
+# the rpcsvc functionality is not present in uclibc
+DESCRIPTION ?= "NIS Server and Tools"
+HOMEPAGE ?= "http://www.linux-nis.org/nis/"
+MAINTAINER ?= "John Bowler <jbowler@acm.org>"
+SECTION ?= "console/networking"
+PRIORITY ?= "optional"
+LICENSE ?= "GPL-2"
+
+# Override these *after* the include file if necessary!
+SRC_URI = "ftp://ftp.kernel.org/pub/linux/utils/net/NIS/${P}.tar.bz2"
+
+inherit autotools gettext
+
+# install is broken because src/Makefile heroically adds '-s'
+# to the install flags - passing -s to the build /usr/bin/install!
+# install-strip gets it right but installs ypbind -m <default>,
+# not -m 555. In an OE build this is not, so far as I can see,
+# a security problem (and this fix to the build problem is *much*
+# easier and more maintainable.)
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install-strip
+}
+
+# An attempt to build on uclibc will fail, causing annoyance,
+# so force the package to be skipped here (this will cause a
+# 'nothing provides' error)
+python () {
+ os = bb.data.getVar("TARGET_OS", d, 1)
+ if os == "linux-uclibc":
+ raise bb.parse.SkipPackage("NIS functionality requires rpcsvc/yp.h, uClibC does not provide this")
+}
diff --git a/packages/nis/pwdutils_2.6.bb b/packages/nis/pwdutils_2.6.bb
index e69de29bb2..4ba89ffb23 100644
--- a/packages/nis/pwdutils_2.6.bb
+++ b/packages/nis/pwdutils_2.6.bb
@@ -0,0 +1,39 @@
+# This package builds tools to manage NIS passwords
+# The source package is utils/net/NIS/pwdutils
+# The package requires -lpam
+#
+PR = "r1"
+DESCRIPTION="\
+NIS PAM password management tools. \
+This is a collection of utilities to manage the passwd \
+information stored in local files, NIS, NIS+ or LDAP \
+and can replace the shadow suite completely."
+HOMEPAGE="http://lists.suse.com/archive/pwdutils/"
+
+include nis.inc
+
+# an selinux API is used even if no selinux is detected by
+# configure.
+SRC_URI += " file://no-selinux.patch;patch=1"
+SRC_URI += " file://libdl.patch;patch=1"
+
+DEPENDS += " libpam openldap openssl"
+
+# -Werror is set within the pwdutils configure.in!
+# You might prefer to use -Wno-error rather than the
+# following long list.
+#
+# #if undefined happens in bits/string2.h and probably
+# elsewhere (since it is a standard safe C programming
+# practice - safer than #ifdef!)
+TARGET_CFLAGS += " -Wno-undef"
+# bits/socket.h has a macro which casts 'up' (increasing
+# the alignment requirement) but it is in a macro which
+# does the alignment correctly, so the following warning
+# needs to be non-error'ed. I just turn it off...
+TARGET_CFLAGS += " -Wno-cast-align"
+# openssl contains large numbers of declarations wherein
+# f() is used instead of f(void), so:
+TARGET_CFLAGS += " -Wno-strict-prototypes"
+# openssl uses error as a local variable, so:
+TARGET_CFLAGS += " -Wno-shadow"
diff --git a/packages/nis/yp-tools_2.9.bb b/packages/nis/yp-tools_2.9.bb
index e69de29bb2..dda6f7f4de 100644
--- a/packages/nis/yp-tools_2.9.bb
+++ b/packages/nis/yp-tools_2.9.bb
@@ -0,0 +1,11 @@
+# This package builds tools to manage NIS
+# The source package is utils/net/NIS/yp-tools
+#
+PR = "r0"
+DESCRIPTION="\
+Network Information Service tools. \
+This package contains ypcat, ypmatch, ypset, \
+ypwhich, yppasswd, domainname, nisdomainname \
+and ypdomainname."
+
+include nis.inc
diff --git a/packages/nis/ypbind-mt_1.18.bb b/packages/nis/ypbind-mt_1.18.bb
index e69de29bb2..e58daa6670 100644
--- a/packages/nis/ypbind-mt_1.18.bb
+++ b/packages/nis/ypbind-mt_1.18.bb
@@ -0,0 +1,21 @@
+# This package builds the NIS ypbind daemon
+# The source package is utils/net/NIS/ypbind-mt
+#
+PR = "r0"
+DESCRIPTION="\
+Multithreaded NIS bind service (ypbind-mt). \
+ypbind-mt is a complete new implementation of a NIS \
+binding daemon for Linux. It has the following \
+features. Supports ypbind protocol V1 and V2. \
+Uses threads for better response. Supports multiple \
+domain bindings. Supports /var/yp/binding/* file \
+for Linux libc 4/5 and glibc 2.x. Supports a list \
+of known secure NIS server (/etc/yp.conf) Binds to \
+the server which answered as first."
+HOMEPAGE="http://www.linux-nis.org/nis/ypbind-mt/index.html"
+
+include nis.inc
+
+# ypbind-mt now provides all the functionality of ypbind
+# and is used in place of it.
+PROVIDES += "ypbind"
diff --git a/packages/nis/ypserv_2.15.bb b/packages/nis/ypserv_2.15.bb
index e69de29bb2..6edb534e8f 100644
--- a/packages/nis/ypserv_2.15.bb
+++ b/packages/nis/ypserv_2.15.bb
@@ -0,0 +1,12 @@
+# This package builds the NIS server
+# The source package is utils/net/NIS/ypserv
+#
+PR = "r0"
+DESCRIPTION="NIS version 2 server for Linux."
+HOMEPAGE="http://www.linux-nis.org/nis/ypserv/index.html"
+
+include nis.inc
+
+# ypserv needs a database package, gdbm is currently the
+# only candidate
+DEPENDS += " gdbm"