aboutsummaryrefslogtreecommitdiffstats
path: root/packages/nonworking/bogl
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/nonworking/bogl
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/nonworking/bogl')
-rw-r--r--packages/nonworking/bogl/.mtn2git_empty0
-rw-r--r--packages/nonworking/bogl/bogl-utils-native_0.1.9.bb20
-rw-r--r--packages/nonworking/bogl/libbogl_0.1.9.bb24
3 files changed, 44 insertions, 0 deletions
diff --git a/packages/nonworking/bogl/.mtn2git_empty b/packages/nonworking/bogl/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/nonworking/bogl/.mtn2git_empty
diff --git a/packages/nonworking/bogl/bogl-utils-native_0.1.9.bb b/packages/nonworking/bogl/bogl-utils-native_0.1.9.bb
index e69de29bb2..94a1d4e00b 100644
--- a/packages/nonworking/bogl/bogl-utils-native_0.1.9.bb
+++ b/packages/nonworking/bogl/bogl-utils-native_0.1.9.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Utilities for Ben's Own Graphics Library"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "gd-native"
+PR = "2"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/b/bogl/bogl_${PV}-${PR}.tar.gz"
+S = "${WORKDIR}/bogl"
+
+inherit native
+
+do_compile() {
+ oe_runmake bdftobogl pngtobogl
+ # giftobogl doesn't work because gd no longer comes with GIF support
+}
+
+do_stage() {
+ install -d ${STAGING_BINDIR}/
+ install -m 0755 bdftobogl pngtobogl ${STAGING_BINDIR}/
+}
diff --git a/packages/nonworking/bogl/libbogl_0.1.9.bb b/packages/nonworking/bogl/libbogl_0.1.9.bb
index e69de29bb2..e9198eae89 100644
--- a/packages/nonworking/bogl/libbogl_0.1.9.bb
+++ b/packages/nonworking/bogl/libbogl_0.1.9.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Ben's Own Graphics Library"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "bogl-utils-native"
+PR = "2"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/b/bogl/bogl_${PV}-${PR}.tar.gz"
+S = "${WORKDIR}/bogl"
+
+do_compile() {
+ ln -sf ${STAGING_BINDIR}/bdftobogl .
+ ln -sf ${STAGING_BINDIR}/pngtobogl .
+ oe_runmake libbogl.so.0.1 libbogl.a
+}
+
+do_stage() {
+ oe_soinstall libbogl.so.0.1 ${STAGING_LIBDIR}/
+ install bogl*.h ${STAGING_INCDIR}/
+}
+
+do_install() {
+ oe_soinstall libbogl.so.0.1 ${STAGING_LIBDIR}/
+}
+