aboutsummaryrefslogtreecommitdiffstats
path: root/packages/nonworking
diff options
context:
space:
mode:
authorquickdev <niklas.coding@gmail.com>2009-01-24 17:13:32 +0100
committerquickdev <niklas.coding@gmail.com>2009-01-24 17:13:32 +0100
commit3c635ab244b48708901e5763fb6c3345b9ce5190 (patch)
tree4f197afe9b2f705bdb2c809d29b76fbbc63ad470 /packages/nonworking
parenteb0493f0ebee9c0baf9bbec020cfeb8a3e82b227 (diff)
downloadopenembedded-3c635ab244b48708901e5763fb6c3345b9ce5190.tar.gz
python-mysqldb: Modified patch to properly compile. Removed it from nonworking.
Before, bitbake failed with "CROSS COMPILE Badness: /usr/include in INCLUDEPATH: /usr/include/mysql". The patch modification adds a new line in site.cfg, which removes /usr/include/mysql from INCLUDEPATH.
Diffstat (limited to 'packages/nonworking')
-rw-r--r--packages/nonworking/python/python-mysqldb/mysqlpath.patch19
-rw-r--r--packages/nonworking/python/python-mysqldb/site.patch13
-rw-r--r--packages/nonworking/python/python-mysqldb_1.2.1.bb20
3 files changed, 0 insertions, 52 deletions
diff --git a/packages/nonworking/python/python-mysqldb/mysqlpath.patch b/packages/nonworking/python/python-mysqldb/mysqlpath.patch
deleted file mode 100644
index 3f471a1703..0000000000
--- a/packages/nonworking/python/python-mysqldb/mysqlpath.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Index: MySQL-python-1.2.1_p2/_mysql.c
-===================================================================
---- MySQL-python-1.2.1_p2.orig/_mysql.c 2006-05-31 12:07:36.000000000 +0200
-+++ MySQL-python-1.2.1_p2/_mysql.c 2006-05-31 12:08:25.000000000 +0200
-@@ -36,10 +36,10 @@
- #endif
-
- #include "structmember.h"
--#include "mysql.h"
--#include "my_config.h"
--#include "mysqld_error.h"
--#include "errmsg.h"
-+#include "mysql/mysql.h"
-+#include "mysql/my_config.h"
-+#include "mysql/mysqld_error.h"
-+#include "mysql/errmsg.h"
-
- #if PY_VERSION_HEX < 0x02020000
- # define MyTuple_Resize(t,n,d) _PyTuple_Resize(t, n, d)
diff --git a/packages/nonworking/python/python-mysqldb/site.patch b/packages/nonworking/python/python-mysqldb/site.patch
deleted file mode 100644
index c99ee3bc0d..0000000000
--- a/packages/nonworking/python/python-mysqldb/site.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: MySQL-python-1.2.1_p2/site.cfg
-===================================================================
---- MySQL-python-1.2.1_p2.orig/site.cfg 2006-05-31 12:13:45.000000000 +0200
-+++ MySQL-python-1.2.1_p2/site.cfg 2006-05-31 12:13:55.000000000 +0200
-@@ -6,7 +6,7 @@
-
- [options]
- embedded = False
--threadsafe = True
-+threadsafe = False
- static = False
-
- # Use the compiler section to add additional options for the extension build.
diff --git a/packages/nonworking/python/python-mysqldb_1.2.1.bb b/packages/nonworking/python/python-mysqldb_1.2.1.bb
deleted file mode 100644
index 9a9ca0fe56..0000000000
--- a/packages/nonworking/python/python-mysqldb_1.2.1.bb
+++ /dev/null
@@ -1,20 +0,0 @@
-DESCRIPTION = "Python interface to MySQL"
-SECTION = "devel/python"
-PRIORITY = "optional"
-LICENSE = "LGPL"
-DEPENDS = "mysql"
-SRCNAME = "MySQL-python"
-
-inherit distutils
-
-SRC_URI = "\
- ${SOURCEFORGE_MIRROR}/mysql-python/MySQL-python-${PV}_p2.tar.gz \
- file://mysqlpath.patch;patch=1 \
- file://site.patch;patch=1 \
-"
-S = "${WORKDIR}/${SRCNAME}-${PV}_p2"
-
-do_install_append() {
- install -d ${D}${datadir}/doc/${PN}/
- install -m 0644 ${S}/doc/*.txt ${D}${datadir}/doc/${PN}/
-}