aboutsummaryrefslogtreecommitdiffstats
path: root/packages/nslu2-binary-only/nslu2-linksys-libs_2.3r29.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/nslu2-binary-only/nslu2-linksys-libs_2.3r29.bb
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/nslu2-binary-only/nslu2-linksys-libs_2.3r29.bb')
-rw-r--r--packages/nslu2-binary-only/nslu2-linksys-libs_2.3r29.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/packages/nslu2-binary-only/nslu2-linksys-libs_2.3r29.bb b/packages/nslu2-binary-only/nslu2-linksys-libs_2.3r29.bb
index e69de29bb2..f8348a615a 100644
--- a/packages/nslu2-binary-only/nslu2-linksys-libs_2.3r29.bb
+++ b/packages/nslu2-binary-only/nslu2-linksys-libs_2.3r29.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Linksys NSLU2 Stock Firmware Libraries."
+PACKAGE_ARCH = "nslu2"
+SECTION = "base"
+PRIORITY = "required"
+PR = "r2"
+
+SRC_URI = "http://nslu.sf.net/downloads/nslu2-linksys-ramdisk-2.3r29.tar.bz2"
+
+S = "${WORKDIR}/nslu2-linksys-ramdisk-2.3r29"
+
+do_install () {
+ ( cd ${S} ; rm -rf bin dev home mnt proc sbin share tmp upload usr var )
+ ( cd ${S} ; tar cvf - . ) | ( cd ${D} ; tar xvf - )
+}
+
+PACKAGES = "${PN}"
+FILES_${PN} = "/lib"
+
+python () {
+ # Don't build unless we're targeting an nslu2
+ if bb.data.getVar("MACHINE", d, 1) != "nslu2":
+ raise bb.parse.SkipPackage("NSLU2 stock firmware libraries only builds for the Linksys NSLU2")
+}