aboutsummaryrefslogtreecommitdiffstats
path: root/packages/nslu2-binary-only
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/nslu2-binary-only
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/nslu2-binary-only')
-rw-r--r--packages/nslu2-binary-only/.mtn2git_empty0
-rw-r--r--packages/nslu2-binary-only/nslu2-linksys-firmware_2.3r29.bb24
-rw-r--r--packages/nslu2-binary-only/nslu2-linksys-libs_2.3r29.bb23
-rw-r--r--packages/nslu2-binary-only/nslu2-linksys-ramdisk_2.3r25.bb20
-rw-r--r--packages/nslu2-binary-only/nslu2-linksys-ramdisk_2.3r29.bb20
-rw-r--r--packages/nslu2-binary-only/unslung-rootfs/.mtn2git_empty0
-rwxr-xr-x[-rw-r--r--]packages/nslu2-binary-only/unslung-rootfs/linuxrc0
-rw-r--r--packages/nslu2-binary-only/unslung-rootfs/mount_usbdevfs.patch10
-rw-r--r--packages/nslu2-binary-only/unslung-rootfs/nsswitch.conf6
-rw-r--r--packages/nslu2-binary-only/unslung-rootfs/profile2
-rwxr-xr-x[-rw-r--r--]packages/nslu2-binary-only/unslung-rootfs/rc.bootbin0
-rwxr-xr-x[-rw-r--r--]packages/nslu2-binary-only/unslung-rootfs/rc.unslung-start0
-rwxr-xr-x[-rw-r--r--]packages/nslu2-binary-only/unslung-rootfs/rc.unslung-stop0
-rwxr-xr-x[-rw-r--r--]packages/nslu2-binary-only/unslung-rootfs/resling60
-rw-r--r--packages/nslu2-binary-only/unslung-rootfs/root-passwd.patch16
-rw-r--r--packages/nslu2-binary-only/unslung-rootfs/security-fixes.patch16
-rwxr-xr-x[-rw-r--r--]packages/nslu2-binary-only/unslung-rootfs/slingover83
-rwxr-xr-x[-rw-r--r--]packages/nslu2-binary-only/unslung-rootfs/unsling0
-rwxr-xr-x[-rw-r--r--]packages/nslu2-binary-only/unslung-rootfs/upgrade.cgi0
-rw-r--r--packages/nslu2-binary-only/unslung-rootfs/wait-for-quotacheck.patch9
20 files changed, 289 insertions, 0 deletions
diff --git a/packages/nslu2-binary-only/.mtn2git_empty b/packages/nslu2-binary-only/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/nslu2-binary-only/.mtn2git_empty
diff --git a/packages/nslu2-binary-only/nslu2-linksys-firmware_2.3r29.bb b/packages/nslu2-binary-only/nslu2-linksys-firmware_2.3r29.bb
index e69de29bb2..dbb4ad2502 100644
--- a/packages/nslu2-binary-only/nslu2-linksys-firmware_2.3r29.bb
+++ b/packages/nslu2-binary-only/nslu2-linksys-firmware_2.3r29.bb
@@ -0,0 +1,24 @@
+SECTION = "base"
+DEPENDS = "slugimage-native unzip-native"
+PACKAGES = ""
+LICENSE = "GPL"
+INHIBIT_DEFAULT_DEPS = "1"
+PR = "r1"
+
+SRC_URI = "ftp://ftp.linksys.com/pub/network/NSLU2_V23R29.zip"
+S = "${WORKDIR}"
+
+python () {
+ # Don't build unless we're targeting an nslu2
+ if bb.data.getVar("MACHINE", d, 1) != "nslu2":
+ raise bb.parse.SkipPackage("NSLU2 firmware only builds for the Linksys NSLU2")
+}
+
+do_compile () {
+ slugimage -u -i NSLU2_V23R29.bin -b RedBoot -s SysConf -r ramdisk.ext2.gz -t Trailer
+ install -d ${STAGING_LIBDIR}/nslu2-binaries
+ install -m 0755 RedBoot ${STAGING_LIBDIR}/nslu2-binaries/
+ install -m 0755 SysConf ${STAGING_LIBDIR}/nslu2-binaries/
+ install -m 0755 ramdisk.ext2.gz ${STAGING_LIBDIR}/nslu2-binaries/
+ install -m 0755 Trailer ${STAGING_LIBDIR}/nslu2-binaries/
+}
diff --git a/packages/nslu2-binary-only/nslu2-linksys-libs_2.3r29.bb b/packages/nslu2-binary-only/nslu2-linksys-libs_2.3r29.bb
index e69de29bb2..f8348a615a 100644
--- a/packages/nslu2-binary-only/nslu2-linksys-libs_2.3r29.bb
+++ b/packages/nslu2-binary-only/nslu2-linksys-libs_2.3r29.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Linksys NSLU2 Stock Firmware Libraries."
+PACKAGE_ARCH = "nslu2"
+SECTION = "base"
+PRIORITY = "required"
+PR = "r2"
+
+SRC_URI = "http://nslu.sf.net/downloads/nslu2-linksys-ramdisk-2.3r29.tar.bz2"
+
+S = "${WORKDIR}/nslu2-linksys-ramdisk-2.3r29"
+
+do_install () {
+ ( cd ${S} ; rm -rf bin dev home mnt proc sbin share tmp upload usr var )
+ ( cd ${S} ; tar cvf - . ) | ( cd ${D} ; tar xvf - )
+}
+
+PACKAGES = "${PN}"
+FILES_${PN} = "/lib"
+
+python () {
+ # Don't build unless we're targeting an nslu2
+ if bb.data.getVar("MACHINE", d, 1) != "nslu2":
+ raise bb.parse.SkipPackage("NSLU2 stock firmware libraries only builds for the Linksys NSLU2")
+}
diff --git a/packages/nslu2-binary-only/nslu2-linksys-ramdisk_2.3r25.bb b/packages/nslu2-binary-only/nslu2-linksys-ramdisk_2.3r25.bb
index e69de29bb2..f20a2779a3 100644
--- a/packages/nslu2-binary-only/nslu2-linksys-ramdisk_2.3r25.bb
+++ b/packages/nslu2-binary-only/nslu2-linksys-ramdisk_2.3r25.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Linksys NSLU2 Stock Firmware Ramdisk."
+PACKAGE_ARCH = "nslu2"
+SECTION = "base"
+PRIORITY = "required"
+PR = "r1"
+
+SRC_URI = "http://nslu.sf.net/downloads/nslu2-linksys-ramdisk-2.3r25.tar.bz2"
+
+do_install () {
+ ( cd ${S} ; tar cvf - . ) | ( cd ${D} ; tar xvf - )
+}
+
+PACKAGES = "${PN}"
+FILES_${PN} = "/"
+
+python () {
+ # Don't build unless we're targeting an nslu2
+ if bb.data.getVar("MACHINE", d, 1) != "nslu2":
+ raise bb.parse.SkipPackage("NSLU2 ramdisk only builds for the Linksys NSLU2")
+}
diff --git a/packages/nslu2-binary-only/nslu2-linksys-ramdisk_2.3r29.bb b/packages/nslu2-binary-only/nslu2-linksys-ramdisk_2.3r29.bb
index e69de29bb2..c37c283706 100644
--- a/packages/nslu2-binary-only/nslu2-linksys-ramdisk_2.3r29.bb
+++ b/packages/nslu2-binary-only/nslu2-linksys-ramdisk_2.3r29.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Linksys NSLU2 Stock Firmware Ramdisk."
+PACKAGE_ARCH = "nslu2"
+SECTION = "base"
+PRIORITY = "required"
+PR = "r1"
+
+SRC_URI = "http://nslu.sf.net/downloads/nslu2-linksys-ramdisk-2.3r29.tar.bz2"
+
+do_install () {
+ ( cd ${S} ; tar cvf - . ) | ( cd ${D} ; tar xvf - )
+}
+
+PACKAGES = "${PN}"
+FILES_${PN} = "/"
+
+python () {
+ # Don't build unless we're targeting an nslu2
+ if bb.data.getVar("MACHINE", d, 1) != "nslu2":
+ raise bb.parse.SkipPackage("NSLU2 ramdisk only builds for the Linksys NSLU2")
+}
diff --git a/packages/nslu2-binary-only/unslung-rootfs/.mtn2git_empty b/packages/nslu2-binary-only/unslung-rootfs/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/nslu2-binary-only/unslung-rootfs/.mtn2git_empty
diff --git a/packages/nslu2-binary-only/unslung-rootfs/linuxrc b/packages/nslu2-binary-only/unslung-rootfs/linuxrc
index af694bc68d..af694bc68d 100644..100755
--- a/packages/nslu2-binary-only/unslung-rootfs/linuxrc
+++ b/packages/nslu2-binary-only/unslung-rootfs/linuxrc
diff --git a/packages/nslu2-binary-only/unslung-rootfs/mount_usbdevfs.patch b/packages/nslu2-binary-only/unslung-rootfs/mount_usbdevfs.patch
index e69de29bb2..744636d0d9 100644
--- a/packages/nslu2-binary-only/unslung-rootfs/mount_usbdevfs.patch
+++ b/packages/nslu2-binary-only/unslung-rootfs/mount_usbdevfs.patch
@@ -0,0 +1,10 @@
+--- nslu2-linksys-ramdisk-2.3r25/etc/rc.orig 2004-11-03 14:38:45.838082343 +1100
++++ nslu2-linksys-ramdisk-2.3r25/etc/rc 2004-11-03 16:27:08.572763797 +1100
+@@ -4,6 +4,7 @@
+
+ /usr/bin/Set_Led r_blinking &
+ mount -t proc proc /proc
++mount -t usbdevfs usbdevfs /proc/bus/usb
+ mount -o remount,rw /dev/root /
+ ifconfig lo 127.0.0.1
+ route add -net 127.0.0.0 netmask 255.255.255.0 lo
diff --git a/packages/nslu2-binary-only/unslung-rootfs/nsswitch.conf b/packages/nslu2-binary-only/unslung-rootfs/nsswitch.conf
index e69de29bb2..4e0692b4f9 100644
--- a/packages/nslu2-binary-only/unslung-rootfs/nsswitch.conf
+++ b/packages/nslu2-binary-only/unslung-rootfs/nsswitch.conf
@@ -0,0 +1,6 @@
+passwd: files
+group: files
+hosts: files dns
+networks: files dns
+services: files
+protocols: files
diff --git a/packages/nslu2-binary-only/unslung-rootfs/profile b/packages/nslu2-binary-only/unslung-rootfs/profile
index e69de29bb2..a8009daf39 100644
--- a/packages/nslu2-binary-only/unslung-rootfs/profile
+++ b/packages/nslu2-binary-only/unslung-rootfs/profile
@@ -0,0 +1,2 @@
+export PATH=$PATH:/opt/bin:/opt/sbin:/opt/usr/bin:/opt/usr/sbin
+export LD_LIBRARY_PATH=/opt/lib
diff --git a/packages/nslu2-binary-only/unslung-rootfs/rc.bootbin b/packages/nslu2-binary-only/unslung-rootfs/rc.bootbin
index 42959e8b80..42959e8b80 100644..100755
--- a/packages/nslu2-binary-only/unslung-rootfs/rc.bootbin
+++ b/packages/nslu2-binary-only/unslung-rootfs/rc.bootbin
diff --git a/packages/nslu2-binary-only/unslung-rootfs/rc.unslung-start b/packages/nslu2-binary-only/unslung-rootfs/rc.unslung-start
index f738761644..f738761644 100644..100755
--- a/packages/nslu2-binary-only/unslung-rootfs/rc.unslung-start
+++ b/packages/nslu2-binary-only/unslung-rootfs/rc.unslung-start
diff --git a/packages/nslu2-binary-only/unslung-rootfs/rc.unslung-stop b/packages/nslu2-binary-only/unslung-rootfs/rc.unslung-stop
index cf5c6ede67..cf5c6ede67 100644..100755
--- a/packages/nslu2-binary-only/unslung-rootfs/rc.unslung-stop
+++ b/packages/nslu2-binary-only/unslung-rootfs/rc.unslung-stop
diff --git a/packages/nslu2-binary-only/unslung-rootfs/resling b/packages/nslu2-binary-only/unslung-rootfs/resling
index e69de29bb2..07dc432ea7 100644..100755
--- a/packages/nslu2-binary-only/unslung-rootfs/resling
+++ b/packages/nslu2-binary-only/unslung-rootfs/resling
@@ -0,0 +1,60 @@
+#!/bin/sh
+#
+# Copyright (C) 2004 by Oleg I. Vdovikin <oleg@cs.msu.su>
+# Modified for Unslung by Rod Whitby
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+#
+
+if [ -f /share/flash/data/resling.tar.gz ] ; then
+ RESLING=/share/flash/data/resling.tar.gz
+elif [ -f /share/hdd/data/resling.tar.gz ] ; then
+ RESLING=/share/hdd/data/resling.tar.gz
+elif [ -f /share/flash/conf/resling.tar.gz ] ; then
+ RESLING=/share/flash/conf/resling.tar.gz
+elif [ -f /share/hdd/conf/resling.tar.gz ] ; then
+ RESLING=/share/hdd/conf/resling.tar.gz
+else
+ RESLING=/share/flash/data/resling.tar.gz
+fi
+
+case "$1" in
+ start)
+ if [ -f ${RESLING} ]; then
+ tar -C / -zxf ${RESLING}
+ fi
+ ;;
+ clear)
+ rm -f ${RESLING}
+ ;;
+ load)
+ tar -C / -zxvf ${RESLING}
+ ;;
+ list)
+ tar -C / -ztf ${RESLING}
+ ;;
+ save)
+ [ -f /unslung/.files ] && FILES=$(cat /unslung/.files)
+ rm -f /tmp/resling.tar.gz
+ tar -C / -zcvf /tmp/resling.tar.gz /unslung $FILES &&
+ rm -f ${RESLING} &&
+ mv /tmp/resling.tar.gz ${RESLING} &&
+ ls -l ${RESLING} &&
+ echo "Saved."
+ ;;
+ *)
+ echo "Usage: $0 start|clear|load|list|save"
+ ;;
+esac
diff --git a/packages/nslu2-binary-only/unslung-rootfs/root-passwd.patch b/packages/nslu2-binary-only/unslung-rootfs/root-passwd.patch
index e69de29bb2..60dae459ba 100644
--- a/packages/nslu2-binary-only/unslung-rootfs/root-passwd.patch
+++ b/packages/nslu2-binary-only/unslung-rootfs/root-passwd.patch
@@ -0,0 +1,16 @@
+--- nslu2-linksys-ramdisk-2.3r25/etc/passwd.orig 2004-07-27 23:37:55.000000000 -0400
++++ nslu2-linksys-ramdisk-2.3r25/etc/passwd 2004-08-30 09:02:51.000000000 -0400
+@@ -1,4 +1,4 @@
+-root:WeeOvKUvbQ6nI:0:0:root:/root:/bin/sh
++root:t1PLUeOinN/eI:0:0:root:/root:/bin/sh
+ bin:x:1:1:bin:/bin:
+ lp:x:4:7:lp:/share/spool:
+ mail:x:8:12:mail:/var/spool/mail:
+--- nslu2-linksys-ramdisk-2.3r25/usr/local/passwd.orig 2004-07-27 23:37:56.000000000 -0400
++++ nslu2-linksys-ramdisk-2.3r25/usr/local/passwd 2004-08-30 09:02:51.000000000 -0400
+@@ -1,4 +1,4 @@
+-root:WeeOvKUvbQ6nI:0:0:root:/root:/bin/sh
++root:t1PLUeOinN/eI:0:0:root:/root:/bin/sh
+ bin:x:1:1:bin:/bin:
+ lp:x:4:7:lp:/share/spool:
+ mail:x:8:12:mail:/var/spool/mail:
diff --git a/packages/nslu2-binary-only/unslung-rootfs/security-fixes.patch b/packages/nslu2-binary-only/unslung-rootfs/security-fixes.patch
index e69de29bb2..aeed5980f8 100644
--- a/packages/nslu2-binary-only/unslung-rootfs/security-fixes.patch
+++ b/packages/nslu2-binary-only/unslung-rootfs/security-fixes.patch
@@ -0,0 +1,16 @@
+--- nslu2-linksys-ramdisk-2.3r29/etc/rc.d/rc.1.orig 2005-06-12 21:43:26.940523728 +0930
++++ nslu2-linksys-ramdisk-2.3r29/etc/rc.d/rc.1 2005-06-12 21:43:36.910008136 +0930
+@@ -16,11 +16,11 @@
+
+ /bin/echo "Restore time and timezone:"; /etc/rc.d/rc.rstimezone; check_status
+ /bin/echo "Restore usrgrpshares:"; /etc/rc.d/rc.reset_usrgrpshare; check_status
+-/bin/echo "Generating telnet password:"; /usr/sbin/TelnetPassword; check_status
++#/bin/echo "Generating telnet password:"; /usr/sbin/TelnetPassword; check_status
+ #/bin/echo "Restore time and timezone:"; /etc/rc.d/rc.rstimezone; check_status
+ /bin/echo "Starting WEB Server:"; . /etc/rc.d/rc.thttpd;check_status
+ /bin/echo "Starting samba:"; . /etc/rc.d/rc.samba
+-/bin/echo "Starting download:"; /usr/sbin/download
++#/bin/echo "Starting download:"; /usr/sbin/download
+ /bin/echo "Starting INET Server:"; . /etc/rc.d/rc.xinetd; check_status
+ if ( [ ! -f /.sda1root ] && [ ! -f /.sda2root ] && [ ! -f /.sdb1root ] && [ ! -f /.sdb2root ] ) ; then
+ /bin/echo "Creating ramfs for /tmp:"; mount -t ramfs none /tmp -o maxsize=512
diff --git a/packages/nslu2-binary-only/unslung-rootfs/slingover b/packages/nslu2-binary-only/unslung-rootfs/slingover
index e69de29bb2..51f03316e5 100644..100755
--- a/packages/nslu2-binary-only/unslung-rootfs/slingover
+++ b/packages/nslu2-binary-only/unslung-rootfs/slingover
@@ -0,0 +1,83 @@
+#!/bin/sh
+
+usage="Usage: $0 disk1|disk2"
+
+if [ $# -gt 1 ] ; then
+ echo $usage
+ exit 1
+fi
+
+if [ $# -lt 1 ] ; then
+ echo $usage
+ exit 1
+fi
+
+if [ "$1" = "disk1" ] ; then
+ source=/share/hdd/conf
+ target=/share/hdd/data
+elif [ "$1" = "disk2" ] ; then
+ source=/share/flash/conf
+ target=/share/flash/data
+else
+ echo $usage
+ exit 1
+fi
+
+# Check it's a real mount point
+
+if grep $source /proc/mounts >/dev/null 2>&1 ; then
+ echo "Source disk is $source"
+else
+ echo "Error: $source is not a mounted disk"
+ exit 1
+fi
+
+if grep $target /proc/mounts >/dev/null 2>&1 ; then
+ echo "Target disk is $target"
+else
+ echo "Error: $target is not a mounted disk"
+ exit 1
+fi
+
+if [ -d $source/opt ] ; then
+ if [ -d $target/opt.old -a -h $target/opt ] ; then
+ echo "Reverting old /opt symlink on $target."
+ rm -f $target/opt
+ mv $target/opt.old $target/opt
+ fi
+ echo "Copying /opt directory from $source to $target."
+ ( cd $source ; tar cf - opt ) | ( cd $target ; tar xf - )
+ rm -rf $source/opt.old
+ mv $source/opt $source/opt.old
+fi
+
+if [ -d $source/usr ] ; then
+ if [ -d $target/usr/lib/ipkg.old -a -h $target/usr/lib/ipkg ] ; then
+ echo "Reverting old /usr/lib/ipkg symlink on $target."
+ rm -f $target/usr/lib/ipkg
+ mv $target/usr/lib/ipkg.old $target/usr/lib/ipkg
+ fi
+ echo "Copying /usr directory from $source to $target."
+ ( cd $source ; tar cf - usr ) | ( cd $target ; tar xf - )
+ rm -rf $source/usr.old
+ mv $source/usr $source/usr.old
+fi
+
+if [ -d $source/unslung ] ; then
+ echo "Copying /unslung directory from $source to $target."
+ ( cd $source ; tar cf - unslung ) | ( cd $target ; tar xf - )
+ rm -rf $source/unslung.old
+ mv $source/unslung $source/unslung.old
+fi
+
+if [ -f $target/opt/bin/perl ] ; then
+ echo "Replicating /usr/bin/perl symlink."
+ ln -s /opt/bin/perl $target/usr/bin/perl
+fi
+
+if [ -f $target/opt/bin/bash ] ; then
+ echo "Replicating /bin/bash symlink."
+ ln -s /opt/bin/bash $target/bin/bash
+fi
+
+exit 0
diff --git a/packages/nslu2-binary-only/unslung-rootfs/unsling b/packages/nslu2-binary-only/unslung-rootfs/unsling
index b784378812..b784378812 100644..100755
--- a/packages/nslu2-binary-only/unslung-rootfs/unsling
+++ b/packages/nslu2-binary-only/unslung-rootfs/unsling
diff --git a/packages/nslu2-binary-only/unslung-rootfs/upgrade.cgi b/packages/nslu2-binary-only/unslung-rootfs/upgrade.cgi
index 0eee123550..0eee123550 100644..100755
--- a/packages/nslu2-binary-only/unslung-rootfs/upgrade.cgi
+++ b/packages/nslu2-binary-only/unslung-rootfs/upgrade.cgi
diff --git a/packages/nslu2-binary-only/unslung-rootfs/wait-for-quotacheck.patch b/packages/nslu2-binary-only/unslung-rootfs/wait-for-quotacheck.patch
index e69de29bb2..ffdda1b88b 100644
--- a/packages/nslu2-binary-only/unslung-rootfs/wait-for-quotacheck.patch
+++ b/packages/nslu2-binary-only/unslung-rootfs/wait-for-quotacheck.patch
@@ -0,0 +1,9 @@
+--- nslu2-linksys-ramdisk-2.3r25/etc/rc.d/rc.local~ 2005-04-03 10:14:51.000000000 +0930
++++ nslu2-linksys-ramdisk-2.3r25/etc/rc.d/rc.local 2005-04-03 10:14:59.000000000 +0930
+@@ -14,5 +14,5 @@
+ /bin/chmod 775 /share 2>/dev/null
+ /bin/chown admin.everyone /share/hdd/ 2>/dev/null
+ /bin/chown admin.everyone /share 2>/dev/null
+-/etc/rc.d/rc.quota &>/dev/null
++/etc/rc.d/rc.quota 2>/dev/null
+ /bin/echo "$HOSTNAME: boot complete!"; check_status