aboutsummaryrefslogtreecommitdiffstats
path: root/packages/nslu2-binary-only
diff options
context:
space:
mode:
authorMike Westerhof <mwester@dls.net>2006-04-15 18:04:12 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-15 18:04:12 +0000
commitf5193e9a40465133df954d44a1a0e0c0abc36ec7 (patch)
tree0711926cf94d49c0742807f4551fe6818dad213e /packages/nslu2-binary-only
parent64a0899b9317814694d2a80b42edd7f0896d1507 (diff)
downloadopenembedded-f5193e9a40465133df954d44a1a0e0c0abc36ec7.tar.gz
Unslung: unslung-rootfs, unslung-kernel, unslung-image - rearranged NLS support, removed Linksys upgrade page
Diffstat (limited to 'packages/nslu2-binary-only')
-rw-r--r--packages/nslu2-binary-only/nslu2-linksys-libs_2.3r63.bb2
-rw-r--r--packages/nslu2-binary-only/nslu2-linksys-sambacodepages_2.3r63.bb29
-rw-r--r--packages/nslu2-binary-only/unslung-rootfs/NOTES25
-rw-r--r--packages/nslu2-binary-only/unslung-rootfs/rc.modules-diversion.patch12
-rw-r--r--packages/nslu2-binary-only/unslung-rootfs/rc.modules-nls.patch10
-rwxr-xr-xpackages/nslu2-binary-only/unslung-rootfs/upgrade.cgi4
-rw-r--r--packages/nslu2-binary-only/unslung-rootfs/upgrade.htm50
-rw-r--r--packages/nslu2-binary-only/unslung-rootfs_2.3r63.bb39
8 files changed, 131 insertions, 40 deletions
diff --git a/packages/nslu2-binary-only/nslu2-linksys-libs_2.3r63.bb b/packages/nslu2-binary-only/nslu2-linksys-libs_2.3r63.bb
index 1843de069c..4424e99d19 100644
--- a/packages/nslu2-binary-only/nslu2-linksys-libs_2.3r63.bb
+++ b/packages/nslu2-binary-only/nslu2-linksys-libs_2.3r63.bb
@@ -9,7 +9,7 @@ SRC_URI = "http://nslu.sf.net/downloads/nslu2-linksys-ramdisk-2.3r63-2.tar.bz2"
S = "${WORKDIR}/nslu2-linksys-ramdisk-2.3r63"
do_install () {
- ( cd ${S} ; rm -rf bin dev etc home mnt proc sbin share tmp upload usr var )
+ ( cd ${S} ; rm -rf bin dev etc home lost+found mnt proc sbin share tmp upload usr var )
( cd ${S} ; tar cvf - . ) | ( cd ${D} ; tar xvf - )
}
diff --git a/packages/nslu2-binary-only/nslu2-linksys-sambacodepages_2.3r63.bb b/packages/nslu2-binary-only/nslu2-linksys-sambacodepages_2.3r63.bb
new file mode 100644
index 0000000000..4aace52412
--- /dev/null
+++ b/packages/nslu2-binary-only/nslu2-linksys-sambacodepages_2.3r63.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Linksys NSLU2 Stock Firmware Samba Code Pages."
+PACKAGE_ARCH = "nslu2"
+SECTION = "base"
+PRIORITY = "required"
+PR = "r1"
+
+SRC_URI = "http://nslu.sf.net/downloads/nslu2-linksys-ramdisk-2.3r63-2.tar.bz2"
+
+S = "${WORKDIR}/nslu2-linksys-ramdisk-2.3r63"
+
+do_install () {
+ ( cd ${S} ; mkdir unslung-tmp )
+ ( cd ${S}/etc ; tar cvf - samba/codepages ) | ( cd ${S}/unslung-tmp; tar xvf - )
+ ( cd ${S} ; rm -rf bin dev etc home lib lost+found mnt proc sbin share tmp upload usr var )
+ ( cd ${S} ; mv unslung-tmp etc )
+ ( cd ${S}/etc/samba/codepages; rm -f codepage.437 unicode_map.437 )
+ ( cd ${S}/etc/samba/codepages; rm -f codepage.850 unicode_map.850 )
+ ( cd ${S}/etc/samba/codepages; rm -f unicode_map.ISO8859-1 )
+ ( cd ${S} ; tar cvf - . ) | ( cd ${D} ; tar xvf - )
+}
+
+PACKAGES = "${PN}"
+FILES_${PN} = "/etc/samba/codepages"
+
+python () {
+ # Don't build unless we're targeting an nslu2
+ if bb.data.getVar("MACHINE", d, 1) != "nslu2":
+ raise bb.parse.SkipPackage("NSLU2 stock firmware Samba code pages only builds for the Linksys NSLU2")
+}
diff --git a/packages/nslu2-binary-only/unslung-rootfs/NOTES b/packages/nslu2-binary-only/unslung-rootfs/NOTES
index ae9d7c607c..82d7448a80 100644
--- a/packages/nslu2-binary-only/unslung-rootfs/NOTES
+++ b/packages/nslu2-binary-only/unslung-rootfs/NOTES
@@ -487,3 +487,28 @@ Added original "netconsole" code as a kernel module
Fixed problem with password changing from the GUI and automatic mounting of
drives and flash devices in port 1.
Remove unnecessary directory /lib/modules/2.4.22-xfs/pcmcia.
+
+6.8:
+
+First beta release.
+
+6.9:
+
+Modified /etc/rc.d/rc.modules to "insmod" any nls code page modules present.
+
+Code Page 850 is now compiled into the kernel instead of a kernel module,
+and added Code Page 949 (as a module).
+
+Updated the upgrade.htm file to reflect redboot as the upgrade means.
+
+Remove the upgrade.cgi, upgrade_ui.htm, and upgrade_ui.cgi files from the
+root image as they are no longer used, and we can always use free space.
+
+Rearranged portions of the build procedure to remove the samba code pages in
+the rootfs bb, create a new package with the removed code pages in a new
+nslu2-linksys-sambacodepages.bb file (to restore the code pages, use ipkg to
+install package "nslu2-linksys-sambacodepages". Note that the rootfs and the
+sambacodepages bb files must be kept in sync regarding the samba code pages
+that are left in the image and the ones that are added to the package (and it
+is also a good idea if the kernel defconfig reflects the inclusion of NLS
+support for the code pages that are left in the image, of course).
diff --git a/packages/nslu2-binary-only/unslung-rootfs/rc.modules-diversion.patch b/packages/nslu2-binary-only/unslung-rootfs/rc.modules-diversion.patch
index fa7532401d..d1de027f9a 100644
--- a/packages/nslu2-binary-only/unslung-rootfs/rc.modules-diversion.patch
+++ b/packages/nslu2-binary-only/unslung-rootfs/rc.modules-diversion.patch
@@ -1,8 +1,10 @@
---- nslu2-linksys-ramdisk-2.3r25/etc/rc.d/rc.modules.orig 2004-07-27 23:37:55.000000000 -0400
-+++ nslu2-linksys-ramdisk-2.3r25/etc/rc.d/rc.modules 2004-09-01 21:57:34.000000000 -0400
-@@ -1,2 +1,5 @@
+--- nslu2-linksys-ramdisk-2.3r63/etc/rc.d/rc.modules.orig 2006-04-14 21:00:58.000000000 -0500
++++ nslu2-linksys-ramdisk-2.3r63/etc/rc.d/rc.modules 2006-04-14 21:05:47.000000000 -0500
+@@ -1,4 +1,7 @@
+ #!/bin/sh
+
+if ( [ -f /unslung/rc.modules ] && . /unslung/rc.modules ) ; then return 0 ; fi
+
- insmod rbuttons &>/dev/null
- insmod x1226-rtc &>/dev/null
+ insmod pbuttons 2>/dev/null
+ insmod rbuttons 2>/dev/null
+ insmod x1226-rtc 2>/dev/null
diff --git a/packages/nslu2-binary-only/unslung-rootfs/rc.modules-nls.patch b/packages/nslu2-binary-only/unslung-rootfs/rc.modules-nls.patch
new file mode 100644
index 0000000000..1eb342b715
--- /dev/null
+++ b/packages/nslu2-binary-only/unslung-rootfs/rc.modules-nls.patch
@@ -0,0 +1,10 @@
+--- nslu2-linksys-ramdisk-2.3r63/etc/rc.d/rc.modules.orig 2006-04-14 21:05:47.000000000 -0500
++++ nslu2-linksys-ramdisk-2.3r63/etc/rc.d/rc.modules 2006-04-14 19:56:29.000000000 -0500
+@@ -6,3 +6,7 @@
+ insmod rbuttons 2>/dev/null
+ insmod x1226-rtc 2>/dev/null
+ insmod ufsd 2>/dev/null
++
++for i in /lib/modules/`/bin/uname -r`/kernel/fs/nls/nls_cp*.o ; do
++ insmod "$i" 2>/dev/null
++done
diff --git a/packages/nslu2-binary-only/unslung-rootfs/upgrade.cgi b/packages/nslu2-binary-only/unslung-rootfs/upgrade.cgi
deleted file mode 100755
index 0eee123550..0000000000
--- a/packages/nslu2-binary-only/unslung-rootfs/upgrade.cgi
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-
-/sbin/devio ">>/dev/mtdblock5" "fb#255" 2>/dev/null
-/usr/sbin/DO_Reboot 2>/dev/null
diff --git a/packages/nslu2-binary-only/unslung-rootfs/upgrade.htm b/packages/nslu2-binary-only/unslung-rootfs/upgrade.htm
index 88644e305e..2301a89c0f 100644
--- a/packages/nslu2-binary-only/unslung-rootfs/upgrade.htm
+++ b/packages/nslu2-binary-only/unslung-rootfs/upgrade.htm
@@ -4,21 +4,6 @@
<meta HTTP-EQUIV="Expires" CONTENT="Mon, 06 Jan 1990 00:00:01 GMT">
<script language="JavaScript" type="text/javascript" src="../stdlib.js"></script>
<script language="JavaScript" type="text/javascript" src="../message.js"></script>
-<script language="JavaScript" type="text/javascript">
-<!-- Start Script
-
-function checkUpgrade()
-{
- var cf=document.upgrade;
-
- if(!confirm("Your NSLU2 will now enter RedBoot Upgrade Mode\n(Ready/Status LED will be flashing red and green).\nYou will require either the Linux UpSlug tool or the\nWindows SerComm Upgrade tool to upload firmware.\nNote that you will not be able to access your NSLU2\nuntil you have successfully uploaded new firmware.\nClick OK to continue, Cancel to abort."))
- return;
- cf.submit();
- return;
-}
-
-// end script -->
-</script>
</head>
<body bgcolor="white" onLoad="showMsg()" marginheight="0" marginwidth="0" leftmargin="0" topmargin="0">
@@ -81,8 +66,6 @@ function checkUpgrade()
<tr>
<td colspan="3" bgcolor="#e7e7e7" height="6"><img src="TRANSPAR.GIF" width="1" height="6" alt="" border="0"></td>
</tr>
-
-
<tr>
<th width="165" height="24">Current Firmware &nbsp; </th>
<td width="409"><img src="TRANSPAR.GIF" width="409" height="6" alt="" border="0"></td>
@@ -93,16 +76,33 @@ function checkUpgrade()
<td width="409"><div class="std"><table border=0 cellspacing=0 cellpadding=4>
<tr>
<td nowrap>Current Firmware Version:</td>
- <td nowrap>@ds_sw_version# </td></tr>
- <tr><td>
- <div align="left"><a href="http://www.linksys.com" target="new_win"><img src="button_checkupdate.jpg" width="107" height="20" alt="" border="0"></a></div>
- </td>
+ <td nowrap>@ds_sw_version# </td>
</tr>
</table></div> </td>
<td width="176" bgcolor="#6666cc"><img border="0" src="../UI_05.gif" height="80" width="15"></td>
</tr>
<tr>
+ <th width="165" height="24">Upgrade &nbsp; </th>
+ <td width="409"><img src="TRANSPAR.GIF" width="409" height="6" alt="" border="0"></td>
+ <td width="176" bgcolor="#6666cc"><img border="0" src="../UI_05.gif" height="24" width="15"></td>
+</tr>
+<tr>
+ <td bgcolor="#e7e7e7" align="right"><img border="0" src="../UI_04.gif" width="8" hspace="0" vspace="0" height="120"></td>
+ <td width="409"><div class="std"><table border=0 cellspacing=0 cellpadding=4>
+ <tr>
+ </tr>
+ <tr>
+<td colspan="2" align="left" class="smsg">
+NOTE: You cannot use this upgrade page to install new firmware on Unslung.
+You must use the Redboot mechanism in order to install new firmware instead.
+</td>
+ </tr>
+ </table></div> </td>
+ <td width="176" bgcolor="#6666cc"><img border="0" src="../UI_05.gif" height="120" width="15"></td>
+</tr>
+
+<tr>
<td bgcolor="#e7e7e7" height="30" align="right"><img border="0" src="../UI_04.gif" width="8" hspace="0" vspace="0" height="30"></td>
<td height="30">&nbsp; </td>
<td rowspan="2" valign="bottom" bgcolor="#6666cc" height="64"><img src="../cisco.gif" hspace="0" vspace="0"></td>
@@ -110,12 +110,10 @@ function checkUpgrade()
<tr>
<td bgcolor="black" height="34">&nbsp; </td>
- <td bgcolor="#6666cc" align="right" height="33" valign="middle"><a class="textbutton" href="javascript:checkUpgrade();" style="{padding:3px}">&nbsp;
- Enter Upgrade Mode&nbsp;</a>&nbsp; <a class="textbutton" href="javascript:openHelpWin('help/util_upg.htm')" style="{padding:3px}">
- Help &nbsp;</a> &nbsp; &nbsp; </td>
+ <td bgcolor="#6666cc" align="right" height="33" valign="middle">
+ &nbsp; &nbsp; </td>
</tr>
-
</table>
</div>
<input type="Hidden" name="message" value="@message#">
@@ -123,7 +121,5 @@ function checkUpgrade()
<input type="Hidden" name="todo" value="@todo#">
<input type="Hidden" name="finish" value="@finish#">
</form>
-
</body>
-
</html>
diff --git a/packages/nslu2-binary-only/unslung-rootfs_2.3r63.bb b/packages/nslu2-binary-only/unslung-rootfs_2.3r63.bb
index 910ad102a9..f105e6830a 100644
--- a/packages/nslu2-binary-only/unslung-rootfs_2.3r63.bb
+++ b/packages/nslu2-binary-only/unslung-rootfs_2.3r63.bb
@@ -1,8 +1,8 @@
SECTION = "base"
-PR = "r11"
+PR = "r12"
-DEPENDS = "nslu2-linksys-libs"
+DEPENDS = "nslu2-linksys-libs nslu2-linksys-sambacodepages"
SRC_URI = "http://nslu.sf.net/downloads/nslu2-linksys-ramdisk-2.3r63-2.tar.bz2 \
file://README \
@@ -43,8 +43,8 @@ SRC_URI = "http://nslu.sf.net/downloads/nslu2-linksys-ramdisk-2.3r63-2.tar.bz2 \
file://mount_usbdevfs.patch;patch=1 \
file://security-fixes.patch;patch=1 \
file://rc.sysinit-clean_var.patch;patch=1 \
+ file://rc.modules-nls.patch;patch=1 \
file://upgrade.htm \
- file://upgrade.cgi \
file://telnet.htm \
file://rc.bootbin \
"
@@ -66,6 +66,7 @@ do_compile () {
install -m 644 ${WORKDIR}/telnet.htm ${S}/home/httpd/html/Management/telnet.htm
sed -i -e 's/@version#</@version#-uNSLUng-'${DISTRO_VERSION}'</' ${S}/home/httpd/html/home.htm
+ install -m 644 ${WORKDIR}/upgrade.htm ${S}/home/httpd/html/Management/upgrade.htm
sed -i -e s/@ds_sw_version#/@ds_sw_version#-uNSLUng-${DISTRO_VERSION}/ \
${S}/home/httpd/html/Management/upgrade.htm
@@ -110,6 +111,38 @@ do_compile () {
# Remove the libraries, because they are in nslu2-linksys-libs now
rm -rf ${S}/lib
+
+ # Remove some unnecessary web stuff to free space
+ rm -f ${S}/home/httpd/html/Management/upgrade.cgi
+ rm -f ${S}/home/httpd/html/Management/upgrade_ui.htm
+ rm -f ${S}/home/httpd/html/Management/upgrade_ui.cgi
+
+ # Remove some of the Samba codepages to make space
+ # These will have to be separately packaged, like the libraries...
+ # 437 (USA) - keep
+ # 737 (Greek)
+ rm -f ${S}/etc/samba/codepages/codepage.737
+ rm -f ${S}/etc/samba/codepages/unicode_map.737
+ # 850 (Latin1) - keep
+ # 852 (Latin2)
+ rm -f ${S}/etc/samba/codepages/codepage.852
+ rm -f ${S}/etc/samba/codepages/unicode_map.852
+ # 861 (Iceland)
+ rm -f ${S}/etc/samba/codepages/codepage.861
+ rm -f ${S}/etc/samba/codepages/unicode_map.861
+ # 866 (Russian)
+ rm -f ${S}/etc/samba/codepages/codepage.866
+ rm -f ${S}/etc/samba/codepages/unicode_map.866
+ # 932 (Japanese Shift-JIS)
+ rm -f ${S}/etc/samba/codepages/codepage.932
+ rm -f ${S}/etc/samba/codepages/unicode_map.932
+ # 936 (Simplified Chinese)
+ rm -f ${S}/etc/samba/codepages/codepage.936
+ # 949 (Korean)
+ rm -f ${S}/etc/samba/codepages/codepage.949
+ # 950 (Chinese BIG-5)
+ rm -f ${S}/etc/samba/codepages/codepage.950
+ # ISO8859-1 (Latin 1) - keep
}
do_install () {