aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ntp
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-10-10 21:34:12 +0000
committerKoen Kooi <koen@openembedded.org>2006-10-10 21:34:12 +0000
commitcf799ae1fa268a365d5030d02a8a36f2e52788c4 (patch)
tree0ba5417de9e5125a60e707d31c2d9c71132b6416 /packages/ntp
parent26b1fd3d708ab07beb8006208497770306dc9331 (diff)
downloadopenembedded-cf799ae1fa268a365d5030d02a8a36f2e52788c4.tar.gz
ntp: fixes
* don't use PACKAGES = "foo", that breaks debug packages * removed bogus looking nylon override * we have an scm, so no need to comment lines * please conform to the styleguide when adding recipes
Diffstat (limited to 'packages/ntp')
-rw-r--r--packages/ntp/ntp_4.2.2p3.bb11
1 files changed, 4 insertions, 7 deletions
diff --git a/packages/ntp/ntp_4.2.2p3.bb b/packages/ntp/ntp_4.2.2p3.bb
index cb6aff272e..886f36253a 100644
--- a/packages/ntp/ntp_4.2.2p3.bb
+++ b/packages/ntp/ntp_4.2.2p3.bb
@@ -25,22 +25,19 @@ inherit autotools update-rc.d
EXTRA_OECONF = "--without-openssl --without-crypto ac_cv_header_readline_history_h=no"
CFLAGS_append = " -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED"
-PACKAGES = "ntpdate ntp-bin ntp ntp-tickadj"
+PACKAGES += "ntpdate ntp-bin ntp-tickadj ntp-utils"
# NOTE: you don't need ntpdate, use "ntpdc -q -g -x"
-PROVIDES = "ntpdate-${PV} ntpdate-${PV}-${PR} ntpdate"
# This should use rc.update
FILES_ntpdate = "${bindir}/ntpdate ${sysconfdir}/init.d/ntpdate"
-#This is too painful - perl is only needed for ntp-wait and ntptrace, which are
-#perl scripts, and installing perl is an enormous overhead for a user who only
-#needs ntpq
-#RDEPENDS_ntp-bin = perl
+
# ntp originally includes tickadj. It's split off for inclusion in small firmware images on platforms
# with wonky clocks (e.g. OpenSlug)
RDEPENDS_${PN} = ${PN}-tickadj
FILES_${PN}-bin = "${bindir}/ntp-wait ${bindir}/ntpdc ${bindir}/ntpq ${bindir}/ntptime ${bindir}/ntptrace"
FILES_${PN} = "${bindir}/ntpd ${sysconfdir}/ntp.conf ${sysconfdir}/init.d/ntpd"
FILES_${PN}-tickadj = "${bindir}/tickadj"
+FILES_ntp-utils = "${bindir}/*"
do_install_append() {
install -d ${D}/${sysconfdir}/init.d
@@ -49,7 +46,7 @@ do_install_append() {
install -m 755 ${WORKDIR}/ntpd ${D}/${sysconfdir}/init.d
}
-pkg_postinst_ntpdate_nylon() {
+pkg_postinst_ntpdate() {
if test "x$D" != "x"; then
exit 1
else