aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ntp
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2005-11-15 10:57:45 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-11-15 10:57:45 +0000
commit4517a7f078a24c3af19cf5e43098882ba3028171 (patch)
treed7ed197ed6b1cd48641a7a2f54ed357c90892730 /packages/ntp
parent1c3a109402522ea3f1cc0b5da98c3341eb412128 (diff)
downloadopenembedded-4517a7f078a24c3af19cf5e43098882ba3028171.tar.gz
ntp 4.2.0: fixed build problem with gcc 4.x
Diffstat (limited to 'packages/ntp')
-rw-r--r--packages/ntp/files/gcc4.patch46
-rw-r--r--packages/ntp/ntp_4.2.0.bb3
2 files changed, 48 insertions, 1 deletions
diff --git a/packages/ntp/files/gcc4.patch b/packages/ntp/files/gcc4.patch
new file mode 100644
index 0000000000..469d914e17
--- /dev/null
+++ b/packages/ntp/files/gcc4.patch
@@ -0,0 +1,46 @@
+Patch taken from Debian: http://bugs.debian.org/298697
+------------------------------------------------------------------------
+With the attached patch 'ntp' can be compiled
+on amd64 using gcc-4.0.
+
+The attached patch also changes the Build-Depends from libreadline4-dev
+to libreadline5-dev.
+
+Regards
+Andreas Jochens
+
+diff -urN ../tmp-orig/ntp-4.2.0a+stable/include/ntp_stdlib.h ./include/ntp_stdlib.h
+--- ../tmp-orig/ntp-4.2.0a+stable/include/ntp_stdlib.h 2003-05-04 16:50:25.000000000 +0200
++++ ./include/ntp_stdlib.h 2005-03-09 12:59:45.000000000 +0100
+@@ -135,7 +135,7 @@
+
+ /* clocktypes.c */
+ struct clktype;
+-extern struct clktype clktypes[];
++extern struct clktype *clktypes;
+
+ /* getopt.c */
+ extern char * ntp_optarg; /* global argument pointer */
+diff -urN ../tmp-orig/ntp-4.2.0a+stable/include/ntpd.h ./include/ntpd.h
+--- ../tmp-orig/ntp-4.2.0a+stable/include/ntpd.h 2004-05-04 07:01:25.000000000 +0200
++++ ./include/ntpd.h 2005-03-09 12:56:03.000000000 +0100
+@@ -226,7 +226,6 @@
+
+ /* ntp_control.c */
+ struct ctl_trap;
+-extern struct ctl_trap ctl_trap[];
+ extern int num_ctl_traps;
+ extern keyid_t ctl_auth_keyid; /* keyid used for authenticating write requests */
+
+diff -urN ../tmp-orig/ntp-4.2.0a+stable/libntp/clocktypes.c ./libntp/clocktypes.c
+--- ../tmp-orig/ntp-4.2.0a+stable/libntp/clocktypes.c 2002-07-19 19:15:54.000000000 +0200
++++ ./libntp/clocktypes.c 2005-03-09 13:05:42.000000000 +0100
+@@ -9,7 +9,7 @@
+ #include "ntp_refclock.h"
+ #include "ntp_stdlib.h"
+
+-struct clktype clktypes[] = {
++struct clktype *clktypes = {
+ { REFCLK_NONE, "unspecified type (0)",
+ "UNKNOWN" },
+ { REFCLK_LOCALCLOCK, "Undisciplined local clock (1)",
diff --git a/packages/ntp/ntp_4.2.0.bb b/packages/ntp/ntp_4.2.0.bb
index 817c3c32f7..f59df25ec5 100644
--- a/packages/ntp/ntp_4.2.0.bb
+++ b/packages/ntp/ntp_4.2.0.bb
@@ -6,10 +6,11 @@ HOMEPAGE = "http://ntp.isc.org/bin/view/Main/WebHome"
SECTION = "console/network"
PRIORITY = "optional"
LICENSE = "ntp"
-PR = "r4"
+PR = "r5"
SRC_URI = "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/${P}.tar.gz \
file://ntpdc.Makefile.am.maybe-layout.patch;patch=1 \
+ file://gcc4.patch;patch=1 \
file://ntpd \
file://ntp.conf \
file://ntpdate"