aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ntp
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-01 00:40:07 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-01 00:40:07 +0000
commit8da895599110003a11469d92c29074e4d21f4010 (patch)
tree27f868956b6f5c714026616d043abc68b9c2b64f /packages/ntp
parent00590e39668c11f13f315683c6a3435d768b1322 (diff)
downloadopenembedded-8da895599110003a11469d92c29074e4d21f4010.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/01/01 00:25:17+00:00 nexus.co.uk!pb split out some esoteric pcmcia-cs stuff into separate packages 2005/01/01 00:22:26+00:00 nexus.co.uk!pb Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into stealth.nexus.co.uk:/home/pb/oe/oe 2005/01/01 00:18:09+00:00 nexus.co.uk!pb patch ntp to only use -lreadline with executables that actually need it, so that ntpdate doesn't drag readline and ncurses into handheld rootfs. BKrev: 41d5f167yzLSvdvx8KMhVpa3w3BDXQ
Diffstat (limited to 'packages/ntp')
-rw-r--r--packages/ntp/files/readline.patch0
-rw-r--r--packages/ntp/ntp-ssl_4.1.2.bb30
-rw-r--r--packages/ntp/ntp_4.1.2.bb28
3 files changed, 58 insertions, 0 deletions
diff --git a/packages/ntp/files/readline.patch b/packages/ntp/files/readline.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/ntp/files/readline.patch
diff --git a/packages/ntp/ntp-ssl_4.1.2.bb b/packages/ntp/ntp-ssl_4.1.2.bb
index e69de29bb2..937a0e20a4 100644
--- a/packages/ntp/ntp-ssl_4.1.2.bb
+++ b/packages/ntp/ntp-ssl_4.1.2.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "The Network Time Protocol (NTP) is used to \
+synchronize the time of a computer client or server to \
+another server or reference time source, such as a radio \
+or satellite receiver or modem."
+SECTION = "console/network"
+PRIORITY = "optional"
+DEPENDS = "openssl"
+LICENSE = "NTP"
+PR = "r1"
+
+SRC_URI = "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-${PV}.tar.gz \
+ file://configure.patch;patch=1 \
+ file://readline.patch;patch=1 \
+ file://ntpdate"
+S = "${WORKDIR}/ntp-${PV}"
+
+inherit autotools
+
+EXTRA_OECONF = "--with-openssl-libdir=${STAGING_LIBDIR} \
+ --with-openssl-incdir=${STAGING_INCDIR}/openssl"
+CFLAGS_append = " -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED"
+
+PACKAGES = "ntpdate ntp"
+
+FILES_ntpdate = "/usr/bin/ntpdate /etc/init.d/ntpdate"
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}/init.d
+ install -m 755 ${WORKDIR}/ntpdate ${D}/${sysconfdir}/init.d
+}
diff --git a/packages/ntp/ntp_4.1.2.bb b/packages/ntp/ntp_4.1.2.bb
index e69de29bb2..97bd23b196 100644
--- a/packages/ntp/ntp_4.1.2.bb
+++ b/packages/ntp/ntp_4.1.2.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "The Network Time Protocol (NTP) is used to \
+synchronize the time of a computer client or server to \
+another server or reference time source, such as a radio \
+or satellite receiver or modem."
+HOMEPAGE = "http://ntp.isc.org/bin/view/Main/WebHome"
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "ntp"
+PR = "r1"
+
+SRC_URI = "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-${PV}.tar.gz \
+ file://configure.patch;patch=1 \
+ file://readline.patch;patch=1 \
+ file://ntpdate"
+
+inherit autotools
+
+EXTRA_OECONF = "--without-openssl"
+CFLAGS_append = " -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED"
+
+PACKAGES = "ntpdate ntp"
+
+FILES_ntpdate = "/usr/bin/ntpdate /etc/init.d/ntpdate"
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}/init.d
+ install -m 755 ${WORKDIR}/ntpdate ${D}/${sysconfdir}/init.d
+}