aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ntp
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2005-11-15 17:46:57 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-11-15 17:46:57 +0000
commitef17342f3996aeb72e9d7b7c095a85c16a030330 (patch)
treee7ba8b3e384e623562b1ba0d63fb314e83d65de9 /packages/ntp
parentf6cb11d26ea5ee3cb9f6b4b43d7fbb304f4ab290 (diff)
downloadopenembedded-ef17342f3996aeb72e9d7b7c095a85c16a030330.tar.gz
ntp 4.2.0: added workaround for IPv6 problem on 2.4.18 machines
- according to http://bugs.debian.org/249216 problem exist in kernels older then 2.4.26 - quote: "It's a kernel bug. Returns an AF_INET6 socket, but IPV6_V6ONLY fails. There may be a way to work-around it in ntpdate, but the correct answer is to upgrade the kernel." Behaviour without that changeset: # ntpdate time.apple.com ntpdate[25796]: setsockopt() IPV6_V6ONLY failed: Protocol not available removing ipv6 kernel module helps but it is not a resolution
Diffstat (limited to 'packages/ntp')
-rw-r--r--packages/ntp/files/ipv6only-workaround.patch13
-rw-r--r--packages/ntp/ntp_4.2.0.bb3
2 files changed, 15 insertions, 1 deletions
diff --git a/packages/ntp/files/ipv6only-workaround.patch b/packages/ntp/files/ipv6only-workaround.patch
new file mode 100644
index 0000000000..998d2bdad9
--- /dev/null
+++ b/packages/ntp/files/ipv6only-workaround.patch
@@ -0,0 +1,13 @@
+Patch taken from Debian: http://bugs.debian.org/249216
+------------------------------------------------------------------------
+--- ntp-4.2.0/ntpdate/ntpdate.c~ipv6only-workaround
++++ ntp-4.2.0/ntpdate/ntpdate.c
+@@ -1698,8 +1698,6 @@
+ if (res->ai_family == AF_INET6)
+ if (setsockopt(fd[nbsock], IPPROTO_IPV6, IPV6_V6ONLY, (void*) &optval, sizeof(optval)) < 0) {
+ netsyslog(LOG_ERR, "setsockopt() IPV6_V6ONLY failed: %m");
+- exit(1);
+- /*NOTREACHED*/
+ }
+ #endif
+
diff --git a/packages/ntp/ntp_4.2.0.bb b/packages/ntp/ntp_4.2.0.bb
index f59df25ec5..5f4c2a8262 100644
--- a/packages/ntp/ntp_4.2.0.bb
+++ b/packages/ntp/ntp_4.2.0.bb
@@ -6,11 +6,12 @@ HOMEPAGE = "http://ntp.isc.org/bin/view/Main/WebHome"
SECTION = "console/network"
PRIORITY = "optional"
LICENSE = "ntp"
-PR = "r5"
+PR = "r6"
SRC_URI = "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/${P}.tar.gz \
file://ntpdc.Makefile.am.maybe-layout.patch;patch=1 \
file://gcc4.patch;patch=1 \
+ file://ipv6only-workaround.patch;patch=1 \
file://ntpd \
file://ntp.conf \
file://ntpdate"