aboutsummaryrefslogtreecommitdiffstats
path: root/packages/nunome
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2007-05-29 00:04:48 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2007-05-29 00:04:48 +0000
commitd3e661042f818b9cd813ba54b9e6a978fa66c896 (patch)
treef755bc21eb114a48189d5b78d69ec399fcf08899 /packages/nunome
parent0cbfc641fae9473f7dcc4a92d7ab398b2f01ffea (diff)
downloadopenembedded-d3e661042f818b9cd813ba54b9e6a978fa66c896.tar.gz
nunome: fix non-working nunome on spitz/Angstrom
* Thanks to polyonymous for providing the patch * fixes access to the timer object before allocating it
Diffstat (limited to 'packages/nunome')
-rw-r--r--packages/nunome/files/timer.patch21
-rw-r--r--packages/nunome/nunome_1.0.2.bb4
2 files changed, 24 insertions, 1 deletions
diff --git a/packages/nunome/files/timer.patch b/packages/nunome/files/timer.patch
new file mode 100644
index 0000000000..ccd65647be
--- /dev/null
+++ b/packages/nunome/files/timer.patch
@@ -0,0 +1,21 @@
+diff --git a/ui/nnmCanvas.cpp b/ui/nnmCanvas.cpp
+index a548ddf..3b8e7d4 100755
+--- a/ui/nnmCanvas.cpp
++++ b/ui/nnmCanvas.cpp
+@@ -35,7 +35,7 @@
+
+ nnmCanvas::nnmCanvas( QWidget *parent, int timeoutParam, int initID,
+ const char *name, WFlags f )
+- : QWidget( parent, name, f )
++ : QWidget( parent, name, f ), timer(0)
+ {
+ setFixedSize( NnmCANVAS_DISPLAY_SIZE, NnmCANVAS_DISPLAY_SIZE );
+ init();
+@@ -149,7 +149,7 @@ void nnmCanvas::resizeEvent( QResizeEvent *event )
+
+ void nnmCanvas::init( void )
+ {
+- if ( timeoutMsec > 0 && timer->isActive() ) {
++ if ( timeoutMsec > 0 && timer && timer->isActive() ) {
+ timer->stop();
+ } \ No newline at end of file
diff --git a/packages/nunome/nunome_1.0.2.bb b/packages/nunome/nunome_1.0.2.bb
index ae29277291..0401c195e0 100644
--- a/packages/nunome/nunome_1.0.2.bb
+++ b/packages/nunome/nunome_1.0.2.bb
@@ -1,11 +1,13 @@
DESCRIPTION = "Japanese input method plugin"
+HOMEPAGE = "http://www.sikigami.com/nunome-Qtopia-1.0/"
SECTION = "opie/inputmethods"
PRIORITY = "optional"
LICENSE = "GPL"
-HOMEPAGE = "http://www.sikigami.com/nunome-Qtopia-1.0/"
RDEPENDS = "virtual/japanese-font"
+PR = "r1"
SRC_URI = "${SOURCEFORGE_MIRROR}/gakusei/nunome-${PV}.tar.bz2 \
+ file://timer.patch;patch=1 \
file://nunome.patch;patch=1"
S = "${WORKDIR}/nunome"