aboutsummaryrefslogtreecommitdiffstats
path: root/packages/nxproxy
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2008-09-06 12:01:09 +0000
committerHenning Heinold <heinold@inf.fu-berlin.de>2008-09-06 12:01:09 +0000
commit2c6f4b857c2742fc7aae63fa78ebe81d044439e8 (patch)
treec1fa64ad4692b01d1c077010582f0cd2f23732d0 /packages/nxproxy
parent04353b67d3e6208a51e17a5290b469497aed81bc (diff)
downloadopenembedded-2c6f4b857c2742fc7aae63fa78ebe81d044439e8.tar.gz
nproxy: import nxproxy to openembedded
* nxproxy this binary linked against libxcomp, which controls a remote or local connection to the nxserver * stdin.patch taken from debian, original posted by Fabian Franz * second step for nx-client support in oe
Diffstat (limited to 'packages/nxproxy')
-rw-r--r--packages/nxproxy/.mtn2git_empty0
-rw-r--r--packages/nxproxy/files/.mtn2git_empty0
-rw-r--r--packages/nxproxy/files/stdin.patch73
-rw-r--r--packages/nxproxy/nxproxy_3.2.0-1.bb18
4 files changed, 91 insertions, 0 deletions
diff --git a/packages/nxproxy/.mtn2git_empty b/packages/nxproxy/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/nxproxy/.mtn2git_empty
diff --git a/packages/nxproxy/files/.mtn2git_empty b/packages/nxproxy/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/nxproxy/files/.mtn2git_empty
diff --git a/packages/nxproxy/files/stdin.patch b/packages/nxproxy/files/stdin.patch
new file mode 100644
index 0000000000..20c71dbf76
--- /dev/null
+++ b/packages/nxproxy/files/stdin.patch
@@ -0,0 +1,73 @@
+Patch taken from the debian unstable package
+original posted by Fabian Franz on the freenx mailinglist
+
+
+Index: nxproxy/Main.c
+--- nxproxy/Main.c.old 2007-07-18 17:39:13.000000000 +0200
++++ nxproxy/Main.c 2008-03-12 04:40:30.000000000 +0100
+@@ -36,28 +36,48 @@
+ int result = -1;
+
+ char *options = NULL;
+-
++
++ char *nx_commfd_str = NULL;
++
+ options = getenv("NX_DISPLAY");
+-
+- if (NXTransParseCommandLine(argc, argv) < 0)
++
++ if ((nx_commfd_str = getenv("NX_COMMFD")) != NULL)
+ {
+- NXTransCleanup();
+- }
++ int nx_commfd = atoi(nx_commfd_str);
+
+- if (NXTransParseEnvironment(options, 0) < 0)
+- {
+- NXTransCleanup();
++ if (result)
++ result = NXTransCreate(nx_commfd, NX_MODE_SERVER, options);
++
++ // go into endless loop
++
++ if (result)
++ {
++ while (NXTransRunning(NX_FD_ANY))
++ result = NXTransContinue(NULL);
++ }
+ }
++ else
++ {
++ if (NXTransParseCommandLine(argc, argv) < 0)
++ {
++ NXTransCleanup();
++ }
++
++ if (NXTransParseEnvironment(options, 0) < 0)
++ {
++ NXTransCleanup();
++ }
++
++ /*
++ * This should not return...
++ */
++
++ #ifdef TEST
++ fprintf(stderr, "Main: Yielding control to NX entry point.\n");
++ #endif
+
+- /*
+- * This should not return...
+- */
+-
+- #ifdef TEST
+- fprintf(stderr, "Main: Yielding control to NX entry point.\n");
+- #endif
+-
+- result = NXTransProxy(NX_FD_ANY, NX_MODE_ANY, NX_DISPLAY_ANY);
++ result = NXTransProxy(NX_FD_ANY, NX_MODE_ANY, NX_DISPLAY_ANY);
++ }
+
+ /*
+ * ...So these should not be called.
diff --git a/packages/nxproxy/nxproxy_3.2.0-1.bb b/packages/nxproxy/nxproxy_3.2.0-1.bb
new file mode 100644
index 0000000000..162945f0d3
--- /dev/null
+++ b/packages/nxproxy/nxproxy_3.2.0-1.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "The binary which uses libxcomp from nomachine"
+HOMEPAGE = "http://www.nomachine.com/"
+LICENSE = "GPL"
+PR = "r0"
+
+DEPENDS = "libxcomp"
+
+SRC_URI = "http://64.34.161.181/download/3.2.0/sources/${PN}-${PV}.tar.gz \
+ file://stdin.patch;patch=1 \
+ "
+inherit autotools
+
+S = "${WORKDIR}/nxproxy"
+
+do_install () {
+ install -d ${D}${bindir}/
+ install -s -m 0644 nxproxy ${D}${bindir}/
+}