aboutsummaryrefslogtreecommitdiffstats
path: root/packages/obexftp
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2008-06-23 18:52:40 +0000
committerHenning Heinold <heinold@inf.fu-berlin.de>2008-06-23 18:52:40 +0000
commitd13aaf28ed9939c0d7dd7d282c8e91e709ef430a (patch)
treee4585e26e1fb37a5ad8087a9a5f1834e8aad9d86 /packages/obexftp
parent9937a368e65f87366194bb5fe516bd38a3c0969a (diff)
downloadopenembedded-d13aaf28ed9939c0d7dd7d282c8e91e709ef430a.tar.gz
obexftp: update to version 0.22
* libgsm code is now in another package * adjust DEPENDS
Diffstat (limited to 'packages/obexftp')
-rw-r--r--packages/obexftp/obexftp_0.20.bb8
-rw-r--r--packages/obexftp/obexftp_0.22.bb30
2 files changed, 34 insertions, 4 deletions
diff --git a/packages/obexftp/obexftp_0.20.bb b/packages/obexftp/obexftp_0.20.bb
index 386e83d6dc..2a0b310a49 100644
--- a/packages/obexftp/obexftp_0.20.bb
+++ b/packages/obexftp/obexftp_0.20.bb
@@ -2,17 +2,17 @@ DESCRIPTION = "OBEX Ftp Client based on openobex."
SECTION = "console/network"
HOMEPAGE = "http://openobex.triq.net"
LICENSE = "GPL"
-DEPENDS = "openobex libgsm virtual/libiconv"
-PR = "r3"
+DEPENDS = "openobex libgsm"
+PR = "r4"
SRC_URI = "${SOURCEFORGE_MIRROR}/openobex/obexftp-${PV}.tar.gz \
file://iconv.patch;patch=1 \
file://i-hate-libtool.patch;patch=1 \
file://m4.patch;patch=1"
-inherit autotools
+inherit autotools gettext
-EXTRA_OECONF = "--enable-bluetooth --disable-swig --disable-perl --disable-python --disable-tcl --disable-builddocs"
+EXTRA_OECONF += "--enable-bluetooth --disable-swig --disable-perl --disable-python --disable-tcl --disable-builddocs --disable-rpath"
PARALLEL_MAKE = ""
diff --git a/packages/obexftp/obexftp_0.22.bb b/packages/obexftp/obexftp_0.22.bb
new file mode 100644
index 0000000000..89e10a72af
--- /dev/null
+++ b/packages/obexftp/obexftp_0.22.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "OBEX Ftp Client based on openobex."
+SECTION = "console/network"
+HOMEPAGE = "http://dev.zuckschwerdt.org/openobex/wiki/ObexFtp"
+LICENSE = "GPL"
+DEPENDS = "openobex bluez-libs libusb virtual/libiconv"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/openobex/obexftp-${PV}.tar.bz2 \
+ "
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF += "--enable-bluetooth \
+ --disable-swig \
+ --disable-perl \
+ --disable-python \
+ --disable-tcl \
+ --disable-ruby \
+ --disable-builddocs \
+ --disable-rpath \
+ "
+
+PARALLEL_MAKE = ""
+
+LEAD_SONAME = "libobexftp.so"
+
+do_stage() {
+ autotools_stage_all
+}
+