aboutsummaryrefslogtreecommitdiffstats
path: root/packages/obexpush
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-08-21 22:16:21 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-21 22:16:21 +0000
commit58960b40d7be51c5c696ba61ae9301ebb4b86be7 (patch)
tree46d04d504d45ba017846f8f001b4c370fa317450 /packages/obexpush
parent6080734a11b136ea0f4275959c9d3a1ab6eb6f61 (diff)
downloadopenembedded-58960b40d7be51c5c696ba61ae9301ebb4b86be7.tar.gz
add OBEX Push command line helpers
Diffstat (limited to 'packages/obexpush')
-rw-r--r--packages/obexpush/.mtn2git_empty0
-rw-r--r--packages/obexpush/files/.mtn2git_empty0
-rw-r--r--packages/obexpush/files/init29
-rw-r--r--packages/obexpush/obexpush_1.0.0.bb41
4 files changed, 70 insertions, 0 deletions
diff --git a/packages/obexpush/.mtn2git_empty b/packages/obexpush/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/obexpush/.mtn2git_empty
diff --git a/packages/obexpush/files/.mtn2git_empty b/packages/obexpush/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/obexpush/files/.mtn2git_empty
diff --git a/packages/obexpush/files/init b/packages/obexpush/files/init
new file mode 100644
index 0000000000..ac1fd62ead
--- /dev/null
+++ b/packages/obexpush/files/init
@@ -0,0 +1,29 @@
+#!/bin/sh
+#
+# /etc/init.d/obd: start or stop the OBEX Push helper daemon
+#
+
+PARAMS="--mode OBEX --channel 10 --path /tmp/opd --sdp --metadata"
+
+case "$1" in
+ start)
+ echo -n "Starting OBEX Push helper: opd"
+ opd $PARAMS &
+ ;;
+ stop)
+ echo -n "Shutting down OBEX Push helper: opd"
+ killall opd
+ ;;
+ restart|force-reload)
+ echo -n "Restarting OBEX Push helper: opd"
+ killall opd
+ sleep 2
+ obd $PARAMS &
+ ;;
+ *)
+ echo "Usage: /etc/init.d/obd {start|stop|restart|force-reload}"
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/packages/obexpush/obexpush_1.0.0.bb b/packages/obexpush/obexpush_1.0.0.bb
new file mode 100644
index 0000000000..97e2049108
--- /dev/null
+++ b/packages/obexpush/obexpush_1.0.0.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "Obex Push Utilities"
+HOMEPAGE = "http://www.caside.lancs.ac.uk/java_bt.php"
+SECTION = "console/network"
+LICENSE = "GPL"
+DEPENDS = "glib-2.0 openobex"
+
+SRC_URI = "http://www.caside.lancs.ac.uk/bt/obexpush.tar.gz \
+ file://init"
+S = "${WORKDIR}/obexpush"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "opd"
+INITSCRIPT_PARAMS = "defaults 33 09"
+
+export GLIBINC=-I${STAGING_INCDIR}/glib-2.0
+export GLIBLIB=-I${STAGING_LIBDIR} -lglib-2.0
+export OBEXINC=-I${STAGING_INCDIR}
+export OBEXLIB=-L${STAGING_LIBDIR} -lopenobex
+
+do_configure() {
+ rm -f client/*.o client/ussp-push
+ rm -f opd/*.o opd/opd
+ sed -i 's:gcc:${CC}:' */Makefile
+ sed -i 's:__FUNCTION__::' opd/*.c
+}
+
+do_compile() {
+ oe_runmake -C client
+ oe_runmake -C opd
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 client/ussp-push ${D}${bindir}
+ install -m 0755 opd/opd ${D}${bindir}
+
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0644 ${WORKDIR}/init ${D}${sysconfdir}/init.d/opd
+}
+