aboutsummaryrefslogtreecommitdiffstats
path: root/packages/omniorb
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2006-11-20 21:54:23 +0000
committerPhilip Balister <philip@balister.org>2006-11-20 21:54:23 +0000
commit7f26c89b330705cbfb428f89df94c7879667af72 (patch)
tree9974358f9ae343b8e7e744fd7629be32302e24d7 /packages/omniorb
parent5229146f37c75353e7ee976db3113d743ac562d3 (diff)
downloadopenembedded-7f26c89b330705cbfb428f89df94c7879667af72.tar.gz
omniorb, omniorb-native : Fix bb file syntax and style.
Diffstat (limited to 'packages/omniorb')
-rw-r--r--packages/omniorb/omniorb-native_4.0.7.bb20
-rw-r--r--packages/omniorb/omniorb_4.0.7.bb29
2 files changed, 19 insertions, 30 deletions
diff --git a/packages/omniorb/omniorb-native_4.0.7.bb b/packages/omniorb/omniorb-native_4.0.7.bb
index 4f3a815380..b8a2e40395 100644
--- a/packages/omniorb/omniorb-native_4.0.7.bb
+++ b/packages/omniorb/omniorb-native_4.0.7.bb
@@ -1,26 +1,18 @@
+SECTION = "devel"
+DEPENDS += "python-native"
PR = "r0"
+
SRC_URI = "${SOURCEFORGE_MIRROR}/omniorb/omniORB-${PV}.tar.gz"
-SECTION = "devel"
-S = "${WORKDIR}/omniORB-${PV}"
-DEPENDS += "python-native"
+S = "${WORKDIR}/omniORB-${PV}"
inherit native autotools
do_compile () {
- oe_runmake
+ oe_runmake
}
-
# Ugly hack so libtool does not find native libs when building cross packages
# We really only build this package for omniidl anyway
do_stage_append() {
- rm -f ${STAGING_DIR}/${BUILD_SYS}/lib/libomni*
+ rm -f ${STAGING_DIR}/${BUILD_SYS}/lib/libomni*
}
-
-#do_stage() {
-# install -m 0755 src/bison ${STAGING_BINDIR}/
-# ln -sf ./bison ${STAGING_BINDIR}/yacc
-# install -d ${STAGING_BINDIR}/../share/bison/m4sugar
-# install -m 0755 data/c.m4 data/glr.c data/lalr1.cc data/yacc.c ${STAGING_BINDIR}/../share/bison/
-# install -m 0755 data/m4sugar/m4sugar.m4 ${STAGING_BINDIR}/../share/bison/m4sugar/
-#}
diff --git a/packages/omniorb/omniorb_4.0.7.bb b/packages/omniorb/omniorb_4.0.7.bb
index d9094926b2..d475b22791 100644
--- a/packages/omniorb/omniorb_4.0.7.bb
+++ b/packages/omniorb/omniorb_4.0.7.bb
@@ -1,10 +1,9 @@
-PR = "r0"
DESCRIPTION = "OmniORB High Performance ORB"
SECTION = "devel"
PRIORITY = "optional"
LICENSE = "LGPL"
-
DEPENDS = "omniorb-native"
+PR = "r0"
SRC_URI = "${SOURCEFORGE_MIRROR}/omniorb/omniORB-${PV}.tar.gz \
file://omniORB.cfg \
@@ -19,20 +18,18 @@ S = "${WORKDIR}/omniORB-${PV}"
inherit autotools pkgconfig
do_compile () {
- export EmbeddedSystem=1
- export TOOLBINDIR=${STAGING_BINDIR}
- oe_runmake
+ export EmbeddedSystem=1
+ export TOOLBINDIR=${STAGING_BINDIR}
+ oe_runmake
}
-
-do_stage () {
- export EmbeddedSystem=1
- autotools_stage_all
-}
-
do_install () {
- export EmbeddedSystem=1
- make DESTDIR=${D} install
- install -d ${D}${sysconfdir}
- install -m 0644 ${WORKDIR}/omniORB.cfg ${D}${sysconfdir}
- install -d ${D}${localstatedir}/omninames
+ export EmbeddedSystem=1
+ make DESTDIR=${D} install
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/omniORB.cfg ${D}${sysconfdir}
+ install -d ${D}${localstatedir}/omninames
+}
+do_stage () {
+ export EmbeddedSystem=1
+ autotools_stage_all
}