aboutsummaryrefslogtreecommitdiffstats
path: root/packages/openal
diff options
context:
space:
mode:
authorPhilipp Zabel <philipp.zabel@gmail.com>2007-09-22 17:43:32 +0000
committerPhilipp Zabel <philipp.zabel@gmail.com>2007-09-22 17:43:32 +0000
commit55b129fae9aab286288280807ed9891ad6aa394f (patch)
tree4c403e958df9ec2ceeff752324c8735f874219b4 /packages/openal
parentb06f83e691674ac1bfd5ab01281e83a3cfa6dae5 (diff)
downloadopenembedded-55b129fae9aab286288280807ed9891ad6aa394f.tar.gz
openal: add void workaround, otherwise gcc 4.2.1 doesn't want to compile
anything including alc.h
Diffstat (limited to 'packages/openal')
-rw-r--r--packages/openal/files/.mtn2git_empty0
-rw-r--r--packages/openal/files/void-workaround.patch13
-rw-r--r--packages/openal/openal_0.0.8.bb15
3 files changed, 22 insertions, 6 deletions
diff --git a/packages/openal/files/.mtn2git_empty b/packages/openal/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/openal/files/.mtn2git_empty
diff --git a/packages/openal/files/void-workaround.patch b/packages/openal/files/void-workaround.patch
new file mode 100644
index 0000000000..c2698a95bb
--- /dev/null
+++ b/packages/openal/files/void-workaround.patch
@@ -0,0 +1,13 @@
+Index: openal-0.0.8/common/include/AL/alc.h
+===================================================================
+--- openal-0.0.8.orig/common/include/AL/alc.h 2007-09-22 19:40:47.000000000 +0200
++++ openal-0.0.8/common/include/AL/alc.h 2007-09-22 19:41:04.000000000 +0200
+@@ -82,7 +82,7 @@
+ typedef double ALCdouble;
+
+ /** void type (for opaque pointers only) */
+-typedef void ALCvoid;
++#define ALCvoid void
+
+
+ /* Enumerant values begin at column 50. No tabs. */
diff --git a/packages/openal/openal_0.0.8.bb b/packages/openal/openal_0.0.8.bb
index b77e885c7a..280c5d75e8 100644
--- a/packages/openal/openal_0.0.8.bb
+++ b/packages/openal/openal_0.0.8.bb
@@ -1,17 +1,14 @@
DESCRIPTION = "OpenAL is a cross-platform 3D audio API."
-SRC_URI = "http://www.openal.org/openal_webstf/downloads/${PN}-${PV}.tar.gz"
DEPENDS = "alsa-lib virtual/libsdl libvorbis"
+SRC_URI = "http://www.openal.org/openal_webstf/downloads/${PN}-${PV}.tar.gz \
+ file://void-workaround.patch"
+
inherit autotools pkgconfig
EXTRA_OECONF = "--enable-alsa --enable-sdl --enable-vorbis --disable-mp3 \
--disable-smpeg --disable-arts"
-PACKAGES =+ "libopenal"
-FILES_libopenal += "${libdir}/libopenal.so.*"
-FILES_openal-dev += "${bindir}/openal-config"
-FILES_openal = ""
-
do_configure_append () {
sed -i "s/@requirements@/alsa vorbis/" admin/pkgconfig/openal.pc
}
@@ -19,3 +16,9 @@ do_configure_append () {
do_stage () {
autotools_stage_all
}
+
+PACKAGES =+ "libopenal"
+
+FILES_libopenal += "${libdir}/libopenal.so.*"
+FILES_openal-dev += "${bindir}/openal-config"
+FILES_openal = ""